summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-10-15 21:29:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-10-15 21:29:31 +0000
commit4ac0f54fb4ee8123184d30c3285f8440d7c2ad82 (patch)
tree3a2690d1972a1a978505a4ef6dbc296eef4231a0 /app-text/xpdf
parentversion bump (diff)
downloadhistorical-4ac0f54fb4ee8123184d30c3285f8440d7c2ad82.tar.gz
historical-4ac0f54fb4ee8123184d30c3285f8440d7c2ad82.tar.bz2
historical-4ac0f54fb4ee8123184d30c3285f8440d7c2ad82.zip
version bump
Diffstat (limited to 'app-text/xpdf')
-rw-r--r--app-text/xpdf/Manifest4
-rw-r--r--app-text/xpdf/files/digest-xpdf-2.031
-rw-r--r--app-text/xpdf/xpdf-2.03.ebuild50
3 files changed, 53 insertions, 2 deletions
diff --git a/app-text/xpdf/Manifest b/app-text/xpdf/Manifest
index 21febc5e4e7d..231f7dbcadef 100644
--- a/app-text/xpdf/Manifest
+++ b/app-text/xpdf/Manifest
@@ -1,7 +1,7 @@
MD5 9990618639ab58d3d8eee2d953f91681 xpdf-2.02.ebuild 1104
MD5 ff0d02db927c6afbf354f74c1a376b5c xpdf-2.02.1.ebuild 1152
-MD5 ff0d02db927c6afbf354f74c1a376b5c xpdf-2.03.ebuild 1152
-MD5 b183976f8146c4c963ba35fbb3848531 ChangeLog 2675
+MD5 6210d352a550fa0d3c0ea5bcbb70f2dd xpdf-2.03.ebuild 1160
+MD5 2758b4f7d6ed394778f0ba40da68ed21 ChangeLog 2790
MD5 e231c3f77b475fdbe1307694e55e8542 files/digest-xpdf-2.02 61
MD5 87cd94ef77a9e99ca1fac42c32270d39 files/digest-xpdf-2.03 61
MD5 7c0787e730fecfb5b6ebc5a7a69cd64e files/xpdfrc 1092
diff --git a/app-text/xpdf/files/digest-xpdf-2.03 b/app-text/xpdf/files/digest-xpdf-2.03
new file mode 100644
index 000000000000..04a701d7e4e5
--- /dev/null
+++ b/app-text/xpdf/files/digest-xpdf-2.03
@@ -0,0 +1 @@
+MD5 2bb849c4f525c5fd451f900974f1587c xpdf-2.03.tar.gz 501007
diff --git a/app-text/xpdf/xpdf-2.03.ebuild b/app-text/xpdf/xpdf-2.03.ebuild
new file mode 100644
index 000000000000..cfc704d94be2
--- /dev/null
+++ b/app-text/xpdf/xpdf-2.03.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-2.03.ebuild,v 1.1 2003/10/15 21:29:29 seemant Exp $
+
+IUSE="motif"
+
+MY_PV=${PV/.1/pl1}
+
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="An X Viewer for PDF Files"
+HOMEPAGE="http://www.foolabs.com/xpdf/xpdf.html"
+SRC_URI="ftp://ftp.foolabs.com/pub/xpdf/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64 ~ia64"
+
+DEPEND="motif? ( virtual/x11
+ virtual/motif )
+ >=media-libs/freetype-2.0.5
+ >=media-libs/t1lib-1.3
+ app-text/ghostscript"
+
+src_compile() {
+ econf \
+ --enable-freetype2 \
+ --with-freetype2-includes=/usr/include/freetype2 \
+ --with-gzip || die
+
+ make ${MAKEOPTS} || die
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die
+ prepallman
+ dodoc README ANNOUNCE CHANGES
+ insinto /etc
+ doins ${FILESDIR}/xpdfrc
+}
+
+pkg_postinst() {
+ einfo
+ einfo "HINT: To have even nicer results add these lines to your ~/.xpdfrc"
+ einfo
+ einfo " include /etc/xpdfrc"
+ einfo " t1libControl high"
+ einfo " freetypeControl high"
+ einfo
+}