summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-06-17 16:49:10 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-06-17 16:49:10 +0000
commit682cb0e13b993478416097e8ba6d9617065602f3 (patch)
treec1366f7f94308d3e2b0270de009c1fe7188573bd /app-text/rcs/rcs-5.7-r2.ebuild
parentRemoved libmcrypt entry. (libmcrypt unmasked). (diff)
downloadhistorical-682cb0e13b993478416097e8ba6d9617065602f3.tar.gz
historical-682cb0e13b993478416097e8ba6d9617065602f3.tar.bz2
historical-682cb0e13b993478416097e8ba6d9617065602f3.zip
add small fixed and bumped up ebuild version
Diffstat (limited to 'app-text/rcs/rcs-5.7-r2.ebuild')
-rw-r--r--app-text/rcs/rcs-5.7-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/rcs/rcs-5.7-r2.ebuild b/app-text/rcs/rcs-5.7-r2.ebuild
new file mode 100644
index 000000000000..2f2f8ad94436
--- /dev/null
+++ b/app-text/rcs/rcs-5.7-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/rcs/rcs-5.7-r2.ebuild,v 1.1 2002/06/17 16:49:10 naz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Revision Control System"
+SRC_URI="ftp://ftp.gnu.org/gnu/rcs/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/rcs/"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="sys-apps/diffutils"
+
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-diffutils || die
+
+ cp ${FILESDIR}/conf.sh src/conf.sh
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ man1dir=${D}/usr/share/man/man1 \
+ man3dir=${D}/usr/share/man/man3 \
+ man5dir=${D}/usr/share/man/man5 \
+ install || die
+
+ dodoc ChangeLog COPYING CREDITS NEWS README REFS
+}