summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-21 09:58:45 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-21 09:58:45 +0000
commit0571e4245f099535d67338ef924b2aca3e338dfe (patch)
treeea08b744500ce0968f37e0b4505389ae56faf0f6 /app-text/pdf2djvu/pdf2djvu-0.7.17.ebuild
parentsys-kernel/aufs-sources: Drop old; Bump to latest genpatches (diff)
downloadhistorical-0571e4245f099535d67338ef924b2aca3e338dfe.tar.gz
historical-0571e4245f099535d67338ef924b2aca3e338dfe.tar.bz2
historical-0571e4245f099535d67338ef924b2aca3e338dfe.zip
Version bump, fix src_test for default python3 (bug 473990)
Package-Manager: portage-2.2.0_alpha183/cvs/Linux x86_64 Manifest-Sign-Key: 0x62EEF090
Diffstat (limited to 'app-text/pdf2djvu/pdf2djvu-0.7.17.ebuild')
-rw-r--r--app-text/pdf2djvu/pdf2djvu-0.7.17.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-text/pdf2djvu/pdf2djvu-0.7.17.ebuild b/app-text/pdf2djvu/pdf2djvu-0.7.17.ebuild
new file mode 100644
index 000000000000..43c9ce860182
--- /dev/null
+++ b/app-text/pdf2djvu/pdf2djvu-0.7.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/pdf2djvu-0.7.17.ebuild,v 1.1 2013/06/21 09:58:31 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="A tool to create DjVu files from PDF files"
+HOMEPAGE="http://code.google.com/p/pdf2djvu/"
+SRC_URI="http://pdf2djvu.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+graphicsmagick nls openmp test"
+
+RDEPEND="
+ >=app-text/djvu-3.5.21:=
+ >=app-text/poppler-0.16.7:=
+ dev-libs/libxml2:=
+ dev-libs/libxslt:=
+ graphicsmagick? ( media-gfx/graphicsmagick:= )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/pstreams
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+REQUIRED_USE="test? ( graphicsmagick )"
+
+src_prepare() {
+ sed -e "s:nosetests :nosetests-${EPYTHON} :" \
+ -i tests/Makefile || die
+}
+
+src_configure() {
+ local openmp=--disable-openmp
+ use openmp && tc-has-openmp && openmp=--enable-openmp
+
+ econf \
+ ${openmp} \
+ $(use_enable nls) \
+ $(use_with graphicsmagick)
+}
+
+src_install() {
+ default
+ dodoc doc/{changelog,{cjk,credits,djvudigital}.txt}
+}