summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-09-30 11:45:49 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-09-30 11:45:49 +0000
commit76977ca4e4de04386c0296110e87289aeca70d8f (patch)
tree3aab4cb4b73fc4265a9a7c5dd44753abd52f6ab9 /app-text/paperwork/paperwork-0.2.ebuild
parentForce python2, bug#524024 (diff)
downloadhistorical-76977ca4e4de04386c0296110e87289aeca70d8f.tar.gz
historical-76977ca4e4de04386c0296110e87289aeca70d8f.tar.bz2
historical-76977ca4e4de04386c0296110e87289aeca70d8f.zip
Initial commit, based on lorelei overlay version
Package-Manager: portage-2.2.14_rc1/cvs/Linux x86_64 Manifest-Sign-Key: 0xC74525F2
Diffstat (limited to 'app-text/paperwork/paperwork-0.2.ebuild')
-rw-r--r--app-text/paperwork/paperwork-0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/paperwork/paperwork-0.2.ebuild b/app-text/paperwork/paperwork-0.2.ebuild
new file mode 100644
index 000000000000..92deeefc8c23
--- /dev/null
+++ b/app-text/paperwork/paperwork-0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/paperwork/paperwork-0.2.ebuild,v 1.1 2014/09/30 11:45:41 voyageur Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="a personal document manager for scanned documents (and PDFs)"
+HOMEPAGE="https://github.com/jflesch/paperwork"
+SRC_URI="https://github.com/jflesch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/poppler[introspection]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ >=dev-python/pyinsane-1.3.8[${PYTHON_USEDEP}]
+ >=dev-python/pyocr-0.2.3[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ dev-util/glade[introspection,python]
+ sci-libs/scikits_learn[${PYTHON_USEDEP}]
+ sci-libs/scikits_image[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ elog "To improve page orientation detection, you can optionally install:"
+ elog " app-dicts/aspell-<your language>"
+}