summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-14 09:56:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-14 09:56:48 +0000
commitaa9baf12a648ec7659d82f5d425f4fd7e47e6c98 (patch)
tree79030590427df2b811f443c27bd46fe2d45e19ee /app-text/htmldoc/htmldoc-1.8.27-r2.ebuild
parentNew snapshot. (diff)
downloadhistorical-aa9baf12a648ec7659d82f5d425f4fd7e47e6c98.tar.gz
historical-aa9baf12a648ec7659d82f5d425f4fd7e47e6c98.tar.bz2
historical-aa9baf12a648ec7659d82f5d425f4fd7e47e6c98.zip
Fix limitation of -D_FORTIFY_SOURCE=2 wrt #321407 by Diego Elio Pettenò.
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'app-text/htmldoc/htmldoc-1.8.27-r2.ebuild')
-rw-r--r--app-text/htmldoc/htmldoc-1.8.27-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-text/htmldoc/htmldoc-1.8.27-r2.ebuild b/app-text/htmldoc/htmldoc-1.8.27-r2.ebuild
new file mode 100644
index 000000000000..8902c4086894
--- /dev/null
+++ b/app-text/htmldoc/htmldoc-1.8.27-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmldoc/htmldoc-1.8.27-r2.ebuild,v 1.1 2010/11/14 09:56:48 ssuominen Exp $
+
+inherit eutils
+
+DESCRIPTION="Convert HTML pages into a PDF document"
+SRC_URI="mirror://easysw/htmldoc/${PV}/${P}-source.tar.bz2"
+HOMEPAGE="http://www.easysw.com/htmldoc/"
+
+IUSE="fltk ssl"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="virtual/jpeg
+ >=media-libs/libpng-1.4
+ fltk? ( >=x11-libs/fltk-1.0.11 )
+ ssl? ( >=dev-libs/openssl-0.9.6e )"
+RDEPEND="${DEPEND}"
+
+# this needs to be figured out, since htmldoc looks for all three libs
+# right now there's no virtual/ssl
+#
+# --enable-openssl use OpenSSL for SSL/TLS support, default=yes
+# --enable-gnutls use GNU TLS for SSL/TLS support, default=yes
+# --enable-cdsassl use CDSA for SSL/TLS support, default=yes
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # make sure not to use the libs htmldoc ships with
+ mkdir foo ; mv jpeg foo/ ; mv png foo/ ; mv zlib foo/
+
+ epatch "${FILESDIR}"/${PN}-sscanf-overflows.patch \
+ "${FILESDIR}"/${PN}-fortify-fail.patch
+
+ sed -i "s:^#define DOCUMENTATION \"\$prefix/share/doc/htmldoc\":#define DOCUMENTATION \"\$prefix/share/doc/${PF}/html\":" \
+ configure
+}
+
+src_compile() {
+ local myconf="$(use_enable ssl openssl) $(use_with fltk gui)"
+
+ econf ${myconf} || die "econf failed"
+
+ # Add missing -lfltk_images to LIBS
+ use fltk && sed -i 's:-lfltk :-lfltk -lfltk_images :g' Makedefs
+
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall bindir="${D}/usr/bin" || die "einstall failed"
+
+ # Minor cleanups
+ mv "${D}/usr/share/doc/htmldoc" "${D}/usr/share/doc/${PF}"
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/${PF}/*.html "${D}/usr/share/doc/${PF}/html"
+}