summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-04-15 17:54:06 +0000
committerMamoru Komachi <usata@gentoo.org>2004-04-15 17:54:06 +0000
commit6aa979bf11cb130209d208beadc4785475b74422 (patch)
tree2d6f63574ec9b7336402a640d6e3788cdc047214 /app-text/dgs/dgs-0.5.10-r1.ebuild
parentfix install. closes bug #47476. (diff)
downloadhistorical-6aa979bf11cb130209d208beadc4785475b74422.tar.gz
historical-6aa979bf11cb130209d208beadc4785475b74422.tar.bz2
historical-6aa979bf11cb130209d208beadc4785475b74422.zip
Real fix for tcpd IUSE flag issue. See bug #34016 and #34037
Diffstat (limited to 'app-text/dgs/dgs-0.5.10-r1.ebuild')
-rw-r--r--app-text/dgs/dgs-0.5.10-r1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/app-text/dgs/dgs-0.5.10-r1.ebuild b/app-text/dgs/dgs-0.5.10-r1.ebuild
index 52e3afc296d6..ce0584548926 100644
--- a/app-text/dgs/dgs-0.5.10-r1.ebuild
+++ b/app-text/dgs/dgs-0.5.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/dgs-0.5.10-r1.ebuild,v 1.23 2004/04/07 21:41:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/dgs-0.5.10-r1.ebuild,v 1.24 2004/04/15 17:54:06 usata Exp $
inherit gnuconfig eutils
@@ -17,24 +17,20 @@ RDEPEND="=dev-libs/glib-1.2*
virtual/x11"
DEPEND="${RDEPEND}
sys-apps/texinfo
+ sys-devel/autoconf
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
-pkg_setup() {
- if has_version 'sys-apps/tcp-wrappers' && ! use tcpd ; then
- ewarn "tcp-wrappers will be detected by the package and support will be enabled"
- ewarn "The package presently provides no way to disable tcp-wrappers support if you don't want it"
- fi
-}
-
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gs-time_.h-gentoo.diff
+ epatch ${FILESDIR}/${P}-tcpd-gentoo.diff
use amd64 && gnuconfig_update
}
src_compile() {
- econf --with-x || die
+ WANT_AUTOCONF=2.1 autoconf
+ econf --with-x `use_enable tcpd` || die
make || die
}