summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-28 09:35:10 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-28 09:35:10 +0000
commitad6384b50b632db5d2a97112fdfdaa04fd86d1ec (patch)
treea9a232045c662a47fd41a3ce1a2ac7561cbafae0 /app-text/convmv/convmv-1.14.ebuild
parentBump to 0.9.9.8.2, fixes #275242 (diff)
downloadhistorical-ad6384b50b632db5d2a97112fdfdaa04fd86d1ec.tar.gz
historical-ad6384b50b632db5d2a97112fdfdaa04fd86d1ec.tar.bz2
historical-ad6384b50b632db5d2a97112fdfdaa04fd86d1ec.zip
Bump to 1.14, fixes #272747
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'app-text/convmv/convmv-1.14.ebuild')
-rw-r--r--app-text/convmv/convmv-1.14.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/convmv/convmv-1.14.ebuild b/app-text/convmv/convmv-1.14.ebuild
new file mode 100644
index 000000000000..7c363460794c
--- /dev/null
+++ b/app-text/convmv/convmv-1.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/convmv/convmv-1.14.ebuild,v 1.1 2009/06/28 09:35:10 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="convert filenames to utf8 or any other charset"
+HOMEPAGE="http://j3e.de/linux/convmv"
+SRC_URI="http://j3e.de/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR="${D}" PREFIX=/usr || die "einstall failed"
+ dodoc CREDITS Changes TODO VERSION
+}
+
+src_test() {
+ unpack ./testsuite.tar
+
+ # Patch merged by upstream
+ # Never make assumptions as to the ordering of files inside a directory!
+ #EPATCH_OPTS="-d ${S}/suite/" epatch "${FILESDIR}"/${PN}-1.10-testcase-cleanup.patch
+
+ cd "${S}"/suite
+ ./dotests.sh || die "Tests failed"
+}