summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-24 00:25:51 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-24 00:25:51 +0000
commitec38299f4ff932abeb7fff6016eba8dd699d198d (patch)
tree8d813cffc5bf1416ec234aa93a2c313bf36c63c0 /app-shells/sandboxshell
parentQA - fix use invocation (diff)
downloadhistorical-ec38299f4ff932abeb7fff6016eba8dd699d198d.tar.gz
historical-ec38299f4ff932abeb7fff6016eba8dd699d198d.tar.bz2
historical-ec38299f4ff932abeb7fff6016eba8dd699d198d.zip
Add support for new homedir and trap signals went prompting
Diffstat (limited to 'app-shells/sandboxshell')
-rw-r--r--app-shells/sandboxshell/ChangeLog10
-rw-r--r--app-shells/sandboxshell/Manifest20
-rw-r--r--app-shells/sandboxshell/files/digest-sandboxshell-0.1-r1 (renamed from app-shells/sandboxshell/files/digest-sandboxshell-0.1)0
-rw-r--r--app-shells/sandboxshell/files/sandboxshell.conf6
-rw-r--r--app-shells/sandboxshell/sandboxshell-0.1-r1.ebuild (renamed from app-shells/sandboxshell/sandboxshell-0.1.ebuild)2
5 files changed, 28 insertions, 10 deletions
diff --git a/app-shells/sandboxshell/ChangeLog b/app-shells/sandboxshell/ChangeLog
index 8341c0733679..062de55670ac 100644
--- a/app-shells/sandboxshell/ChangeLog
+++ b/app-shells/sandboxshell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/sandboxshell
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/ChangeLog,v 1.2 2003/08/01 03:45:50 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/ChangeLog,v 1.3 2004/06/24 00:25:51 vapier Exp $
+
+*sandboxshell-0.1-r1 (23 Jun 2004)
+
+ 23 Jun 2004; Mike Frysinger <vapier@gentoo.org> files/sandboxshell.conf,
+ +sandboxshell-0.1-r1.ebuild:
+ Add support for new homedir and trap signals went prompting
*sandboxshell-0.1 (09 Jul 2003)
diff --git a/app-shells/sandboxshell/Manifest b/app-shells/sandboxshell/Manifest
index e63b49622294..82182f7539ad 100644
--- a/app-shells/sandboxshell/Manifest
+++ b/app-shells/sandboxshell/Manifest
@@ -1,6 +1,16 @@
-MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-sandboxshell-0.1 0
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 f21dfad81478923d65970def4474ed12 ChangeLog 630
+MD5 1b174209c90d5d3b3cf731bb2754da71 sandboxshell-0.1-r1.ebuild 681
MD5 540f05af4f7a2f11076c74fab84d6fae files/sandboxshell 1280
-MD5 400c9d8f0525d35bee24fb48622e00c6 files/sandboxshell.1 3116
-MD5 efdff08ba9889ecf839b72ef3f3df410 files/sandboxshell.conf 1646
-MD5 5bcd1edda798c9fb34a0c50da58f205f ChangeLog 426
-MD5 0d5d8b7d33bf70125f55ee8ffab2212f sandboxshell-0.1.ebuild 679
+MD5 89728cab133398dad145e13d92fff6b2 files/sandboxshell.1 3117
+MD5 e6a1ed3054d31d67233843e4624dbd98 files/sandboxshell.conf 1689
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-sandboxshell-0.1-r1 0
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.8 (GNU/Linux)
+
+iD8DBQFA2h+aHTu7gpaalycRAm+5AJ9ijxiZjoctKC+kM0woWszYyGkD/QCfeZ1H
+Yk8Kk5A9PyfYDqqrF9oONVQ=
+=Us+p
+-----END PGP SIGNATURE-----
diff --git a/app-shells/sandboxshell/files/digest-sandboxshell-0.1 b/app-shells/sandboxshell/files/digest-sandboxshell-0.1-r1
index e69de29bb2d1..e69de29bb2d1 100644
--- a/app-shells/sandboxshell/files/digest-sandboxshell-0.1
+++ b/app-shells/sandboxshell/files/digest-sandboxshell-0.1-r1
diff --git a/app-shells/sandboxshell/files/sandboxshell.conf b/app-shells/sandboxshell/files/sandboxshell.conf
index e9e4440894dc..a34e3abe9578 100644
--- a/app-shells/sandboxshell/files/sandboxshell.conf
+++ b/app-shells/sandboxshell/files/sandboxshell.conf
@@ -1,7 +1,9 @@
#!/bin/bash
# Written by vapier@gentoo.org
# public-domain code ... z0r ...
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell.conf,v 1.3 2003/07/10 02:00:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell.conf,v 1.4 2004/06/24 00:25:51 vapier Exp $
+
+trap ":" INT QUIT TSTP
source /etc/profile
@@ -30,7 +32,7 @@ if [ "${PWD:0:${#sbs_pdir}}" == "${sbs_pdir}" ] ; then
sbs_PREPWD=${PWD}
if [ "${env}" == "y" ] ; then
source ${sbs_tmpenvfile} 2> /dev/null
- export SANDBOX_WRITE="${SANDBOX_WRITE}:${sbs_pdir}${sbs_bdir}"
+ export SANDBOX_WRITE="${SANDBOX_WRITE}:${sbs_pdir}${sbs_bdir}:${sbs_pdir}/homedir"
fi
PWD=${sbs_PREPWD}
fi
diff --git a/app-shells/sandboxshell/sandboxshell-0.1.ebuild b/app-shells/sandboxshell/sandboxshell-0.1-r1.ebuild
index 4ae02e1939bb..9cda994dad69 100644
--- a/app-shells/sandboxshell/sandboxshell-0.1.ebuild
+++ b/app-shells/sandboxshell/sandboxshell-0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.1.ebuild,v 1.6 2004/04/25 20:11:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.1-r1.ebuild,v 1.1 2004/06/24 00:25:51 vapier Exp $
DESCRIPTION="launch a sandboxed shell ... useful for debugging ebuilds"
HOMEPAGE="http://wh0rd.org/"