summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-10-07 12:57:40 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-10-07 12:57:40 +0000
commit681293df2679c025bc40939135c3269293bb90dc (patch)
tree307a0eeb7c87bbf0b598c3986364d0a89b63cff1 /app-sci
parentMarking stable on x86 wrt security bug #66251 (diff)
downloadhistorical-681293df2679c025bc40939135c3269293bb90dc.tar.gz
historical-681293df2679c025bc40939135c3269293bb90dc.tar.bz2
historical-681293df2679c025bc40939135c3269293bb90dc.zip
Fixing bug #65141
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/stellarium/ChangeLog8
-rw-r--r--app-sci/stellarium/Manifest9
-rw-r--r--app-sci/stellarium/files/0.6.0-gcc3.4.patch45
-rw-r--r--app-sci/stellarium/stellarium-0.6.0.ebuild10
4 files changed, 66 insertions, 6 deletions
diff --git a/app-sci/stellarium/ChangeLog b/app-sci/stellarium/ChangeLog
index cef5889d3f60..470b49d329d4 100644
--- a/app-sci/stellarium/ChangeLog
+++ b/app-sci/stellarium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/stellarium
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/stellarium/ChangeLog,v 1.10 2004/09/22 00:21:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/stellarium/ChangeLog,v 1.11 2004/10/07 12:57:40 phosphan Exp $
+
+ 07 Oct 2004; Patrick Kursawe <phosphan@gentoo.org>
+ +files/0.6.0-gcc3.4.patch, stellarium-0.6.0.ebuild:
+ Fixing for gcc 3.4 (bug #65141)
21 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
stellarium-0.6.0.ebuild:
@@ -13,6 +17,8 @@
stellarium-0.6.0.ebuild:
tidy
+*stellarium-0.6.0 (28 Jul 2004)
+
28 Jul 2004; Olivier Fisette <ribosome@gentoo.org>
stellarium-0.6.0.ebuild:
Version bump.
diff --git a/app-sci/stellarium/Manifest b/app-sci/stellarium/Manifest
index 1f4cf77142c7..4333b9deac5c 100644
--- a/app-sci/stellarium/Manifest
+++ b/app-sci/stellarium/Manifest
@@ -1,6 +1,7 @@
-MD5 f461e8649b58b3bfbce1c5eb43bf6d6c ChangeLog 1383
-MD5 e4bdac528fd001633aa222d2b42fe048 metadata.xml 219
MD5 6fb808ee71ebfb5139461cf677ef5e0e stellarium-0.5.2.ebuild 754
-MD5 8226f1fc1f623fe3c2e436e459613694 stellarium-0.6.0.ebuild 628
-MD5 66045214d764b4b038374273fd42f9ad files/digest-stellarium-0.6.0 69
+MD5 7eeab5bc61da2ad2ec794d10af0101fa stellarium-0.6.0.ebuild 722
+MD5 0c8b3c0a4765f25911b06ee61ac6f93e ChangeLog 1557
+MD5 e4bdac528fd001633aa222d2b42fe048 metadata.xml 219
MD5 86f0c7ba8d19b134d3fc0ba76f7cb419 files/digest-stellarium-0.5.2 69
+MD5 66045214d764b4b038374273fd42f9ad files/digest-stellarium-0.6.0 69
+MD5 a4fae4fd9a24841590bae608376c0842 files/0.6.0-gcc3.4.patch 1601
diff --git a/app-sci/stellarium/files/0.6.0-gcc3.4.patch b/app-sci/stellarium/files/0.6.0-gcc3.4.patch
new file mode 100644
index 000000000000..a6d9f78bab6f
--- /dev/null
+++ b/app-sci/stellarium/files/0.6.0-gcc3.4.patch
@@ -0,0 +1,45 @@
+diff -ru src/callback_helpers.hpp src.new/callback_helpers.hpp
+--- src/callback_helpers.hpp 2003-08-21 15:51:58.000000000 +0200
++++ src.new/callback_helpers.hpp 2004-10-07 14:30:40.235729977 +0200
+@@ -204,7 +204,7 @@
+ template<bool Condition, class Then, class Else>
+ struct IF {
+ typedef typename Selector<Condition>::RET select;
+- typedef typename select::Result<Then,Else>::RET RET;
++ typedef typename boost::details::Selector<Condition>::RET::template Result<Then,Else>::RET RET;
+ };
+
+
+diff -ru src/stel_atmosphere.cpp src.new/stel_atmosphere.cpp
+--- src/stel_atmosphere.cpp 2004-05-31 16:33:10.000000000 +0200
++++ src.new/stel_atmosphere.cpp 2004-10-07 14:31:25.347505081 +0200
+@@ -30,7 +30,7 @@
+ stel_atmosphere::stel_atmosphere() : sky_resolution(48), tab_sky(NULL)
+ {
+ // Create the vector array used to store the sky color on the full field of view
+- tab_sky = new (Vec3f*)[sky_resolution+1];
++ tab_sky = new Vec3f*[sky_resolution+1];
+ for (int k=0; k<sky_resolution+1 ;k++)
+ {
+ tab_sky[k] = new Vec3f[sky_resolution+1];
+diff -ru src/vecmath.h src.new/vecmath.h
+--- src/vecmath.h 2003-08-08 14:33:28.000000000 +0200
++++ src.new/vecmath.h 2004-10-07 14:28:15.534702249 +0200
+@@ -758,7 +758,7 @@
+ 0, 0, 1, 0,
+ a.v[0], a.v[1], a.v[2], 1);
+ }
+-
++/*
+ template<class T> Matrix4<T> Matrix4<T>::rotation(const Vector3<T>& a)
+ {
+ T c = (T) cos(angle);
+@@ -769,7 +769,7 @@
+ a.v[0]*a.v[2]*d+a.v[1]*s, a.v[1]*a.v[2]*d-a.v[0]*s, a.v[2]*a.v[2]*d+c, 0,
+ 0,0,0,1 );
+ }
+-
++*/
+ template<class T> Matrix4<T> Matrix4<T>::xrotation(T angle)
+ {
+ T c = (T) cos(angle);
diff --git a/app-sci/stellarium/stellarium-0.6.0.ebuild b/app-sci/stellarium/stellarium-0.6.0.ebuild
index b4ef1b8fddf6..d30b2c55680b 100644
--- a/app-sci/stellarium/stellarium-0.6.0.ebuild
+++ b/app-sci/stellarium/stellarium-0.6.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/stellarium/stellarium-0.6.0.ebuild,v 1.4 2004/09/22 00:21:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/stellarium/stellarium-0.6.0.ebuild,v 1.5 2004/10/07 12:57:40 phosphan Exp $
+
+inherit eutils
DESCRIPTION="Stellarium renders 3D photo-realistic skies in real time."
HOMEPAGE="http://stellarium.free.fr/"
@@ -15,6 +17,12 @@ DEPEND="virtual/x11
virtual/opengl
media-libs/libsdl"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.4.patch
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog INSTALL README TODO