summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-08 23:43:26 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-08 23:43:26 +0000
commit3629eff2029e1eab7d35ea177421dc063f0d445b (patch)
tree74fb4116e45f9edc63441d7ec8275327492c4916 /app-sci/snns/snns-4.2-r1.ebuild
parentA newer version :-( (diff)
downloadhistorical-3629eff2029e1eab7d35ea177421dc063f0d445b.tar.gz
historical-3629eff2029e1eab7d35ea177421dc063f0d445b.tar.bz2
historical-3629eff2029e1eab7d35ea177421dc063f0d445b.zip
updates per #10390
Diffstat (limited to 'app-sci/snns/snns-4.2-r1.ebuild')
-rw-r--r--app-sci/snns/snns-4.2-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-sci/snns/snns-4.2-r1.ebuild b/app-sci/snns/snns-4.2-r1.ebuild
new file mode 100644
index 000000000000..fee2d8348d98
--- /dev/null
+++ b/app-sci/snns/snns-4.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2-r1.ebuild,v 1.1 2002/11/08 23:43:26 vapier Exp $
+
+MY_P="SNNSv${PV}"
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="x86"
+SLOT="0"
+IUSE="X doc"
+
+DEPEND="X? ( virtual/x11 )
+ virtual/glibc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
+}
+
+src_compile() {
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if [ `use X` ] ; then
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ econf ${myconf}
+ emake ${compileopts} || die "emake failed"
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ if [ `use X` ] ; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${P}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${P}
+ dodoc default.cfg help.hdoc
+ fi
+
+ insinto /usr/share/doc/${P}
+ use doc && dodoc ${DISTDIR}/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*
+
+ doman man/man*/*
+}