summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-04-21 20:33:05 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-04-21 20:33:05 +0000
commitd6ebdaf2ed11be8b444fb71b5f5ac81a2a3b16a9 (patch)
treef0a89f5e024f57ce87ae515c3e5d6f07d39ea357 /app-sci/lapack
parentinherit eutils; use epatch; error check; tidy (diff)
downloadhistorical-d6ebdaf2ed11be8b444fb71b5f5ac81a2a3b16a9.tar.gz
historical-d6ebdaf2ed11be8b444fb71b5f5ac81a2a3b16a9.tar.bz2
historical-d6ebdaf2ed11be8b444fb71b5f5ac81a2a3b16a9.zip
One step to fix BUG #47629. Version bump to 3.0-r1.
Diffstat (limited to 'app-sci/lapack')
-rw-r--r--app-sci/lapack/ChangeLog5
-rw-r--r--app-sci/lapack/Manifest4
-rw-r--r--app-sci/lapack/files/digest-lapack-3.0-r11
-rw-r--r--app-sci/lapack/lapack-3.0-r1.ebuild29
4 files changed, 37 insertions, 2 deletions
diff --git a/app-sci/lapack/ChangeLog b/app-sci/lapack/ChangeLog
index ebf420c7f01f..4ffe3c8ea4cd 100644
--- a/app-sci/lapack/ChangeLog
+++ b/app-sci/lapack/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/lapack
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack/ChangeLog,v 1.4 2004/04/19 10:29:24 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack/ChangeLog,v 1.5 2004/04/21 20:33:05 kugelfang Exp $
+
+ 21 Apr 2004; Danny van Dyk <kugelfang@gentoo.org> :
+ Version bump to make /usr/lib/liblapack.a linkable on amd64.
19 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> lapack-3.0.ebuild:
Adding IUSE
diff --git a/app-sci/lapack/Manifest b/app-sci/lapack/Manifest
index 834d45f26ac3..eccebf729ec0 100644
--- a/app-sci/lapack/Manifest
+++ b/app-sci/lapack/Manifest
@@ -1,5 +1,7 @@
+MD5 a277dacac24ae3c3987fbab084cd538f ChangeLog 683
MD5 9af5287371585724c509d56a6c14cc40 lapack-3.0.ebuild 733
-MD5 74d353064c9d3d136f137162f7bba425 ChangeLog 564
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 794a9f20f734d45242bb3ed87970b7c9 lapack-3.0-r1.ebuild 835
MD5 823864ca423f83efce8f2b0b64bb44d6 files/Makefile 12334
MD5 dc3f9270e78caa228b1591e03109ef05 files/digest-lapack-3.0 56
+MD5 dc3f9270e78caa228b1591e03109ef05 files/digest-lapack-3.0-r1 56
diff --git a/app-sci/lapack/files/digest-lapack-3.0-r1 b/app-sci/lapack/files/digest-lapack-3.0-r1
new file mode 100644
index 000000000000..e80f5b885b3e
--- /dev/null
+++ b/app-sci/lapack/files/digest-lapack-3.0-r1
@@ -0,0 +1 @@
+MD5 a24f59304f87b78cdc7da2ae59c98664 lapack.tgz 4991992
diff --git a/app-sci/lapack/lapack-3.0-r1.ebuild b/app-sci/lapack/lapack-3.0-r1.ebuild
new file mode 100644
index 000000000000..c72bf0eb8bed
--- /dev/null
+++ b/app-sci/lapack/lapack-3.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lapack/lapack-3.0-r1.ebuild,v 1.1 2004/04/21 20:33:05 kugelfang Exp $
+
+DESCRIPTION="Linear Algebra PACKage for scientists, engineers, and mathematicians. This contains the libraries for creating programs that use LAPACK."
+HOMEPAGE="http://www.netlib.org/lapack/"
+SRC_URI="http://www.netlib.org/lapack/lapack.tgz"
+
+LICENSE="lapack"
+SLOT="0"
+IUSE=""
+KEYWORDS="-* amd64"
+
+DEPEND="virtual/glibc
+ app-sci/blas"
+
+S=${WORKDIR}/LAPACK
+
+src_compile() {
+ cp ${FILESDIR}/Makefile SRC/Makefile
+ cd SRC
+ # ncessary to be able to link against liblapack.a on amd64
+ use amd64 && CFLAGS="${CFLAGS} -fPIC"
+ FC="g77" FFLAGS="${CFLAGS}" make static
+}
+
+src_install() {
+ dolib.a SRC/liblapack.a
+}