summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan Khalil <gongloo@gentoo.org>2004-10-14 12:22:09 +0000
committerHasan Khalil <gongloo@gentoo.org>2004-10-14 12:22:09 +0000
commit2eb772fe9b15810eab0100d232600e0ba0ca1205 (patch)
treed847af676e5f4b54aeccd83e4f11a83190811785 /app-sci/clustalw
parentStable on hppa. (diff)
downloadhistorical-2eb772fe9b15810eab0100d232600e0ba0ca1205.tar.gz
historical-2eb772fe9b15810eab0100d232600e0ba0ca1205.tar.bz2
historical-2eb772fe9b15810eab0100d232600e0ba0ca1205.zip
Fixed gcc with gcc.eclass.
Diffstat (limited to 'app-sci/clustalw')
-rw-r--r--app-sci/clustalw/ChangeLog5
-rw-r--r--app-sci/clustalw/Manifest4
-rw-r--r--app-sci/clustalw/clustalw-1.83-r1.ebuild7
3 files changed, 11 insertions, 5 deletions
diff --git a/app-sci/clustalw/ChangeLog b/app-sci/clustalw/ChangeLog
index 2a818570f496..d13cfe630b49 100644
--- a/app-sci/clustalw/ChangeLog
+++ b/app-sci/clustalw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/clustalw
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/ChangeLog,v 1.8 2004/10/06 02:03:14 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/ChangeLog,v 1.9 2004/10/14 12:22:09 gongloo Exp $
+
+ 14 Oct 2004; Hasan Khalil <gongloo@gentoo.org> clustalw-1.83-r1.ebuild:
+ Fixed gcc with gcc.eclass.
05 Oct 2004; Olivier Fisette <ribosome@gentoo.org> clustalw-1.83-r1.ebuild:
Fixed overly verbose description.
diff --git a/app-sci/clustalw/Manifest b/app-sci/clustalw/Manifest
index 0f0e567012a5..b584a4894150 100644
--- a/app-sci/clustalw/Manifest
+++ b/app-sci/clustalw/Manifest
@@ -1,4 +1,4 @@
-MD5 ce2d44decb2dc5de0d50a088d8549f5e clustalw-1.83-r1.ebuild 1019
-MD5 6b1d6f0854e60d7e5a629125cb6059d9 ChangeLog 930
+MD5 e1909eeea67da7fa00514a5750edc80c ChangeLog 1033
+MD5 6a07418f8066e36260319d52e790e3e7 clustalw-1.83-r1.ebuild 1097
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 59931bb873b284e7ab0b7c452e87d075 files/digest-clustalw-1.83-r1 69
diff --git a/app-sci/clustalw/clustalw-1.83-r1.ebuild b/app-sci/clustalw/clustalw-1.83-r1.ebuild
index b2ec111dfd13..63d13bc22a40 100644
--- a/app-sci/clustalw/clustalw-1.83-r1.ebuild
+++ b/app-sci/clustalw/clustalw-1.83-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83-r1.ebuild,v 1.3 2004/10/06 02:03:14 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83-r1.ebuild,v 1.4 2004/10/14 12:22:09 gongloo Exp $
+
+inherit gcc
DESCRIPTION="General purpose multiple alignment program for DNA and proteins"
HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
@@ -18,6 +20,7 @@ S=${WORKDIR}/${PN}${PV}
src_unpack(){
unpack ${A}
cd ${S}
+ # No longer needed. see emake line below.
sed -i -e "s/CC = cc/CC = ${CC:gcc}/" makefile
sed -i -e "s/CFLAGS = -c -O/CFLAGS = -c ${CFLAGS}/" makefile
sed -i -e "s/LFLAGS = -O -lm/LFLAGS = -lm ${CFLAGS}/" makefile
@@ -25,7 +28,7 @@ src_unpack(){
}
src_compile() {
- emake || die
+ CC=${CC:-$(gcc-getCC)} emake || die
}
src_install() {