summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-10-14 14:30:59 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-10-14 14:30:59 +0000
commit05366d7be5713083a0986e500e6883ef994db26e (patch)
treec32f7c2d05a4e0724fc91d70dd2c9f855c32bc40 /app-sci/clustalw
parenthppa love (diff)
downloadhistorical-05366d7be5713083a0986e500e6883ef994db26e.tar.gz
historical-05366d7be5713083a0986e500e6883ef994db26e.tar.bz2
historical-05366d7be5713083a0986e500e6883ef994db26e.zip
Fixed CC with gcc.eclass.
Diffstat (limited to 'app-sci/clustalw')
-rw-r--r--app-sci/clustalw/ChangeLog5
-rw-r--r--app-sci/clustalw/Manifest4
-rw-r--r--app-sci/clustalw/clustalw-1.83-r1.ebuild6
3 files changed, 9 insertions, 6 deletions
diff --git a/app-sci/clustalw/ChangeLog b/app-sci/clustalw/ChangeLog
index d13cfe630b49..51f6be8d2321 100644
--- a/app-sci/clustalw/ChangeLog
+++ b/app-sci/clustalw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/clustalw
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/ChangeLog,v 1.9 2004/10/14 12:22:09 gongloo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/ChangeLog,v 1.10 2004/10/14 14:30:59 ribosome Exp $
+
+ 14 Oct 2004; Olivier Fisette <ribosome@gentoo.org> clustalw-1.83-r1.ebuild:
+ Fixed gcc with gcc.eclass. gongloo left some mistakes.
14 Oct 2004; Hasan Khalil <gongloo@gentoo.org> clustalw-1.83-r1.ebuild:
Fixed gcc with gcc.eclass.
diff --git a/app-sci/clustalw/Manifest b/app-sci/clustalw/Manifest
index b584a4894150..3f337b628ced 100644
--- a/app-sci/clustalw/Manifest
+++ b/app-sci/clustalw/Manifest
@@ -1,4 +1,4 @@
-MD5 e1909eeea67da7fa00514a5750edc80c ChangeLog 1033
-MD5 6a07418f8066e36260319d52e790e3e7 clustalw-1.83-r1.ebuild 1097
+MD5 17e28fb647891f079650c11105e8084d clustalw-1.83-r1.ebuild 1094
+MD5 3fa84a3158d1e545e9e51efdcaca2ac6 ChangeLog 1171
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 59931bb873b284e7ab0b7c452e87d075 files/digest-clustalw-1.83-r1 69
diff --git a/app-sci/clustalw/clustalw-1.83-r1.ebuild b/app-sci/clustalw/clustalw-1.83-r1.ebuild
index 63d13bc22a40..4837b8fa93f4 100644
--- a/app-sci/clustalw/clustalw-1.83-r1.ebuild
+++ b/app-sci/clustalw/clustalw-1.83-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83-r1.ebuild,v 1.4 2004/10/14 12:22:09 gongloo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83-r1.ebuild,v 1.5 2004/10/14 14:30:59 ribosome Exp $
inherit gcc
@@ -21,14 +21,14 @@ src_unpack(){
unpack ${A}
cd ${S}
# No longer needed. see emake line below.
- sed -i -e "s/CC = cc/CC = ${CC:gcc}/" makefile
+ sed -i -e "s/CC = cc/CC = $(gcc-getCC)/" makefile
sed -i -e "s/CFLAGS = -c -O/CFLAGS = -c ${CFLAGS}/" makefile
sed -i -e "s/LFLAGS = -O -lm/LFLAGS = -lm ${CFLAGS}/" makefile
sed -i -e "s%clustalw_help%/usr/share/doc/${PF}/clustalw_help%" clustalw.c
}
src_compile() {
- CC=${CC:-$(gcc-getCC)} emake || die
+ CC=$(gcc-getCC) emake || die
}
src_install() {