summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-12-31 02:47:21 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-12-31 02:47:21 +0000
commit5be34a34e7ecac256e03b4eb8158496fcd7b6e2b (patch)
tree0afd01e03b0899630924d70fe78c34a97477732a /app-sci/biopython
parentMarked stable on hppa. (diff)
downloadhistorical-5be34a34e7ecac256e03b4eb8158496fcd7b6e2b.tar.gz
historical-5be34a34e7ecac256e03b4eb8158496fcd7b6e2b.tar.bz2
historical-5be34a34e7ecac256e03b4eb8158496fcd7b6e2b.zip
new version, moved 1.21 to stable
Diffstat (limited to 'app-sci/biopython')
-rw-r--r--app-sci/biopython/ChangeLog8
-rw-r--r--app-sci/biopython/Manifest6
-rw-r--r--app-sci/biopython/biopython-1.21.ebuild4
-rw-r--r--app-sci/biopython/biopython-1.23.ebuild32
-rw-r--r--app-sci/biopython/files/digest-biopython-1.231
5 files changed, 46 insertions, 5 deletions
diff --git a/app-sci/biopython/ChangeLog b/app-sci/biopython/ChangeLog
index 962185007870..f7a1c22fc6c1 100644
--- a/app-sci/biopython/ChangeLog
+++ b/app-sci/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/biopython
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/biopython/ChangeLog,v 1.4 2003/09/02 22:45:51 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/biopython/ChangeLog,v 1.5 2003/12/31 02:47:08 george Exp $
+
+*biopython-1.23 (30 Dec 2003)
+
+ 30 Dec 2003; George Shapovalvo <george@gentoo.org> biopython-1.23.ebuild :
+ new version, reworked to use distutils. Thanks to
+ Peter Bienstman <Peter.Bienstman@rug.ac.be> for an update (#35727)
02 Sep 2003; Alastair Tse <liquidx@gentoo.org> biopython-1.10.ebuild,
biopython-1.21.ebuild:
diff --git a/app-sci/biopython/Manifest b/app-sci/biopython/Manifest
index d881ff30aebb..7cd80772d976 100644
--- a/app-sci/biopython/Manifest
+++ b/app-sci/biopython/Manifest
@@ -1,6 +1,8 @@
-MD5 440b4661ee43ed2d7473063537c75565 ChangeLog 970
+MD5 445f20da2afd5ac16e07d984e736ecf3 biopython-1.23.ebuild 803
MD5 a8580a4e13390edfcc1b711bc584d4e4 biopython-1.10.ebuild 835
+MD5 638f12aa82c86f9ab5de42cdb9f1784b ChangeLog 1200
MD5 e52ec7d225835cda2c95c5317cdccfb4 metadata.xml 217
-MD5 b439358b65ada7f537e8f10c414ff1ab biopython-1.21.ebuild 928
+MD5 f0a42f8bb8c343ae27d0073a4fbb2f20 biopython-1.21.ebuild 925
MD5 8e719491da5d9664fddedbffc6af8f06 files/digest-biopython-1.10 67
MD5 c54d7ea5347210ae92b5e01a346e2a21 files/digest-biopython-1.21 67
+MD5 3a482a8872b4342414ac1d59b7fee4ed files/digest-biopython-1.23 67
diff --git a/app-sci/biopython/biopython-1.21.ebuild b/app-sci/biopython/biopython-1.21.ebuild
index ca28327debdb..c6078261c271 100644
--- a/app-sci/biopython/biopython-1.21.ebuild
+++ b/app-sci/biopython/biopython-1.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/biopython/biopython-1.21.ebuild,v 1.3 2003/09/08 07:24:58 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/biopython/biopython-1.21.ebuild,v 1.4 2003/12/31 02:47:08 george Exp $
IUSE=""
@@ -16,7 +16,7 @@ DEPEND=">=dev-lang/python-2.0
SLOT="0"
LICENSE="as-is"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
src_compile() {
python setup.py build || die
diff --git a/app-sci/biopython/biopython-1.23.ebuild b/app-sci/biopython/biopython-1.23.ebuild
new file mode 100644
index 000000000000..036ddc9a1a79
--- /dev/null
+++ b/app-sci/biopython/biopython-1.23.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/biopython/biopython-1.23.ebuild,v 1.1 2003/12/31 02:47:08 george Exp $
+
+inherit distutils
+
+IUSE=""
+
+DESCRIPTION="Biopython - python modules for computational molecular biology"
+SRC_URI="http://www.biopython.org/files/${P}.tar.gz"
+HOMEPAGE="http://www.biopython.org"
+
+DEPEND=">=dev-lang/python-2.0
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-python/numeric-19.0
+ >=dev-python/reportlab-1.11"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="Doc/* Doc/install/*.txt"
+ distutils_src_install
+
+ dohtml Doc/install/*.html
+ cp -r Doc/examples/ ${D}/usr/share/doc/${PF}/
+}
diff --git a/app-sci/biopython/files/digest-biopython-1.23 b/app-sci/biopython/files/digest-biopython-1.23
new file mode 100644
index 000000000000..72f729c48557
--- /dev/null
+++ b/app-sci/biopython/files/digest-biopython-1.23
@@ -0,0 +1 @@
+MD5 45ea628621c6b04d471f029ef5873aaf biopython-1.23.tar.gz 2241300