summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-09-08 14:22:25 +0000
committerTroy Dack <tad@gentoo.org>2003-09-08 14:22:25 +0000
commitee6ef05f9c62469cd789937b5bb76a88b2f0cded (patch)
tree7ece16242440ce70ddebc80f4ce254cec8da42f2 /app-pda
parentNew ebuild. Sync your PDA/phone with a variety of clients (diff)
downloadhistorical-ee6ef05f9c62469cd789937b5bb76a88b2f0cded.tar.gz
historical-ee6ef05f9c62469cd789937b5bb76a88b2f0cded.tar.bz2
historical-ee6ef05f9c62469cd789937b5bb76a88b2f0cded.zip
New ebuild. Sync your PDA/phone with a variety of clients
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/multisync/Manifest4
-rw-r--r--app-pda/multisync/files/digest-multisync-0.80-r11
-rw-r--r--app-pda/multisync/metadata.xml10
-rw-r--r--app-pda/multisync/multisync-0.80-r1.ebuild93
-rw-r--r--app-pda/synce-multisync_plugin/ChangeLog10
-rw-r--r--app-pda/synce-multisync_plugin/Manifest4
6 files changed, 120 insertions, 2 deletions
diff --git a/app-pda/multisync/Manifest b/app-pda/multisync/Manifest
index dc433f2e1c7f..e7f2c03c60f4 100644
--- a/app-pda/multisync/Manifest
+++ b/app-pda/multisync/Manifest
@@ -1,4 +1,4 @@
-MD5 91b089635aa5bd479479395099e1ff4a multisync-0.80-r1.ebuild 2088
-MD5 b1d4c788673f76ddc2be55bd6453534d ChangeLog 146
+MD5 2ae842c8296a48dd5188973b0e826584 multisync-0.80-r1.ebuild 2190
+MD5 b9c04f810db0e8976c5d95333f3f9c72 ChangeLog 448
MD5 8bf6f02e04d1b0ccf382064a2d1ee056 metadata.xml 331
MD5 8ad3a49acbf349a211788f9fadd1285d files/digest-multisync-0.80-r1 69
diff --git a/app-pda/multisync/files/digest-multisync-0.80-r1 b/app-pda/multisync/files/digest-multisync-0.80-r1
new file mode 100644
index 000000000000..4b790b50cff8
--- /dev/null
+++ b/app-pda/multisync/files/digest-multisync-0.80-r1
@@ -0,0 +1 @@
+MD5 f1b1ff5665d7de82b2a2948752b818c7 multisync-0.80-1.tar.gz 1592241
diff --git a/app-pda/multisync/metadata.xml b/app-pda/multisync/metadata.xml
new file mode 100644
index 000000000000..e53acf2f7457
--- /dev/null
+++ b/app-pda/multisync/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>tad@gentoo.org</email>
+ <name>Troy Dack</name>
+</maintainer>
+<longdescription>Sync various portable devices with multiple clients</longdescription>
+</pkgmetadata>
diff --git a/app-pda/multisync/multisync-0.80-r1.ebuild b/app-pda/multisync/multisync-0.80-r1.ebuild
new file mode 100644
index 000000000000..c29244c857c3
--- /dev/null
+++ b/app-pda/multisync/multisync-0.80-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.80-r1.ebuild,v 1.1 2003/09/08 14:21:42 tad Exp $
+
+DESCRIPTION="Client to sync apps with WinCE or mobile devices"
+
+HOMEPAGE="http://wultisync.sourceforge.net/"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+MY_P="${PF/r1/1}"
+SRC_URI="mirror://sourceforge/multisync/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+# evo - evolution plugin
+# irmc - bluetooth/irmc/irda plugin ( local )
+# opie - opie plugin ( local )
+# ldap - ldap plugin - experimental
+
+IUSE="evo irmc opie ldap"
+
+DEPEND="virtual/glibc
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/ORBit-0.5.17
+ >=dev-libs/openssl-0.9.6j
+ evo? ( gtk2? ( =net-mail/evolution-1.4*
+ =x11-libs/gtk+-2* ) :
+ ( =net-mail/evolution-1.2*
+ =x11-libs/gtk+-1* )
+ )
+ irmc? ( >=sys-apps/irda-utils-0.9.15
+ >=net-wireless/bluez-utils-2.3
+ >=dev-libs/openobex-1.0.0 )
+ opie? ( >=net-ftp/curl-7.10.5 )
+ ldap? ( >=net-nds/openldap-2.0.27 )"
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+
+S=${WORKDIR}/${PF/-r1/}
+
+PLUGINS="backup_plugin syncml_plugin"
+
+if [ `use irmc` ] ; then
+ PLUGINS="${PLUGINS} irmc_sync"
+fi
+if [ `use evo` ] ; then
+ PLUGINS="${PLUGINS} evolution_sync"
+fi
+
+if [ `use opie` ] ; then
+ PLUGINS="${PLUGINS} opie_sync"
+fi
+
+if [ `use ldap` ] ; then
+ PLUGINS="${PLUGINS} ldap_plugin"
+fi
+
+
+src_compile() {
+ einfo "Building Multisynx with these plugins:"
+ for plugin_dir in ${PLUGINS}
+ do
+ einfo " ${plugin_dir}"
+ done
+
+ cd ${S}
+ econf || die
+ make || die "Multisync make failed"
+
+ cd ${S}/plugins
+ for plugin_dir in ${PLUGINS}
+ do
+ cd ${S}/plugins/${plugin_dir}
+ econf || die "${plugin_dir} config failed!"
+ make || die "${plugin_dir} make failed!"
+ done
+}
+
+src_install() {
+ cd ${S}
+ einstall || die "Multisync install failed!"
+ for plugin_dir in ${PLUGINS}
+ do
+ cd ${S}/plugins/${plugin_dir}
+ einstall || die "${plugin_dir} make failed!"
+ done
+}
diff --git a/app-pda/synce-multisync_plugin/ChangeLog b/app-pda/synce-multisync_plugin/ChangeLog
new file mode 100644
index 000000000000..aec5ce8dc13b
--- /dev/null
+++ b/app-pda/synce-multisync_plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-pde/synce-multisync_plugin
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-multisync_plugin/ChangeLog,v 1.1 2003/09/08 14:22:25 tad Exp $
+
+*synce-multisync_plugin-0.8.2 (09 Sep 2003)
+
+ 09 Sep 2003; Troy Dack <tad@gentoo.org> metadata.xml,
+ synce-multisync_plugin-0.8.2.ebuild:
+ New ebuild. Multisync plugin to enable sync'ing with WinCE devices.
+
diff --git a/app-pda/synce-multisync_plugin/Manifest b/app-pda/synce-multisync_plugin/Manifest
new file mode 100644
index 000000000000..a3b346517e6b
--- /dev/null
+++ b/app-pda/synce-multisync_plugin/Manifest
@@ -0,0 +1,4 @@
+MD5 81ed52519d864b4a88eef32d3cc5be43 synce-multisync_plugin-0.8.2.ebuild 645
+MD5 fa1bc87d9b211f9b0570daaba1fd8c2f ChangeLog 350
+MD5 f535c81d12e32af4e46be4a1027fed85 metadata.xml 331
+MD5 a5f2f9c533a14ab27aa9565e8860f7e8 files/digest-synce-multisync_plugin-0.8.2 80