summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2006-07-10 16:55:15 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2006-07-10 16:55:15 +0000
commite566a8b3537e295802f642105f401394300b7b9c (patch)
tree3fc35c813486502e4b219e28773cb5f3fbbd8e05 /app-office
parentMark 1.0.2 stable on ia64 (diff)
downloadhistorical-e566a8b3537e295802f642105f401394300b7b9c.tar.gz
historical-e566a8b3537e295802f642105f401394300b7b9c.tar.bz2
historical-e566a8b3537e295802f642105f401394300b7b9c.zip
Revbump thanks to Pacho Ramos see #139823
Package-Manager: portage-2.1-r1
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword-plugins/ChangeLog8
-rw-r--r--app-office/abiword-plugins/abiword-plugins-2.4.5.ebuild76
-rw-r--r--app-office/abiword-plugins/files/digest-abiword-plugins-2.4.53
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/abiword-2.4.5.ebuild86
-rw-r--r--app-office/abiword/files/digest-abiword-2.4.53
6 files changed, 181 insertions, 2 deletions
diff --git a/app-office/abiword-plugins/ChangeLog b/app-office/abiword-plugins/ChangeLog
index 95d49c4c851f..6d3709043985 100644
--- a/app-office/abiword-plugins/ChangeLog
+++ b/app-office/abiword-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/abiword-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/ChangeLog,v 1.15 2006/05/17 17:27:14 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/ChangeLog,v 1.16 2006/07/10 16:55:15 gustavoz Exp $
+
+*abiword-plugins-2.4.5 (10 Jul 2006)
+
+ 10 Jul 2006; Gustavo Zacarias <gustavoz@gentoo.org>
+ +abiword-plugins-2.4.5.ebuild:
+ Revbump thanks to Pacho Ramos see #139823
*abiword-plugins-2.4.4 (17 May 2006)
diff --git a/app-office/abiword-plugins/abiword-plugins-2.4.5.ebuild b/app-office/abiword-plugins/abiword-plugins-2.4.5.ebuild
new file mode 100644
index 000000000000..54f285d176e3
--- /dev/null
+++ b/app-office/abiword-plugins/abiword-plugins-2.4.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/abiword-plugins-2.4.5.ebuild,v 1.1 2006/07/10 16:55:15 gustavoz Exp $
+
+inherit eutils
+
+DESCRIPTION="Set of plugins for abiword"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/abiword/${PV}/abiword-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bzip2 debug gnome grammar jpeg libgda math pdf readline svg thesaurus wmf wordperfect"
+S=${WORKDIR}/abiword-${PV}/${PN}
+
+# libgsf dependency used by some document format importers
+RDEPEND="=app-office/abiword-${PV}*
+ virtual/xft
+ >=media-libs/fontconfig-1
+ >=dev-libs/fribidi-0.10.4
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=gnome-extra/libgsf-1.12.1
+ bzip2? ( app-arch/bzip2 )
+ gnome? ( >=x11-libs/goffice-0.1 )
+ grammar? ( >=dev-libs/link-grammar-4.2.2 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ libgda? (
+ >=gnome-extra/libgda-1.2
+ >=gnome-extra/libgnomedb-1.2 )
+ math? ( >=x11-libs/gtkmathview-0.7.5 )
+ pdf? ( >=app-text/poppler-0.5.0-r1 )
+ readline? ( sys-libs/readline )
+ thesaurus? ( >=app-text/aiksaurus-1.2 )
+ wordperfect? ( >=app-text/libwpd-0.8 )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ svg? ( >=gnome-base/librsvg-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/poppler_abi_change.patch
+}
+
+src_compile() {
+ local myconf="--enable-all \
+ --with-abiword=${WORKDIR}/abiword-${PV}/abi \
+ $(use_enable debug) \
+ $(use_with bzip2 bz2abw) \
+ $(use_with gnome abigochart) \
+ $(use_with grammar abigrammar) \
+ $(use_with jpeg) \
+ $(use_with libgda gda) \
+ $(use_with math abimathview) \
+ $(use_with pdf) \
+ $(use_with readline abicommand)
+ $(use_with svg librsvg) \
+ $(use_with thesaurus aiksaurus) \
+ $(use_with wmf) \
+ $(use_with wordperfect) \
+ --without-psion"
+
+ econf $myconf || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/app-office/abiword-plugins/files/digest-abiword-plugins-2.4.5 b/app-office/abiword-plugins/files/digest-abiword-plugins-2.4.5
new file mode 100644
index 000000000000..92a5bbc12741
--- /dev/null
+++ b/app-office/abiword-plugins/files/digest-abiword-plugins-2.4.5
@@ -0,0 +1,3 @@
+MD5 e018669a154164d31c768f773a1c95b4 abiword-2.4.5.tar.bz2 24930028
+RMD160 f0de27f97135f8fff9b4400b05d74a27eee348cd abiword-2.4.5.tar.bz2 24930028
+SHA256 b8e5f61697c6d796e8f9f0812886666487fd0125bc777ca093c096b4b3e31264 abiword-2.4.5.tar.bz2 24930028
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 1df02e9010ec..520d2e8fc05d 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.152 2006/07/05 07:51:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.153 2006/07/10 16:51:51 gustavoz Exp $
+
+*abiword-2.4.5 (10 Jul 2006)
+
+ 10 Jul 2006; Gustavo Zacarias <gustavoz@gentoo.org> +abiword-2.4.5.ebuild:
+ Revbump thanks to Pacho Ramos see #139823
05 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
abiword-2.2.10.ebuild, abiword-2.2.11.ebuild, abiword-2.4.1.ebuild,
diff --git a/app-office/abiword/abiword-2.4.5.ebuild b/app-office/abiword/abiword-2.4.5.ebuild
new file mode 100644
index 000000000000..cf9e5bed145a
--- /dev/null
+++ b/app-office/abiword/abiword-2.4.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.5.ebuild,v 1.1 2006/07/10 16:51:51 gustavoz Exp $
+
+inherit eutils fdo-mime alternatives
+
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gnome spell xml"
+
+LICENSE="GPL-2"
+SLOT="2"
+
+RDEPEND="virtual/xft
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2.4
+ >=x11-libs/pango-1.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ sys-libs/zlib
+ >=media-libs/libpng-1.2
+ dev-libs/popt
+ >=media-libs/fontconfig-2.1
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ xml? ( >=dev-libs/libxml2-2.4.10 )
+ !xml? ( dev-libs/expat )
+ spell? ( >=app-text/enchant-1.1 )
+ gnome? (
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-extra/gucharmap-1.4 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_compile() {
+ # this is a hack since I don't want to go hack in the gnome-vfs
+ # headerfiles. The issue is about gnome-vfs containing "long long"
+ # which makes gcc 3.3.1 balk
+ sed -i -e 's:-pedantic::g' configure
+
+ local myconf="$(use_enable gnome) \
+ $(use_enable gnome gucharmap) \
+ $(use_enable spell enchant) \
+ $(use_enable debug) \
+ $(use_with xml libxml2) \
+ --enable-threads \
+ --disable-scripting \
+ --with-sys-wv"
+
+ econf $myconf || die "./configure failed"
+
+ emake all-recursive || die "Compilation failed"
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dosed "s:Exec=abiword:Exec=abiword-2.4:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword-2.4
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.4 /usr/bin/abiword-2.4
+
+ dodoc *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ alternatives_auto_makesym "/usr/bin/abiword" "/usr/bin/abiword-[0-9].[0-9]"
+
+ einfo "As of version 2.4, all abiword plugins have been moved"
+ einfo "into a seperate abiword-plugins package"
+ einfo "You can install them by running emerge abiword-plugins"
+}
diff --git a/app-office/abiword/files/digest-abiword-2.4.5 b/app-office/abiword/files/digest-abiword-2.4.5
new file mode 100644
index 000000000000..92a5bbc12741
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-2.4.5
@@ -0,0 +1,3 @@
+MD5 e018669a154164d31c768f773a1c95b4 abiword-2.4.5.tar.bz2 24930028
+RMD160 f0de27f97135f8fff9b4400b05d74a27eee348cd abiword-2.4.5.tar.bz2 24930028
+SHA256 b8e5f61697c6d796e8f9f0812886666487fd0125bc777ca093c096b4b3e31264 abiword-2.4.5.tar.bz2 24930028