summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-01 13:22:04 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-01 13:22:04 +0000
commitdf42bc66c04c44de239d9fa8b00f518dafcded58 (patch)
tree13f70090ba19be810d30b2fcaeb3d170cfd1ce49 /app-office
parentcode clean (diff)
downloadhistorical-df42bc66c04c44de239d9fa8b00f518dafcded58.tar.gz
historical-df42bc66c04c44de239d9fa8b00f518dafcded58.tar.bz2
historical-df42bc66c04c44de239d9fa8b00f518dafcded58.zip
lyx 1.2.0, a great new version.
also: lyx-base and lyx-utils are now deprecated (as per my recent -core post), they were imho both ugly and unnecessary. from now on app-office/lyx will both install lyx itslf and (r)depend on all the utils.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/ChangeLog12
-rw-r--r--app-office/lyx/files/digest-lyx-1.2.01
-rw-r--r--app-office/lyx/lyx-1.2.0.ebuild64
3 files changed, 76 insertions, 1 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index e54a66122dd0..bde939f62547 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-office/lyx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.1 2002/02/01 21:53:09 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.2 2002/06/01 13:22:04 danarmak Exp $
+
+*lyx-1.2.0 (1 Jun 2002)
+
+ 1 Jun 2002; Dan Armak <danarmak@gentoo.org> changelog:
+
+ The great new release of lyx (see changelog).
+ The lyx=lyx-base+lyx-utils scheme has been abandoned; the app-office/lyx-base
+ and app-office/lyx-utils ebuilds have been deprecated. I think they are
+ unnecessary. From now on, app-office/lyx will both install lyx itslf and
+ depend on all the lyx utils.
*lyx-1.1.6.4 (1 Feb 2002)
diff --git a/app-office/lyx/files/digest-lyx-1.2.0 b/app-office/lyx/files/digest-lyx-1.2.0
new file mode 100644
index 000000000000..1f91ab1787f7
--- /dev/null
+++ b/app-office/lyx/files/digest-lyx-1.2.0
@@ -0,0 +1 @@
+MD5 cc7592d311f3dfd2db01f9ca5e506fb6 lyx-1.2.0.tar.gz 6418424
diff --git a/app-office/lyx/lyx-1.2.0.ebuild b/app-office/lyx/lyx-1.2.0.ebuild
new file mode 100644
index 000000000000..f1003f8b6943
--- /dev/null
+++ b/app-office/lyx/lyx-1.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.0.ebuild,v 1.1 2002/06/01 13:22:04 danarmak Exp $
+
+# The real version of LyX is 1.1.6fix4. As Portage has no support for
+# arbitrary suffixes like 'fix', this is translated into 1.1.6.4.
+S=${WORKDIR}/${P}
+DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
+HOMEPAGE="http://www.lyx.org/"
+LICENSE=GPL-2
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ x11-libs/xforms
+ app-text/tetex
+ >=sys-devel/perl-5
+ nls? ( sys-devel/gettext )
+ app-text/aiksaurus"
+RDEPEND="$DEPEND
+ app-text/ghostscript
+ app-text/xpdf
+ app-text/ispell
+ app-text/gv
+ app-text/latex2html
+ media-gfx/imagemagick
+ cups? ( virtual/lpr )
+ app-text/rcs
+ dev-util/cvs
+ app-text/sgmltools-lite
+ app-text/noweb"
+# app-text/chktex"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
+
+ # -O3 and higher breaks (at least with gcc 2)
+ export CXXFLAGS="${CXXFLAGS//-O[3..9]/-O2}"
+ export CFLAGS="${CFLAGS//-O[3..9]/-O2}"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir='$(prefix)/share/info' \
+ --with-extra-inc=/usr/X11R6/include \
+ --mandir='$(prefix)/share/man' \
+ ${myconf} || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ # The 'install-strip' target is provided by the LyX makefile
+ # for stripping installed binaries. Use prefix= instead of
+ # DESTDIR=, otherwise it violates the sandbox in the po directory.
+ make prefix=${D}/usr install
+ dodoc README* UPGRADING INSTALL* ChangeLog NEW COPYING ANNOUNCE ABOUT-NLS
+}
+