summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-08-17 12:48:05 +0000
committerTroy Dack <tad@gentoo.org>2003-08-17 12:48:05 +0000
commitab34c6b268ae40e93b992c8131091c4b86052b23 (patch)
tree58d53f606fb6cc197ee9a32dd74bb91df00d80c7 /app-office
parentVersion bump to 1.1_rc3 (diff)
downloadhistorical-ab34c6b268ae40e93b992c8131091c4b86052b23.tar.gz
historical-ab34c6b268ae40e93b992c8131091c4b86052b23.tar.bz2
historical-ab34c6b268ae40e93b992c8131091c4b86052b23.zip
Version bump to 1.1_rc3
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-bin/Manifest4
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-1.1_rc31
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1_rc3.ebuild229
3 files changed, 232 insertions, 2 deletions
diff --git a/app-office/openoffice-bin/Manifest b/app-office/openoffice-bin/Manifest
index 256667b6b925..5f79ed52585a 100644
--- a/app-office/openoffice-bin/Manifest
+++ b/app-office/openoffice-bin/Manifest
@@ -2,10 +2,10 @@ MD5 87cdcf3dcef19c66ccfd76ef09dbfc85 openoffice-bin-1.1_rc2.ebuild 6344
MD5 98d48815cb1b470eaa680bee025cd825 openoffice-bin-1.0.2.ebuild 6174
MD5 286e13ebb4c41e2b2a502ac3b12fa6b4 openoffice-bin-1.0.3.1.ebuild 6448
MD5 56ef01c9cde2c8d14a33456381be87a5 openoffice-bin-1.1_rc1.ebuild 6345
-MD5 ff7eb4a7e3f2d9c38ae0eb284a61946b openoffice-bin-1.1_rc3.ebuild 6376
+MD5 97ebaa004033e97d1464da173ce04db7 openoffice-bin-1.1_rc3.ebuild 6373
MD5 1d4d7e2d4125513818b334f9be8a9dcb openoffice-bin-1.1_beta2-r1.ebuild 6285
MD5 7576a51aef82508612fa18256c0e7c85 openoffice-bin-1.0.3.ebuild 6167
-MD5 6f967c35c22761414765b3bfa7aa050f ChangeLog 5789
+MD5 91258107ea411fbc00f272d5fba0cb7e ChangeLog 5952
MD5 b53b5b274336275ed73675bae1fc5dfc files/digest-openoffice-bin-1.1_beta2-r1 85
MD5 6bb2dccd6a53a5457be6670d628c77d3 files/digest-openoffice-bin-1.0.2 168
MD5 7f69df73d15c5fca3829e9f3083cf440 files/digest-openoffice-bin-1.0.3 82
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-1.1_rc3 b/app-office/openoffice-bin/files/digest-openoffice-bin-1.1_rc3
new file mode 100644
index 000000000000..46218413aa47
--- /dev/null
+++ b/app-office/openoffice-bin/files/digest-openoffice-bin-1.1_rc3
@@ -0,0 +1 @@
+MD5 3ce7aa3a924035e11fe9a4519b0b52b9 OOo_1.1rc3_LinuxIntel_install.tar.gz 78657276
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1_rc3.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1_rc3.ebuild
new file mode 100644
index 000000000000..afbfbf952e82
--- /dev/null
+++ b/app-office/openoffice-bin/openoffice-bin-1.1_rc3.ebuild
@@ -0,0 +1,229 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1_rc3.ebuild,v 1.1 2003/08/17 12:47:53 tad Exp $
+
+IUSE="kde gnome"
+
+inherit virtualx
+
+# NOTE: There are two big issues that should be addressed.
+#
+# 1) Language support and fonts should be addressed.
+
+LOC="/opt"
+
+INSTDIR="${LOC}/OpenOffice.org${PV}"
+#MY_PV="`echo ${PV} | gawk '{ print tolower($1) }'`"
+MY_PV="${PV/_rc3/rc3}"
+
+#No PPC rc3 as yet
+#if [ `use ppc` ]; then
+# MY_PV="${MY_PV/rc/RC}"
+# MY_P="OOo_${MY_PV}_LinuxPPC_installer"
+# S="${WORKDIR}/${MY_P}"
+#else
+ MY_P="OOo_${MY_PV}_LinuxIntel_install"
+ S="${WORKDIR}/${MY_P}"
+#fi;
+
+DESCRIPTION="OpenOffice productivity suite"
+SRC_URI="x86? ( http://vlaai.snt.utwente.nl/pub/software/openoffice/stable/${MY_PV}/OOo_${MY_PV}_LinuxIntel_install.tar.gz
+ http://openoffice.mirrors.pair.com/stable/${MY_PV}/OOo_${MY_PV}_LinuxIntel_install.tar.gz )"
+# ppc? ( ftp://ftp.yellowdoglinux.com/pub/yellowdog/software/openoffice/OOo_${MY_PV}_LinuxPPC_installer.tar.gz )"
+
+HOMEPAGE="http://www.openoffice.org"
+
+DEPEND="sys-apps/findutils
+ virtual/glibc
+ >=dev-lang/perl-5.0
+ virtual/x11
+ app-arch/zip
+ app-arch/unzip
+ || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
+ !app-office/openoffice"
+
+RDEPEND="virtual/glibc
+ >=dev-lang/perl-5.0
+ virtual/x11
+ app-arch/zip
+ app-arch/unzip
+ || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
+ !app-office/openoffice"
+
+LICENSE="LGPL-2 | SISSL-1.1"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc "
+
+src_install() {
+ # Sandbox issues; bug #8587
+ addpredict "/user"
+ addpredict "/share"
+ addpredict "/pspfontcache"
+ addpredict "/usr/bin/soffice"
+
+ # Sandbox issues; bug 8063
+ addpredict "/dev/dri"
+
+ # Autoresponse file for main installation
+ cat > ${T}/rsfile-global <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_NETWORK
+ INSTALLATIONTYPE=STANDARD
+ DESTINATIONPATH=<destdir>
+ OUTERPATH=
+ LOGFILE=
+ LANGUAGELIST=<LANGUAGE>
+
+ [JAVA]
+ JavaSupport=preinstalled_or_none
+ END_RS
+
+ # Autoresponse file for user isntallation
+ cat > ${T}/rsfile-local <<-"END_RS"
+ [ENVIRONMENT]
+ INSTALLATIONMODE=INSTALL_WORKSTATION
+ INSTALLATIONTYPE=WORKSTATION
+ DESTINATIONPATH=<home>/.openoffice/<pv>
+
+ [JAVA]
+ JavaSupport=none
+ END_RS
+
+ # Fixing install location in response file
+ sed -e "s|<destdir>|${D}${INSTDIR}|" \
+ ${T}/rsfile-global > ${T}/autoresponse
+
+ einfo "Installing OpenOffice.org into build root..."
+ dodir ${INSTDIR}
+ cd ${S}
+ # Setup virtualmake
+ export maketype="./setup"
+ # We need X to install...
+ virtualmake "-v -r:${T}/autoresponse"
+
+ echo
+ einfo "Removing build root from registry..."
+ # Remove totally useless stuff.
+ rm -f ${D}${INSTDIR}/program/{setup.log,sopatchlevel.sh}
+ # Remove build root from registry and co
+ egrep -rl "${D}" ${D}${INSTDIR}/* | \
+ xargs -i perl -pi -e "s|${D}||g" {} || :
+
+ einfo "Fixing permissions..."
+ # Fix permissions
+ find ${D}${INSTDIR}/ -type f -exec chmod a+r {} \;
+ chmod a+x ${D}${INSTDIR}/share/config/webcast/*.pl
+
+ # Fix symlinks
+ for x in "soffice program/spadmin" \
+ "program/setup setup" \
+ "program/spadmin spadmin"
+ do
+ dosym $(echo ${x} | awk '{print $1}') \
+ ${INSTDIR}/$(echo ${x} | awk '{print $2}')
+ done
+
+ # Install user autoresponse file
+ insinto /etc/openoffice
+ sed -e "s|<pv>|${PV//_rc3}|g" ${T}/rsfile-local > ${T}/autoresponse-${PV}.conf
+ doins ${T}/autoresponse-${PV}.conf
+
+ # Install wrapper script
+ exeinto /usr/bin
+ sed -e "s|<pv>|${PV}|g" \
+ ${FILESDIR}/${PV}/ooffice-wrapper-1.3 > ${T}/ooffice
+ doexe ${T}/ooffice
+ # Component symlinks
+ dosym ooffice /usr/bin/oocalc
+ dosym ooffice /usr/bin/oodraw
+ dosym ooffice /usr/bin/ooimpress
+ dosym ooffice /usr/bin/oomath
+ dosym ooffice /usr/bin/oowriter
+ dosym ooffice /usr/bin/ooweb
+ dosym ooffice /usr/bin/oosetup
+ dosym ooffice /usr/bin/oopadmin
+
+ einfo "Installing Menu shortcuts (need \"gnome\" or \"kde\" in USE)..."
+ if [ -n "`use gnome`" ]
+ then
+ insinto /usr/share/gnome/apps/OpenOffice.org
+ # Install the files needed for the catagory
+ doins ${D}${INSTDIR}/share/gnome/net/.directory
+ doins ${D}${INSTDIR}/share/gnome/net/.order
+
+ # Change this to ooo*.desktop from *.desktop for now, since
+ # otherwise two sets of icons will appear in the GNOME menu.
+ # <brad@gentoo.org> (04 Aug 2003)
+ for x in ${D}${INSTDIR}/share/gnome/net/ooo*.desktop
+ do
+ # We have to handle setup differently
+ perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
+ # Now fix the rest
+ perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
+ doins ${x}
+ done
+ fi
+
+ if [ -n "`use kde`" ]
+ then
+ local kdeloc="${D}${INSTDIR}/share/kde/net/"
+
+ insinto /usr/share/applnk/OpenOffice.org\ 1.1
+ # Install the files needed for the catagory
+ doins ${kdeloc}/.directory
+ doins ${kdeloc}/.order
+ dodir /usr/share
+ # Install the icons and mime info
+ cp -r ${D}${INSTDIR}/share/kde/net/share/mimelnk ${D}${INSTDIR}/share/kde/net/share/icons ${D}/usr/share
+
+ for x in ${kdeloc}/*.desktop
+ do
+ # We have to handle setup differently
+ perl -pi -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
+ # Now fix the rest
+ perl -pi -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
+ doins ${x}
+ done
+ fi
+
+ # Unneeded, as they get installed into /usr/share...
+# rm -rf ${D}${INSTDIR}/share/{cde,gnome,kde}
+ rm -rf ${D}${INSTDIR}/share/cde
+
+ for f in ${D}/usr/share/gnome/apps/OpenOffice.org/* ; do
+ echo 'Categories=Application;Office;' >> ${f}
+ done
+
+
+ # Make sure these do not get nuked.
+ keepdir ${INSTDIR}/user/registry/res/en-us/org/openoffice/{Office,ucb}
+ keepdir ${INSTDIR}/user/psprint/{driver,fontmetric}
+ keepdir ${INSTDIR}/user/{autocorr,backup,plugin,store,temp,template}
+
+ #touch files to make portage uninstalling happy (#22593)
+ find ${D} -type f -exec touch {} \;
+}
+
+pkg_preinst() {
+
+ # The one with OO-1.0.0 was not valid
+ if [ -f ${ROOT}/etc/openoffice/autoresponse.conf ]
+ then
+ rm -f ${ROOT}/etc/openoffice/autoresponse.conf
+ fi
+}
+
+pkg_postinst() {
+
+ einfo "******************************************************************"
+ einfo " To start OpenOffice.org, run:"
+ einfo
+ einfo " $ ooffice"
+ einfo
+ einfo " Also, for individual components, you can use any of:"
+ einfo
+ einfo " oocalc, oodraw, ooimpress, oomath, ooweb or oowriter"
+ einfo
+ einfo "******************************************************************"
+}
+