summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2005-01-29 14:48:52 +0000
committerSimone Gotti <motaboy@gentoo.org>2005-01-29 14:48:52 +0000
commit665e9dec59b566e605c247f016c466da367bdb9c (patch)
treeadb3082bf07111a504a7dedf6b2752ffc986a411 /app-office
parentAdded dev-cpp/glibmm to DEPEND and closing bug #79922. (diff)
downloadhistorical-665e9dec59b566e605c247f016c466da367bdb9c.tar.gz
historical-665e9dec59b566e605c247f016c466da367bdb9c.tar.bz2
historical-665e9dec59b566e605c247f016c466da367bdb9c.zip
Add blockers on split packages derived from koffice.
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/ChangeLog6
-rw-r--r--app-office/koffice/Manifest20
-rw-r--r--app-office/koffice/koffice-1.3.5-r1.ebuild12
-rw-r--r--app-office/koffice/koffice-1.3.5-r2.ebuild12
4 files changed, 28 insertions, 22 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 19d718f7f404..03797522796b 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.97 2005/01/21 20:50:08 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.98 2005/01/29 14:48:52 motaboy Exp $
+
+ 29 Jan 2005; Simone Gotti <motaboy@gentoo.org> koffice-1.3.5-r1.ebuild,
+ koffice-1.3.5-r2.ebuild:
+ Add blockers on split packages derived from koffice.
21 Jan 2005; Bryan Østergaard <kloeri@gentoo.org>
koffice-1.3.5-r2.ebuild:
diff --git a/app-office/koffice/Manifest b/app-office/koffice/Manifest
index d03a95cc0c94..f9b5d937d6a8 100644
--- a/app-office/koffice/Manifest
+++ b/app-office/koffice/Manifest
@@ -1,18 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 5e43f1b06367878a5a3a497d8597e0b5 koffice-1.3.5-r1.ebuild 982
-MD5 371a9e1c63fe2ffe6a649bf29f2958d2 ChangeLog 13650
-MD5 5d1987a0297a4a67dee4dcda3387bb77 koffice-1.3.5-r2.ebuild 1018
+MD5 2cdccb784a11549436811e2e18023e99 koffice-1.3.5-r1.ebuild 1171
+MD5 21079c2a7ec84f809ea6ea3701e031aa ChangeLog 13808
MD5 96a4184e1e3325923219a5f96a5511a5 metadata.xml 163
-MD5 12452317cab5461eb911114062f2cce2 files/digest-koffice-1.3.5-r1 68
+MD5 bdcb79a8db04904d6e6c7110e0ff3ec9 koffice-1.3.5-r2.ebuild 1211
MD5 6ee3768e50296eb2a8158093ee518133 files/CAN-2005-0064.patch 829
-MD5 12452317cab5461eb911114062f2cce2 files/digest-koffice-1.3.5-r2 68
MD5 77399be6733ffca4ed1142ab319c1453 files/koffice_1_3_xpdf_buffer_overflow.diff 1808
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFB8WsNugEuf3OQ0akRAqA1AKCNt7DZjD9HNr0FEY/5bHFDh8xsjACfbhBv
-BQ6oscZHxi/C6b0aeNL4xjs=
-=pIu9
------END PGP SIGNATURE-----
+MD5 12452317cab5461eb911114062f2cce2 files/digest-koffice-1.3.5-r1 68
+MD5 12452317cab5461eb911114062f2cce2 files/digest-koffice-1.3.5-r2 68
diff --git a/app-office/koffice/koffice-1.3.5-r1.ebuild b/app-office/koffice/koffice-1.3.5-r1.ebuild
index 0484a0c45036..946c834c525b 100644
--- a/app-office/koffice/koffice-1.3.5-r1.ebuild
+++ b/app-office/koffice/koffice-1.3.5-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.5-r1.ebuild,v 1.7 2005/01/01 15:35:59 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.5-r1.ebuild,v 1.8 2005/01/29 14:48:52 motaboy Exp $
-inherit kde eutils
+inherit kde kde-functions eutils
# TODO : mysql support
# other refs from configure: jasper, qt-docs, doxygen, libxml2, libxslt, freetype, fontconfig, qt being built with sql support (???)
@@ -16,8 +16,14 @@ KEYWORDS="x86 amd64 ppc sparc alpha ppc64"
IUSE=""
SLOT="0"
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
-DEPEND=">=dev-lang/python-2.2.1
+DEPEND="${DEPEND}
+ >=dev-lang/python-2.2.1
>=media-libs/libart_lgpl-2.3.9
>=media-gfx/imagemagick-5.4.5
>=app-text/wv2-0.1.8
diff --git a/app-office/koffice/koffice-1.3.5-r2.ebuild b/app-office/koffice/koffice-1.3.5-r2.ebuild
index 1c8c17edb627..cbb857c2fcd9 100644
--- a/app-office/koffice/koffice-1.3.5-r2.ebuild
+++ b/app-office/koffice/koffice-1.3.5-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.5-r2.ebuild,v 1.6 2005/01/21 20:50:08 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.5-r2.ebuild,v 1.7 2005/01/29 14:48:52 motaboy Exp $
-inherit kde eutils
+inherit kde kde-functions eutils
# TODO : mysql support
# other refs from configure: jasper, qt-docs, doxygen, libxml2, libxslt, freetype, fontconfig, qt being built with sql support (???)
@@ -16,8 +16,14 @@ KEYWORDS="x86 amd64 ppc sparc alpha ppc64"
IUSE=""
SLOT="0"
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
-DEPEND=">=dev-lang/python-2.2.1
+DEPEND="${DEPEND}
+ >=dev-lang/python-2.2.1
>=media-libs/libart_lgpl-2.3.9
>=media-gfx/imagemagick-5.4.5
>=app-text/wv2-0.1.8