summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 18:58:54 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 18:58:54 +0000
commit26db6fb0eb05ea7c5e8ab79e33369c5c8f639cfb (patch)
treebbddbdc775af524eef8943bcc0eec02b132b8683 /app-office/lyx
parentVersion bump. (diff)
downloadhistorical-26db6fb0eb05ea7c5e8ab79e33369c5c8f639cfb.tar.gz
historical-26db6fb0eb05ea7c5e8ab79e33369c5c8f639cfb.tar.bz2
historical-26db6fb0eb05ea7c5e8ab79e33369c5c8f639cfb.zip
use eutils for epatch
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/lyx-1.3.2-r1.ebuild21
-rw-r--r--app-office/lyx/lyx-1.3.4.ebuild10
2 files changed, 15 insertions, 16 deletions
diff --git a/app-office/lyx/lyx-1.3.2-r1.ebuild b/app-office/lyx/lyx-1.3.2-r1.ebuild
index 7de0d3afac10..7233040022ed 100644
--- a/app-office/lyx/lyx-1.3.2-r1.ebuild
+++ b/app-office/lyx/lyx-1.3.2-r1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.2-r1.ebuild,v 1.15 2004/01/30 05:23:03 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.2-r1.ebuild,v 1.16 2004/04/07 18:58:54 vapier Exp $
+
+inherit kde-functions eutils
DESCRIPTION="WYSIWYM frontend for LaTeX"
HOMEPAGE="http://www.lyx.org/"
SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
http://www.math.tau.ac.il/~dekelts/lyx/files/hebrew.bind
http://www.math.tau.ac.il/~dekelts/lyx/files/preferences"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
IUSE="nls cups qt debug gnome"
@@ -32,8 +34,7 @@ RDEPEND="${DEPEND}
app-text/sgmltools-lite
app-text/noweb
dev-tex/chktex"
-
-DEPEND="$DEPEND >=sys-devel/autoconf-2.58"
+DEPEND="${DEPEND} >=sys-devel/autoconf-2.58"
src_unpack() {
unpack ${A}
@@ -43,8 +44,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if [ `use qt` ]; then
- inherit kde-functions
+ if use qt ; then
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else
@@ -73,21 +73,20 @@ src_compile() {
}
src_install() {
- einstall
- dodoc README* UPGRADING INSTALL* ChangeLog NEWS COPYING ANNOUNCE ABOUT-NLS $DISTDIR/preferences
+ einstall || die
+ dodoc README* UPGRADING INSTALL* ChangeLog NEWS ANNOUNCE ABOUT-NLS $DISTDIR/preferences
insinto /usr/share/lyx/bind
doins $DISTDIR/hebrew.bind
# gnome menu entry
- if use gnome; then
+ if use gnome ; then
insinto /usr/share/applications
doins ${FILESDIR}/lyx.desktop
fi
-
}
pkg_postinst() {
- if [ `use qt` ] ; then
+ if use qt ; then
einfo "WARNING: the QT gui, together with xft2+fontconfig (which you"
einfo "almost certainly have), suffer from one infamous bug that causes"
einfo "the matheditor not to display any special characters (the ones from"
diff --git a/app-office/lyx/lyx-1.3.4.ebuild b/app-office/lyx/lyx-1.3.4.ebuild
index 229a4a7c51b2..f093a0da1361 100644
--- a/app-office/lyx/lyx-1.3.4.ebuild
+++ b/app-office/lyx/lyx-1.3.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.4.ebuild,v 1.2 2004/02/21 20:25:10 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.4.ebuild,v 1.3 2004/04/07 18:56:31 vapier Exp $
-inherit kde-functions
+inherit kde-functions eutils
DESCRIPTION="WYSIWYM frontend for LaTeX"
HOMEPAGE="http://www.lyx.org/"
@@ -10,10 +10,10 @@ SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
http://movementarian.org/latex-xft-fonts-0.1.tar.gz
http://www.math.tau.ac.il/~dekelts/lyx/files/hebrew.bind
http://www.math.tau.ac.il/~dekelts/lyx/files/preferences"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+KEYWORDS="~x86 ~ppc ~sparc amd64"
IUSE="nls cups qt debug gnome"
# these dependencies need looking at.
@@ -51,7 +51,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if [ -n "`use qt`" ]; then
+ if use qt ; then
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else