summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-04-23 00:28:27 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-04-23 00:28:27 +0000
commite4e320e67d893078797d0852db014c2ec01b5d92 (patch)
treed7a9de52b3adeb62d7c31714f3d8a54028f8cb6f /app-office/koffice
parentRemoved old versions. (diff)
downloadhistorical-e4e320e67d893078797d0852db014c2ec01b5d92.tar.gz
historical-e4e320e67d893078797d0852db014c2ec01b5d92.tar.bz2
historical-e4e320e67d893078797d0852db014c2ec01b5d92.zip
move python stuff out of global scope
Diffstat (limited to 'app-office/koffice')
-rw-r--r--app-office/koffice/ChangeLog6
-rw-r--r--app-office/koffice/Manifest8
-rw-r--r--app-office/koffice/koffice-1.2.1-r1.ebuild9
-rw-r--r--app-office/koffice/koffice-1.3.ebuild9
4 files changed, 20 insertions, 12 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 0a67999ab5c7..d32600e4ca4b 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.41 2004/04/20 15:48:26 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.42 2004/04/23 00:28:27 caleb Exp $
+
+ 22 Apr 2004; Caleb Tennis <caleb@gentoo.org> koffice-1.2.1-r1.ebuild,
+ koffice-1.3.ebuild:
+ Move python stuff out of global scope
20 Apr 2004; Martin Holzer <mholzer@gentoo.org> koffice-1.2.1-r1.ebuild:
fixing qa issue with autoconf/automake
diff --git a/app-office/koffice/Manifest b/app-office/koffice/Manifest
index 373141d6b230..747a30998397 100644
--- a/app-office/koffice/Manifest
+++ b/app-office/koffice/Manifest
@@ -1,7 +1,7 @@
-MD5 50450db141e86fe06f06d8e18fa8edf7 ChangeLog 6350
-MD5 f2f63ef236de709abff4b62311532326 koffice-1.2.1-r1.ebuild 847
+MD5 1021b61af228d00bbfed764f718a2f39 koffice-1.2.1-r1.ebuild 883
+MD5 dcb7f603c69a13d9c1a7a62e2d801fa9 koffice-1.3.ebuild 906
+MD5 268bd7cb1fe58199f624377a69307e9e ChangeLog 6483
MD5 3567b0f5f53ad3a98e67fe21ecb23624 metadata.xml 225
-MD5 71cb7d1837e52c28428d68695e40961b koffice-1.3.ebuild 938
-MD5 75c9f696b717a82bf663b4c545be66d2 files/digest-koffice-1.2.1-r1 67
MD5 bd89862f0c15396ad54e30a1c9f2f5d9 files/koffice-1.2.1-kword-crashes.diff 3840
MD5 65a32b814eb23f48f2392f1ae13ac167 files/digest-koffice-1.3 66
+MD5 75c9f696b717a82bf663b4c545be66d2 files/digest-koffice-1.2.1-r1 67
diff --git a/app-office/koffice/koffice-1.2.1-r1.ebuild b/app-office/koffice/koffice-1.2.1-r1.ebuild
index f9925b9c90db..2bf2a086af40 100644
--- a/app-office/koffice/koffice-1.2.1-r1.ebuild
+++ b/app-office/koffice/koffice-1.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2.1-r1.ebuild,v 1.9 2004/04/20 15:48:26 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2.1-r1.ebuild,v 1.10 2004/04/23 00:28:27 caleb Exp $
inherit kde-base flag-o-matic
filter-flags "-fomit-frame-pointer"
@@ -21,8 +21,11 @@ DEPEND="$DEPEND
PATCHES="$FILESDIR/${P}-kword-crashes.diff"
-export LIBPYTHON="`python-config --libs`"
-export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+src_compile() {
+ export LIBPYTHON="`python-config --libs`"
+ export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+ kde_src_compile
+}
export WANT_AUTOCONF=2.5
export WANT_AUTOMAKE=1.5
diff --git a/app-office/koffice/koffice-1.3.ebuild b/app-office/koffice/koffice-1.3.ebuild
index cacefc51fc64..ab8fa3ed4827 100644
--- a/app-office/koffice/koffice-1.3.ebuild
+++ b/app-office/koffice/koffice-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.ebuild,v 1.5 2004/04/16 01:15:25 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.ebuild,v 1.6 2004/04/23 00:28:27 caleb Exp $
inherit kde
# TODO : mysql support
@@ -24,6 +24,7 @@ DEPEND="$DEPEND
>=app-text/wv2-0.1.8
dev-util/pkgconfig"
-export LIBPYTHON="`python-config --libs`"
-#export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
-
+src_compile() {
+ export LIBPYTHON="`python-config --libs`"
+ kde_src_compile
+}