summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-06-15 09:56:00 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-06-15 09:56:00 +0000
commit8750e6359849729d44ecb3957ee8d0e926e458d5 (patch)
treed7a5029fdf943f3e0464e7649275ec95f925fc41 /app-mobilephone/smstools
parentMention FEATURES=-collision-protect in the pkg-postinst einfo notes, thanks t... (diff)
downloadhistorical-8750e6359849729d44ecb3957ee8d0e926e458d5.tar.gz
historical-8750e6359849729d44ecb3957ee8d0e926e458d5.tar.bz2
historical-8750e6359849729d44ecb3957ee8d0e926e458d5.zip
Automatically create directory structure necessary for normal operation as suggested by Graham Murray <gmurray@webwayone.co.uk> in bug #136861. Patched smsd to ignore portage dirlocks.
Package-Manager: portage-2.1
Diffstat (limited to 'app-mobilephone/smstools')
-rw-r--r--app-mobilephone/smstools/ChangeLog11
-rw-r--r--app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch38
-rw-r--r--app-mobilephone/smstools/files/digest-smstools-2.2.1-r13
-rw-r--r--app-mobilephone/smstools/smstools-2.2.1-r1.ebuild41
4 files changed, 92 insertions, 1 deletions
diff --git a/app-mobilephone/smstools/ChangeLog b/app-mobilephone/smstools/ChangeLog
index 8cebf2990291..35c9a4abe1ac 100644
--- a/app-mobilephone/smstools/ChangeLog
+++ b/app-mobilephone/smstools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-mobilephone/smstools
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/ChangeLog,v 1.1 2006/06/14 13:55:58 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/ChangeLog,v 1.2 2006/06/15 09:56:00 chainsaw Exp $
+
+*smstools-2.2.1-r1 (15 Jun 2006)
+
+ 15 Jun 2006; Tony Vroon <chainsaw@gentoo.org>
+ +files/2.2.1-skip-dirlock.patch, -smstools-2.2.1.ebuild,
+ +smstools-2.2.1-r1.ebuild:
+ Automatically create directory structure necessary for normal operation as
+ suggested by Graham Murray <gmurray@webwayone.co.uk> in bug #136861. Patched
+ smsd to ignore portage .keep files.
*smstools-2.2.1 (14 Jun 2006)
diff --git a/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch b/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch
new file mode 100644
index 000000000000..64336eed98a1
--- /dev/null
+++ b/app-mobilephone/smstools/files/2.2.1-skip-dirlock.patch
@@ -0,0 +1,38 @@
+--- src/extras.c.orig 2006-06-15 10:45:59.000000000 +0100
++++ src/extras.c 2006-06-15 10:45:39.000000000 +0100
+@@ -178,20 +178,21 @@
+ stat(filename,&statbuf);
+ if (S_ISDIR(statbuf.st_mode)==0) /* Is this a directory? */
+ {
+- /* File found, check for lock file */
+- if (strstr(filename,".LOCK")==0) /* Is the file a lock file itself? */
+- if (!islocked(filename)) /* no, is there a lock file for this file? */
+- {
+- /* check if the file grows at the moment (another program writes to it) */
+- int groesse1;
+- int groesse2;
+- groesse1=statbuf.st_size;
+- sleep(1);
+- stat(filename,&statbuf);
+- groesse2=statbuf.st_size;
+- if (groesse1==groesse2)
+- found=1;
+- }
++ /* File found, check for lock file and skip portage directory locks */
++ if (strstr(filename,".keep")==0) /* Is it a portage directory lock? */
++ if (strstr(filename,".LOCK")==0) /* Is the file a lock file itself? */
++ if (!islocked(filename)) /* no, is there a lock file for this file? */
++ {
++ /* check if the file grows at the moment (another program writes to it) */
++ int groesse1;
++ int groesse2;
++ groesse1=statbuf.st_size;
++ sleep(1);
++ stat(filename,&statbuf);
++ groesse2=statbuf.st_size;
++ if (groesse1==groesse2)
++ found=1;
++ }
+ }
+ }
+ closedir(dirdata);
diff --git a/app-mobilephone/smstools/files/digest-smstools-2.2.1-r1 b/app-mobilephone/smstools/files/digest-smstools-2.2.1-r1
new file mode 100644
index 000000000000..d1371e7da4bc
--- /dev/null
+++ b/app-mobilephone/smstools/files/digest-smstools-2.2.1-r1
@@ -0,0 +1,3 @@
+MD5 bead6068622b7c177a8cc0628b238050 smstools-2.2.1.tar.gz 167696
+RMD160 88025010cd7cd399dd21cf61e0857c6bd3c4d774 smstools-2.2.1.tar.gz 167696
+SHA256 dbe054b0ff0cc2d3a8168af18a3a7efbf6f5c3ddee11709fe0ccadaefd9dfada smstools-2.2.1.tar.gz 167696
diff --git a/app-mobilephone/smstools/smstools-2.2.1-r1.ebuild b/app-mobilephone/smstools/smstools-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..43574632ca0f
--- /dev/null
+++ b/app-mobilephone/smstools/smstools-2.2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/smstools-2.2.1-r1.ebuild,v 1.1 2006/06/15 09:56:00 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="Send and receive short messages through GSM modems"
+HOMEPAGE="http://smstools.meinemullemaus.de/"
+SRC_URI="http://www.meinemullemaus.de/software/${PN}/packages/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-skip-dirlock.patch
+}
+
+src_compile() {
+ cd src
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin src/smsd
+ dobin scripts/sendsms scripts/sms2html
+ dobin scripts/sms2unicode scripts/unicode2sms
+
+ keepdir /var/spool/sms/incoming
+ keepdir /var/spool/sms/outgoing
+ keepdir /var/spool/sms/checked
+
+ newinitd ${FILESDIR}/smsd.initd smsd
+ insinto /etc
+ newins examples/smsd.conf.easy smsd.conf
+}