summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-03-08 14:56:09 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-03-08 14:56:09 +0000
commit89478f8b43b4c6b47cd47c75fd62c9ecf3d50413 (patch)
treef2cc53b8a3fd25c77d838abc6c7a2bb27012aace /app-misc
parentMoving ginac from local to global flag (diff)
downloadhistorical-89478f8b43b4c6b47cd47c75fd62c9ecf3d50413.tar.gz
historical-89478f8b43b4c6b47cd47c75fd62c9ecf3d50413.tar.bz2
historical-89478f8b43b4c6b47cd47c75fd62c9ecf3d50413.zip
version bump
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/lirc/ChangeLog7
-rw-r--r--app-misc/lirc/Manifest4
-rw-r--r--app-misc/lirc/files/digest-lirc-0.7.0_pre31
-rw-r--r--app-misc/lirc/lirc-0.7.0_pre3.ebuild170
4 files changed, 180 insertions, 2 deletions
diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
index 7d39d4e467a6..0cbd8051d968 100644
--- a/app-misc/lirc/ChangeLog
+++ b/app-misc/lirc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/lirc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.20 2004/02/24 10:45:11 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.21 2004/03/08 14:56:09 lanius Exp $
+
+*lirc-0.7.0_pre3 (08 Mar 2004)
+
+ 08 Mar 2004; Heinrich Wendel <lanius@gentoo.org> lirc-0.7.0_pre3.ebuild:
+ version bump
24 Feb 2004; Heinrich Wendel <lanius@gentoo.org> lirc-0.7.0_pre2.ebuild:
stable on x86
diff --git a/app-misc/lirc/Manifest b/app-misc/lirc/Manifest
index cc141f3135dc..85d7faef2640 100644
--- a/app-misc/lirc/Manifest
+++ b/app-misc/lirc/Manifest
@@ -1,9 +1,11 @@
+MD5 bcba643670785380641f8a48566e29a5 lirc-0.7.0_pre3.ebuild 4534
MD5 3e4ede463c17a006a68994212b70268e lirc-0.6.6-r1.ebuild 3877
MD5 1c135d3cc4aa0f1a527dc3d7c772ad8f lirc-0.7.0_pre2.ebuild 4606
-MD5 584b8f77d55a592abf3213b7f3467925 ChangeLog 3019
+MD5 2f30edfbaa552a8680f0abdb346cc053 ChangeLog 3142
MD5 eb1d5f40e0d59edbc1ac2a097cea5850 files/digest-lirc-0.6.6-r1 63
MD5 d0d865cbe48f328fb4cfb41e22d4407b files/lirc-0.7.0_pre2-i2c.patch.gz 705
MD5 6be29381442461f310f47cb0552e6950 files/lircd 483
MD5 ce31954d209c4e81861d7e3c76aaa91e files/lircd.conf 71
MD5 cee0550f10a0a0d63fcae5209819f4d9 files/digest-lirc-0.7.0_pre2 67
+MD5 cec75bc2acbedddba62b71993bf9981c files/digest-lirc-0.7.0_pre3 67
MD5 6031968a1ddb51ff5265d1f22bd2d237 files/lirc-0.6.6-gentoo.diff.bz2 2215
diff --git a/app-misc/lirc/files/digest-lirc-0.7.0_pre3 b/app-misc/lirc/files/digest-lirc-0.7.0_pre3
new file mode 100644
index 000000000000..9a19d59c4065
--- /dev/null
+++ b/app-misc/lirc/files/digest-lirc-0.7.0_pre3
@@ -0,0 +1 @@
+MD5 5c4ad77f59b6d9b24a6df6beb099a835 lirc-0.7.0pre3.tar.bz2 437242
diff --git a/app-misc/lirc/lirc-0.7.0_pre3.ebuild b/app-misc/lirc/lirc-0.7.0_pre3.ebuild
new file mode 100644
index 000000000000..d096df74ed07
--- /dev/null
+++ b/app-misc/lirc/lirc-0.7.0_pre3.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.7.0_pre3.ebuild,v 1.1 2004/03/08 14:56:09 lanius Exp $
+
+inherit eutils kernel-mod
+
+DESCRIPTION="LIRC is a package that allows you to decode and send infra-red \
+ signals of many (but not all) commonly used remote controls."
+HOMEPAGE="http://www.lirc.org"
+
+[ "x${LIRC_OPTS}" = x ] && LIRC_OPTS="--with-driver=serial \
+ --with-port=0x3f8 --with-irq=4"
+
+# We have a SMP enabled kernel?
+if [ ! -z "`uname -v | grep SMP`" ]
+then
+ export SMP=1
+else
+ export SMP=0
+fi
+
+# This are the defaults. With this support for all supported remotes
+# will be build.
+# If you want other options then set the Environment variable to your needs.
+
+# Note: If you don't specify the driver configure becomes interactiv.
+
+# You have to know, which driver you want;
+# --with-driver=X
+
+# where X is one of:
+# none, any, animax, avermedia, avermedia98,
+# bestbuy, bestbuy2, caraca, chronos, comX,
+# cph03x, cph06x, creative, fly98, flyvideo,
+# hauppauge,hauppauge_dvb, ipaq, irdeo,
+# irdeo_remote, irman, irreal, it87, knc_one,
+# logitech, lptX, mediafocusI, packard_bell,
+# parallel, pctv, pixelview_bt878,
+# pixelview_pak, pixelview_pro, provideo,
+# realmagic, remotemaster, serial, silitek,
+# sir, slinke, tekram, winfast_tv2000
+
+# This could be usefull too
+
+# --with-port=port # port number for the lirc device.
+# --with-irq=irq # irq line for the lirc device.
+# --with-timer=value # timer value for the parallel driver
+# --with-tty=file # tty to use (Irman, RemoteMaster, etc.)
+# --without-soft-carrier # if your serial hw generates carrier
+# --with-transmitter # if you use a transmitter diode
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc alpha ia64"
+
+DEPEND="virtual/linux-sources"
+
+MY_P=${P/_/}
+
+SRC_URI="http://lirc.sourceforge.net/software/snapshots/${MY_P}.tar.bz2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O2 -g:${CFLAGS}:" configure configure.in
+}
+
+src_compile() {
+ ewarn "If you are using a 2.6 kernel you have to patch it for lirc support."
+ ewarn "There are several patches floating around, one of them can be found at "
+ ewarn "http://lwn.net/Articles/42217/."
+
+ ewarn "make sure you have IrDA (infrared) support"
+ ewarn "in your kernel or this will fail"
+
+ # Let portage tell us where to put our modules
+ check_KV
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-kerneldir="/usr/src/linux" \
+ --with-moduledir="/lib/modules/${KV}/misc" \
+ --disable-manage-devices \
+ --enable-sandboxed \
+ ${LIRC_OPTS} || die "./configure failed"
+
+ if kernel-mod_is_2_6_kernel; then
+ (cd daemons; emake) || die
+ (cd tools; emake) || die
+ (cd doc; emake) || die
+ else
+ emake || die
+
+ case ${LIRC_OPTS}
+ in
+ *"any"*)
+ if [ "${SMP}" = 1 ]; then
+ # The parallel driver will not work with SMP kernels
+ # so we need to compile without it
+ emake -C drivers "SUBDIRS=lirc_dev lirc_serial \
+ lirc_sir lirc_it87 lirc_i2c lirc_gpio" || die
+ else
+ emake -C drivers "SUBDIRS=lirc_dev lirc_serial \
+ lirc_parallel lirc_sir lirc_it87 lirc_i2c \
+ lirc_gpio" || die
+ fi
+ ;;
+ esac
+ fi
+}
+
+src_install() {
+ if kernel-mod_is_2_6_kernel; then
+ (cd daemons; make DESTDIR=${D} install) || die
+ (cd tools; make DESTDIR=${D} install) || die
+ (cd doc; make DESTDIR=${D} install) || die
+ else
+ emake || die
+ make DESTDIR=${D} install || die
+
+ case ${LIRC_OPTS}
+ in
+ *"any"*)
+ insinto /lib/modules/${KV}/misc
+ if [ "${SMP}" = 1 ]; then
+ for i in lirc_dev lirc_serial \
+ lirc_sir lirc_it87 lirc_i2c lirc_gpio
+ do
+ doins drivers/${i}/${i}.o
+ done
+ else
+ for i in lirc_dev lirc_serial \
+ lirc_parallel lirc_sir lirc_it87 lirc_i2c lirc_gpio
+ do
+ doins drivers/${i}/${i}.o
+ done
+ fi
+ ;;
+ esac
+ fi
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/lircd
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lircd.conf lircd
+
+ dohtml doc/html/*.html
+}
+
+pkg_postinst () {
+ if kernel-mod_is_2_4_kernel; then
+ /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "The lirc Linux Infrared Remote Control Package has been"
+ einfo "merged, please read the documentation, and if necessary"
+ einfo "add what is needed to /etc/modules.autoload or"
+ einfo "/etc/modules.d. If you need special compile options"
+ einfo "then read the comments at the begin of this"
+ einfo "ebuild (source) and set the LIRC_OPTS environment"
+ einfo "variable to your needs."
+ einfo
+}