summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-25 19:49:52 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-25 19:49:52 +0000
commit5d40a135a511a0d36ab2555f826681b3be31e637 (patch)
tree389b40d5f0afebb367393bb419001af5eea2091a /app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild
parentremove old 2.x versions (diff)
downloadhistorical-5d40a135a511a0d36ab2555f826681b3be31e637.tar.gz
historical-5d40a135a511a0d36ab2555f826681b3be31e637.tar.bz2
historical-5d40a135a511a0d36ab2555f826681b3be31e637.zip
Revision bump: EAPI 5, base eclass, QA fixes. Respect LDFLAGS, wrt bug #331843, patch by Olivier Huber <oli.huber AT gmail.com>
Package-Manager: portage-2.2.0_alpha163/cvs/Linux x86_64 Manifest-Sign-Key: 0x1F357D42
Diffstat (limited to 'app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild')
-rw-r--r--app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild b/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..1e6404cf797d
--- /dev/null
+++ b/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild,v 1.1 2013/02/25 19:49:50 pinkbyte Exp $
+
+EAPI=5
+
+inherit base flag-o-matic toolchain-funcs
+
+DESCRIPTION="tty recorder"
+HOMEPAGE="http://namazu.org/~satoru/ttyrec/"
+SRC_URI="http://namazu.org/~satoru/ttyrec/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+# Bug 331843
+PATCHES=( "${FILESDIR}/${P}-ldflags.patch" )
+
+src_compile() {
+ # Bug 106530
+ append-cppflags -DSVR4 -D_XOPEN_SOURCE=500
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ttyrec ttyplay ttytime
+ dodoc README
+ doman *.1
+}