summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-28 05:59:25 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-28 05:59:25 +0000
commit56fac1159083f6ba70d83e1cd2da3ad6d052548c (patch)
treee880b356fe5d58a13bbdb6158c114970803e55d0 /app-misc/figlet/figlet-22-r1.ebuild
parentVersion bump (diff)
downloadhistorical-56fac1159083f6ba70d83e1cd2da3ad6d052548c.tar.gz
historical-56fac1159083f6ba70d83e1cd2da3ad6d052548c.tar.bz2
historical-56fac1159083f6ba70d83e1cd2da3ad6d052548c.zip
+x fix from #9804
Diffstat (limited to 'app-misc/figlet/figlet-22-r1.ebuild')
-rw-r--r--app-misc/figlet/figlet-22-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/figlet/figlet-22-r1.ebuild b/app-misc/figlet/figlet-22-r1.ebuild
new file mode 100644
index 000000000000..e3bce5abf1bd
--- /dev/null
+++ b/app-misc/figlet/figlet-22-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-22-r1.ebuild,v 1.1 2002/10/28 05:59:25 vapier Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="FIGlet is a program for making large letters out of ordinary text"
+SRC_URI="ftp://ftp.plig.org/pub/figlet/program/unix/${PN}${PV}.tar.gz"
+HOMEPAGE="http://st-www.cs.uiuc.edu/users/chai/figlet.html"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 sparc64"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+ sed "s/CFLAGS = -g/CFLAGS = ${CFLAGS}/g" < Makefile > Makefile.new
+ mv -f Makefile.new Makefile
+}
+
+
+src_compile() {
+ make clean || die
+ make figlet || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man6
+ chmod +x figlist showfigfonts
+ make \
+ DESTDIR=${D}/usr/bin \
+ MANDIR=${D}/usr/share/man/man6 \
+ DEFAULTFONTDIR=${D}/usr/share/figlet \
+ install || die
+
+ dodoc Artistic-license.txt FTP-NOTE README showfigfonts figmagic figfont.txt
+}