summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-03-08 22:02:51 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-03-08 22:02:51 +0000
commit53d66cc23e9af410f23b9d703cb1e9daba3a3e9f (patch)
treeecd28616a709cf886f5cc08c62a15e55ce1818d7 /app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
parentMove LeechCraft to new category (diff)
downloadhistorical-53d66cc23e9af410f23b9d703cb1e9daba3a3e9f.tar.gz
historical-53d66cc23e9af410f23b9d703cb1e9daba3a3e9f.tar.bz2
historical-53d66cc23e9af410f23b9d703cb1e9daba3a3e9f.zip
Move LeechCraft to new category
Package-Manager: portage-2.1.11.55/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0xF8DBDADE
Diffstat (limited to 'app-leechcraft/lc-monocle/lc-monocle-9999.ebuild')
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
new file mode 100644
index 000000000000..68ae5b2eaa10
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild,v 1.1 2013/03/08 22:02:32 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft."
+
+SLOT="0"
+KEYWORDS=""
+IUSE="+djvu debug +fb2 +pdf +spectre"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? ( app-text/libspectre )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)"
+
+ cmake-utils_src_configure
+}