summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-05-05 08:00:17 +0000
committerCédric Krier <cedk@gentoo.org>2008-05-05 08:00:17 +0000
commitded88eff9e5d8fa94b5de28a084e6edab617c3ab (patch)
tree4965746b7692d05d7b2ea47ce81fcd4518a2173e /app-laptop/pommed/files
parentforced DEPEND=<svn-1.5 as it complains endlessly during work (#219505) (diff)
downloadhistorical-ded88eff9e5d8fa94b5de28a084e6edab617c3ab.tar.gz
historical-ded88eff9e5d8fa94b5de28a084e6edab617c3ab.tar.bz2
historical-ded88eff9e5d8fa94b5de28a084e6edab617c3ab.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-laptop/pommed/files')
-rw-r--r--app-laptop/pommed/files/pommed-1.17.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-laptop/pommed/files/pommed-1.17.patch b/app-laptop/pommed/files/pommed-1.17.patch
new file mode 100644
index 000000000000..d9c948dab9df
--- /dev/null
+++ b/app-laptop/pommed/files/pommed-1.17.patch
@@ -0,0 +1,30 @@
+diff -ru pommed-1.16~/pommed/Makefile pommed-1.16/pommed/Makefile
+--- pommed-1.16~/pommed/Makefile 2008-04-27 12:28:57.000000000 +0200
++++ pommed-1.16/pommed/Makefile 2008-04-27 12:31:10.000000000 +0200
+@@ -16,7 +16,7 @@
+
+ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
++CFLAGS += -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
+
+ LDFLAGS = -pthread $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
+
+@@ -42,7 +42,7 @@
+
+ else
+
+-LDFLAGS += -lz -lsmbios
++LDFLAGS += -lz -lsmbios -lstdc++
+
+ SOURCES = pommed.c cd_eject.c evdev.c conffile.c audio.c \
+ dbus.c power.c beep.c video.c \
+@@ -50,7 +50,7 @@
+ mactel/nv8600mgt_backlight.c \
+ mactel/kbd_backlight.c mactel/ambient.c mactel/acpi.c
+
+-LIBS = /usr/lib/libpci.a
++LIBS = $(shell pkg-config libpci --libs)
+ endif
+
+ OBJS = $(SOURCES:%.c=%.o)