summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2010-02-28 16:33:11 +0000
committerCédric Krier <cedk@gentoo.org>2010-02-28 16:33:11 +0000
commita00c9a5850c385478a3728ff887a70f545256dc4 (patch)
treebe3a045c5680adb68c91408b7db7e21208a93fe6 /app-laptop/pommed/files
parentFix init scripts to work with tabs for bug #301619 (diff)
downloadhistorical-a00c9a5850c385478a3728ff887a70f545256dc4.tar.gz
historical-a00c9a5850c385478a3728ff887a70f545256dc4.tar.bz2
historical-a00c9a5850c385478a3728ff887a70f545256dc4.zip
Version bump
Package-Manager: portage-2.1.7.16/cvs/Linux i686
Diffstat (limited to 'app-laptop/pommed/files')
-rw-r--r--app-laptop/pommed/files/pommed-1.31.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-laptop/pommed/files/pommed-1.31.patch b/app-laptop/pommed/files/pommed-1.31.patch
new file mode 100644
index 000000000000..484d7bc2db57
--- /dev/null
+++ b/app-laptop/pommed/files/pommed-1.31.patch
@@ -0,0 +1,75 @@
+diff -ru pommed-1.31~/gpomme/Makefile pommed-1.31/gpomme/Makefile
+--- pommed-1.31~/gpomme/Makefile 2010-02-28 17:24:31.000000000 +0100
++++ pommed-1.31/gpomme/Makefile 2010-02-28 17:25:31.000000000 +0100
+@@ -17,8 +17,8 @@
+
+ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
+-LDFLAGS = -lpthread -lX11 $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
++LDFLAGS += -lpthread -lX11 $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
+
+ SOURCES = gpomme.c theme.c conffile.c \
+ ../client-common/dbus-client.c \
+@@ -33,6 +33,7 @@
+ mo: $(MOFILES)
+
+ gpomme: $(OBJS) $(LIBS)
++ ${CC} -o $@ ${OBJS} ${LIBS} ${LDFLAGS}
+
+ gpomme.o: gpomme.c gpomme.h theme.h ../client-common/dbus-client.h ../client-common/video-client.h
+
+diff -ru pommed-1.31~/pommed/Makefile pommed-1.31/pommed/Makefile
+--- pommed-1.31~/pommed/Makefile 2010-02-28 17:24:31.000000000 +0100
++++ pommed-1.31/pommed/Makefile 2010-02-28 17:26:20.000000000 +0100
+@@ -18,9 +18,9 @@
+
+ TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
+
+-LDFLAGS = -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
++LDFLAGS += -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
+
+ ifneq (, $(findstring ppc, $(ARCH)))
+ OFLIB ?=
+@@ -52,6 +52,7 @@
+
+ CFLAGS += $(LIBPCI_CFLAGS)
+ LDFLAGS += $(LIBPCI_LIBS)
++ LIBS = $(LIBPCI_LIBS)
+ else
+ LIBS = /usr/lib/libpci.a
+ LDFLAGS += -lz
+@@ -69,6 +70,7 @@
+
+
+ pommed: $(OBJS) $(LIBS)
++ ${CC} -o $@ ${OBJS} ${LIBS} ${LDFLAGS}
+
+ pommed.o: pommed.c pommed.h evloop.h kbd_backlight.h lcd_backlight.h cd_eject.h evdev.h conffile.h audio.h dbus.h beep.h
+
+diff -ru pommed-1.31~/wmpomme/Makefile pommed-1.31/wmpomme/Makefile
+--- pommed-1.31~/wmpomme/Makefile 2010-02-28 17:24:31.000000000 +0100
++++ pommed-1.31/wmpomme/Makefile 2010-02-28 17:26:42.000000000 +0100
+@@ -5,8 +5,8 @@
+
+ TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
+-LDFLAGS = -lrt -lXpm -lXext -lX11 $(DBUS_LIBS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
++LDFLAGS += -lrt -lXpm -lXext -lX11 $(DBUS_LIBS)
+
+ SOURCES = wmgeneral.c wmpomme.c \
+ ../client-common/dbus-client.c \
+@@ -15,6 +15,7 @@
+ OBJS = $(SOURCES:%.c=%.o)
+
+ wmpomme: $(OBJS)
++ ${CC} -o $@ ${OBJS} ${LDFLAGS}
+
+ wmpomme.o: wmpomme.c wmgeneral.h wmpomme-master.xpm ../client-common/dbus-client.h
+