summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-08-25 10:17:30 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-08-25 10:17:30 +0000
commitfd8514dcb898c0bade36e5e6c75933008b47eab6 (patch)
tree49714caeb610548ef523e4d660d5bb21e269d39d /app-i18n/zhcon
parentSet +x on the cgi (diff)
downloadhistorical-fd8514dcb898c0bade36e5e6c75933008b47eab6.tar.gz
historical-fd8514dcb898c0bade36e5e6c75933008b47eab6.tar.bz2
historical-fd8514dcb898c0bade36e5e6c75933008b47eab6.zip
Fixed compile problems with gcc-34. Bug #61381.
Diffstat (limited to 'app-i18n/zhcon')
-rw-r--r--app-i18n/zhcon/ChangeLog6
-rw-r--r--app-i18n/zhcon/Manifest17
-rw-r--r--app-i18n/zhcon/files/zhcon-0.2.3-gcc34.patch49
-rw-r--r--app-i18n/zhcon/zhcon-0.2.3.ebuild4
4 files changed, 61 insertions, 15 deletions
diff --git a/app-i18n/zhcon/ChangeLog b/app-i18n/zhcon/ChangeLog
index afc53375d7a1..ef10d0e5a38b 100644
--- a/app-i18n/zhcon/ChangeLog
+++ b/app-i18n/zhcon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/zhcon
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/ChangeLog,v 1.3 2004/06/24 21:57:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/ChangeLog,v 1.4 2004/08/25 10:17:30 sekretarz Exp $
+
+ 25 Aug 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/zhcon-0.2.3-gcc34.patch, zhcon-0.2.3.ebuild:
+ Fixed compile problems with gcc-34. Bug #61381. Thanks to Jackey Yang
25 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> zhcon-0.2.3.ebuild:
Marked stable on x86
diff --git a/app-i18n/zhcon/Manifest b/app-i18n/zhcon/Manifest
index 18a2de28c0c5..670ed44e2dc9 100644
--- a/app-i18n/zhcon/Manifest
+++ b/app-i18n/zhcon/Manifest
@@ -1,16 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 99805ed62bef799fbf82cb552195a6df ChangeLog 552
+MD5 6832c76f1ab1555fdb4d73db3585a787 zhcon-0.2.3.ebuild 810
+MD5 682497035bd66c7e18891e6bc0627add ChangeLog 734
MD5 8ef70951aa06be1284427310a2ef8eb5 metadata.xml 466
-MD5 ee34d242f9c10c7395620b80c8e95061 zhcon-0.2.3.ebuild 769
-MD5 aaa0c58daca46525014d59831e32a3b8 files/digest-zhcon-0.2.3 64
MD5 527bb0c1a80fcb0f8c916d2be40271e4 files/zhcon-0.2.3-assert-gentoo.diff 1063
+MD5 aaa0c58daca46525014d59831e32a3b8 files/digest-zhcon-0.2.3 64
+MD5 fa0b7fc976eef786cf9d61bbcd01584d files/zhcon-0.2.3-gcc34.patch 2127
MD5 33c30557b9d62f9593d178f718431a1b files/zhcon-0.2.3-gentoo.diff 4788
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
-
-iD8DBQFA332oHTu7gpaalycRApc0AKDbxTwEtTZfXJSmYv3bcPppkUVjnQCeKatn
-N0fW2CPNMuDKQRFaclOjbRE=
-=QFNO
------END PGP SIGNATURE-----
diff --git a/app-i18n/zhcon/files/zhcon-0.2.3-gcc34.patch b/app-i18n/zhcon/files/zhcon-0.2.3-gcc34.patch
new file mode 100644
index 000000000000..d44bc7d0d13d
--- /dev/null
+++ b/app-i18n/zhcon/files/zhcon-0.2.3-gcc34.patch
@@ -0,0 +1,49 @@
+diff -Naur zhcon-0.2.3.orig/config.h.in zhcon-0.2.3/config.h.in
+--- zhcon-0.2.3.orig/config.h.in 2003-04-13 07:05:29.000000000 +0200
++++ zhcon-0.2.3/config.h.in 2004-08-25 11:40:00.905785096 +0200
+@@ -275,11 +275,11 @@
+ #undef WORDS_BIGENDIAN
+
+ /* Define to empty if `const' does not conform to ANSI C. */
+-#undef const
++/*#undef const*/
+
+ /* Define as `__inline' if that's what the C compiler calls it, or to nothing
+ if it is not supported. */
+-#undef inline
++/*#undef inline*/
+
+ /* Define to `long' if <sys/types.h> does not define. */
+ #undef off_t
+diff -Naur zhcon-0.2.3.orig/src/display/fblinear24.cpp zhcon-0.2.3/src/display/fblinear24.cpp
+--- zhcon-0.2.3.orig/src/display/fblinear24.cpp 2002-05-12 05:58:28.000000000 +0200
++++ zhcon-0.2.3/src/display/fblinear24.cpp 2004-08-25 11:40:00.635826136 +0200
+@@ -203,11 +203,13 @@
+ d1 = (-(*cdat >> 3 & 1) & eorx) ^ bgx;
+ d2 = (-(*cdat >> 2 & 1) & eorx) ^ bgx;
+ fb_writel(d1 | (d2<<24), dest32++);
+- fb_writew(d2>>8, ((__u16*)dest32)++);
++ dest32 = (__u32*)((__u16*)dest32 + 1);
++ fb_writew(d3, dest32);
+ }
+ if (pFont->w & 1) {
+ d3 = (-(*cdat >> 1 & 1) & eorx) ^ bgx;
+- fb_writew(d3, ((__u16*)dest32)++);
++ dest32 = (__u32*)((__u16*)dest32 + 1);
++ fb_writew(d3, dest32);
+ fb_writeb(d3>>16, (__u8*)dest32);
+ }
+ cdat++;
+diff -Naur zhcon-0.2.3.orig/src/display/fblinear8.cpp zhcon-0.2.3/src/display/fblinear8.cpp
+--- zhcon-0.2.3.orig/src/display/fblinear8.cpp 2002-05-12 05:58:28.000000000 +0200
++++ zhcon-0.2.3/src/display/fblinear8.cpp 2004-08-25 11:40:00.641825224 +0200
+@@ -102,7 +102,8 @@
+ fb_writel((nibbletab_cfb8[*cdat >> 4] & eorx) ^ bgx, dest32++);
+ }
+ if (pFont->w & 2) {
+- fb_writew((nibbletab_cfb8[*cdat & 0xc] & eorx) ^ bgx, ((__u16*)dest32)++);
++ dest32 = (__u32*)((__u16*)dest32 + 1);
++ fb_writew((nibbletab_cfb8[*cdat & 0xc] & eorx) ^ bgx, dest32);
+ }
+ if (pFont->w & 1) {
+ fb_writeb((*cdat & 2) ? fg : bg, (__u8*)dest32);
diff --git a/app-i18n/zhcon/zhcon-0.2.3.ebuild b/app-i18n/zhcon/zhcon-0.2.3.ebuild
index c2298170a957..77897ee9ddae 100644
--- a/app-i18n/zhcon/zhcon-0.2.3.ebuild
+++ b/app-i18n/zhcon/zhcon-0.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/zhcon-0.2.3.ebuild,v 1.5 2004/06/28 02:08:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/zhcon/zhcon-0.2.3.ebuild,v 1.6 2004/08/25 10:17:30 sekretarz Exp $
inherit eutils
@@ -21,6 +21,8 @@ src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gentoo.diff
epatch ${FILESDIR}/${P}-assert-gentoo.diff
+
+ epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {