summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-08-29 18:12:37 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-08-29 18:12:37 +0000
commit1c3a41c3811dc10b03244d70568c274b8b609e03 (patch)
tree29f1cd00115ea3266a424bd523aa61dae4d0285d /app-i18n/scim/scim-0.6.1.ebuild
parentmoving dev-python/PyXML to dev-python/pyxml (diff)
downloadhistorical-1c3a41c3811dc10b03244d70568c274b8b609e03.tar.gz
historical-1c3a41c3811dc10b03244d70568c274b8b609e03.tar.bz2
historical-1c3a41c3811dc10b03244d70568c274b8b609e03.zip
version bump
Diffstat (limited to 'app-i18n/scim/scim-0.6.1.ebuild')
-rw-r--r--app-i18n/scim/scim-0.6.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/scim/scim-0.6.1.ebuild b/app-i18n/scim/scim-0.6.1.ebuild
new file mode 100644
index 000000000000..8da72a4e9d61
--- /dev/null
+++ b/app-i18n/scim/scim-0.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-0.6.1.ebuild,v 1.1 2003/08/29 18:11:11 liquidx Exp $
+
+inherit gnome2
+
+DESCRIPTION="Smart Common Input Method (SCIM) is a Input Method (IM) development platform"
+HOMEPAGE="http://www.turbolinux.com.cn/~suzhe/scim/"
+SRC_URI="http://www.turbolinux.com.cn/~suzhe/scim/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="gnome"
+
+RDEPEND="virtual/x11
+ gnome? ( >=gnome-base/gconf-1.2
+ >=dev-libs/libxml2-2.5
+ >=gnome-base/ORBit2-2
+ >=net-libs/linc-0.5 )
+ >=x11-libs/gtk+-2
+ >=dev-libs/atk-1
+ >=x11-libs/pango-1
+ >=dev-libs/glib-2"
+
+PDEPEND=">=app-i18n/scim-tables-0.2.2"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+ELTCONF="--reverse-deps"
+G2CONF="${G2CONF} `use_enable gnome config-gconf`"
+SCROLLKEEPER_UPDATE="0"
+
+src_unpack() {
+ unpack ${A}
+ # use scim gtk2 IM module only for chinese/japanese/korean
+ epatch ${FILESDIR}/${P}-gtk2immodule.patch
+ # workaround for problematic makefile
+ cd ${S}/src
+ sed -i -e "s:^\(scim_LDFLAGS.*\):\1 -ldl:" Makefile.in
+ cd ${S}/modules/Server
+ sed -i -e "s:^\(scim_make_table_LDFLAGS.*\):\1 -ldl:" Makefile.in
+}
+
+src_install() {
+ gnome2_src_install || "install failed"
+ dodoc README AUTHORS ChangeLog docs/developers docs/scim.cfg
+ dohtml -r docs/html/*
+}
+
+