summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-04-19 06:46:08 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-04-19 06:46:08 +0000
commit152498a18aca94218166c7f11b2a42d478628a68 (patch)
tree04dfc0b2015f35d9855019820e7b2fce31bac6b2 /app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
parentversion bump (diff)
downloadhistorical-152498a18aca94218166c7f11b2a42d478628a68.tar.gz
historical-152498a18aca94218166c7f11b2a42d478628a68.tar.bz2
historical-152498a18aca94218166c7f11b2a42d478628a68.zip
Version bumped. Fixed DEPEND
Package-Manager: portage-2.1.6.11/cvs/Linux x86_64
Diffstat (limited to 'app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild')
-rw-r--r--app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild b/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
new file mode 100644
index 000000000000..a6a64eac0629
--- /dev/null
+++ b/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-m17n/scim-m17n-0.2.3.ebuild,v 1.1 2009/04/19 06:46:08 matsuu Exp $
+
+DESCRIPTION="scim-m17n is an input module for Smart Common Input Method (SCIM) which uses m17n as backend"
+HOMEPAGE="http://www.scim-im.org/projects/imengines"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/scim-1.4
+ >=dev-libs/m17n-lib-1.2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog THANKS README
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=\"scim\""
+ elog
+}