summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 02:08:21 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 02:08:21 +0000
commit4c2ff3169fe7344c216dc840cc1071248eb017cb (patch)
tree0177f54977ae5df9e2b739ccb5a725d79c355f33 /app-i18n/anthy
parentQA - fix use invocation (diff)
downloadhistorical-4c2ff3169fe7344c216dc840cc1071248eb017cb.tar.gz
historical-4c2ff3169fe7344c216dc840cc1071248eb017cb.tar.bz2
historical-4c2ff3169fe7344c216dc840cc1071248eb017cb.zip
touch the libc
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/anthy-4300b.ebuild19
-rw-r--r--app-i18n/anthy/anthy-4700.ebuild19
2 files changed, 16 insertions, 22 deletions
diff --git a/app-i18n/anthy/anthy-4300b.ebuild b/app-i18n/anthy/anthy-4300b.ebuild
index 80ea25e1175e..fb9c835b34cc 100644
--- a/app-i18n/anthy/anthy-4300b.ebuild
+++ b/app-i18n/anthy/anthy-4300b.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4300b.ebuild,v 1.8 2004/06/24 21:43:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4300b.ebuild,v 1.9 2004/06/28 01:40:27 vapier Exp $
inherit elisp-common
-IUSE="emacs"
-
-DESCRIPTION="Anthy -- free and secure Japanese input system"
+DESCRIPTION="free and secure Japanese input system"
HOMEPAGE="http://anthy.sourceforge.jp/"
SRC_URI="mirror://sourceforge.jp/anthy/5332/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 alpha sparc"
SLOT="0"
+KEYWORDS="x86 sparc alpha"
+IUSE="emacs"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
!app-i18n/anthy-ss
emacs? ( virtual/emacs )"
SITEFILE="50anthy-gentoo.el"
src_compile() {
-
- econf `use emacs >/dev/null 2>&1 || echo EMACS=no` || die
+ local myconf=""
+ use emacs || myconf="EMACS=no"
+ econf ${myconf} || die
emake || die
}
src_install() {
-
einstall || die
use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
@@ -37,11 +36,9 @@ src_install() {
}
pkg_postinst() {
-
use emacs && elisp-site-regen
}
pkg_postrm() {
-
use emacs && elisp-site-regen
}
diff --git a/app-i18n/anthy/anthy-4700.ebuild b/app-i18n/anthy/anthy-4700.ebuild
index a7638424da65..b5c67990aea7 100644
--- a/app-i18n/anthy/anthy-4700.ebuild
+++ b/app-i18n/anthy/anthy-4700.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4700.ebuild,v 1.4 2004/06/24 21:43:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4700.ebuild,v 1.5 2004/06/28 01:40:27 vapier Exp $
inherit elisp-common
-IUSE="emacs"
-
-DESCRIPTION="Anthy -- free and secure Japanese input system"
+DESCRIPTION="free and secure Japanese input system"
HOMEPAGE="http://anthy.sourceforge.jp/"
SRC_URI="mirror://sourceforge.jp/anthy/6621/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 alpha sparc"
SLOT="0"
+KEYWORDS="x86 sparc alpha"
+IUSE="emacs"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
!app-i18n/anthy-ss
emacs? ( virtual/emacs )"
SITEFILE="50anthy-gentoo.el"
src_compile() {
-
- econf `use emacs >/dev/null 2>&1 || echo EMACS=no` || die
+ local myconf=""
+ use emacs || myconf="EMACS=no"
+ econf ${myconf} || die
emake || die
}
src_install() {
-
einstall || die
use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
@@ -37,11 +36,9 @@ src_install() {
}
pkg_postinst() {
-
use emacs && elisp-site-regen
}
pkg_postrm() {
-
use emacs && elisp-site-regen
}