summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-07 09:48:38 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-07 09:48:38 +0000
commitb7d723a8813a29c6cd3ee16c063382e53b4ac3a8 (patch)
tree07033b1f36a9e65df608bac1ac403a640e8dc3b0 /app-forensics/tct/tct-1.15-r1.ebuild
parentMarked stable on mips. (diff)
downloadhistorical-b7d723a8813a29c6cd3ee16c063382e53b4ac3a8.tar.gz
historical-b7d723a8813a29c6cd3ee16c063382e53b4ac3a8.tar.bz2
historical-b7d723a8813a29c6cd3ee16c063382e53b4ac3a8.zip
Revision bump; fixes bug #70307, use tc-getCC, and don't install md5 man page as it gets installed by openssl.
Diffstat (limited to 'app-forensics/tct/tct-1.15-r1.ebuild')
-rw-r--r--app-forensics/tct/tct-1.15-r1.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/app-forensics/tct/tct-1.15-r1.ebuild b/app-forensics/tct/tct-1.15-r1.ebuild
new file mode 100644
index 000000000000..c37c25c04629
--- /dev/null
+++ b/app-forensics/tct/tct-1.15-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/tct-1.15-r1.ebuild,v 1.1 2004/11/07 09:48:38 ka0ttic Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The Coroner's Toolkit - a collection of tools to aide in gathering and analyzing forensic data on a UNIX system"
+HOMEPAGE="http://www.porcupine.org/forensics/tct.html"
+SRC_URI="http://www.porcupine.org/forensics/${P}.tar.gz"
+
+LICENSE="IBM as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.0004
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i "s:^\(CC.*= \).*:\1$(tc-getCC):" Makefile || die "sed CC failed"
+ sed -i "s:\$(OPT) \$(DEBUG):${CFLAGS}:" */*/Makefile \
+ || die "sed CFLAGS failed"
+
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_install() {
+ # bins/libs
+ into /usr/lib/tct
+ dobin bin/* || die "bin installation failed"
+
+ exeinto /usr/lib/tct
+ doexe reconfig || die "reconfig installation failed"
+
+ insinto /usr/lib/tct/lib
+ doins lib/*.pl || die "lib installation failed"
+
+ exeinto /usr/lib/tct/extras
+ doexe extras/bdf extras/ils2mac extras/realpath extras/entropy/entropy \
+ extras/findkey/findkey || die "extras installation failed"
+
+ # config
+ insinto /etc/tct
+ doins conf/* || die "conf installation failed"
+
+ # docs
+ newdoc extras/README README.extras || die "newdoc failed"
+ dodoc docs/* Beware CHANGES INSTALL OS-NOTES README.FIRST \
+ TODO* additional-resources bibliography help-recovering-file \
+ help-when-broken-into quick-start || die "doc installation failed"
+
+ # these manual pages are provided by other packages
+ rm man/man1/file.1
+ rm man/man1/md5.1
+ rm man/man5/magic.5
+ doman man/*/* || die "man installation failed"
+
+ # setup dirs/symlinks
+ keepdir /var/log/tct
+
+ dosym /etc/tct /usr/lib/tct/conf || die "dosym failed"
+
+ keepdir /var/lib/tct
+ dosym /var/lib/tct /usr/lib/tct/data || die "dosym failed"
+
+ dodir /usr/sbin
+ cd ${S}/bin
+ # all binaries except the following are meant for internal use
+ for bin in grave-robber lazarus mactime unrm; do
+ dosym /usr/lib/tct/bin/${bin} /usr/sbin/${bin} \
+ || die "dosym ${bin} failed"
+ done
+}
+
+pkg_postinst() {
+ echo
+ einfo "The authors of The Coroner's Toolkit highly recommend"
+ einfo "installing sys-apps/lsof for use by the toolkit."
+ einfo
+ einfo "Please read the README and quickstart files installed"
+ einfo "in /usr/share/doc/${PF} before using The Coroner's Toolkit."
+ echo
+}