summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-03-08 00:01:40 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-03-08 00:01:40 +0000
commitc948b071eac3aca07adf697eff8e94d7e4837bee (patch)
treee1edc5f460ffbddb4bfb8fbe881e684e35c69c19 /app-emulation
parentDo not use deprecated kde-base eclass. (diff)
downloadhistorical-c948b071eac3aca07adf697eff8e94d7e4837bee.tar.gz
historical-c948b071eac3aca07adf697eff8e94d7e4837bee.tar.bz2
historical-c948b071eac3aca07adf697eff8e94d7e4837bee.zip
Updated the big filesystem patch, bug #80098.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/mol/ChangeLog6
-rw-r--r--app-emulation/mol/Manifest4
-rw-r--r--app-emulation/mol/files/mol-0.9.71_pre1-big-filesystem.patch297
3 files changed, 296 insertions, 11 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 715f9919cb11..9b082b876b3c 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.45 2005/02/20 04:59:31 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.46 2005/03/08 00:01:40 josejx Exp $
+
+ 08 Mar 2005; Joseph Jezak <josejx@gentoo.org>
+ files/mol-0.9.71_pre1-big-filesystem.patch:
+ Updated the big filesystem patch, bug #80098.
20 Feb 2005; Joseph Jezak <josejx@gentoo.org>
+files/mol-0.9.71_pre1-big-filesystem.patch, mol-0.9.71_pre1.ebuild:
diff --git a/app-emulation/mol/Manifest b/app-emulation/mol/Manifest
index acef2a5bca9a..6e359ff9c8fe 100644
--- a/app-emulation/mol/Manifest
+++ b/app-emulation/mol/Manifest
@@ -1,4 +1,4 @@
-MD5 ced6407c96f2ab6fdd78eaa746fc1bae ChangeLog 9003
+MD5 1aae2fe015b299eacd5765d16188fbaa ChangeLog 9146
MD5 37e2c58edef99f3f2be0803169d89bcd mol-0.9.70.ebuild 4048
MD5 3263d375abba2d098c636efc2b135ea5 metadata.xml 333
MD5 7b1c05be512e22dbfb69b67e87d6d2f7 mol-0.9.70-r1.ebuild 3940
@@ -6,7 +6,7 @@ MD5 f89d7deb6015b207e4d936fbb487bff5 mol-0.9.71_pre1.ebuild 4217
MD5 f0299c003ac50a8f73bd8264889116d7 files/mol-0.9.71_pre1-linux-2.6.9.patch 2571
MD5 934e9ecf483ff3c4e34bb6307212d776 files/mol-0.9.70-nopriority.patch 1853
MD5 3944510308e77b92ac85c07708947ad0 files/digest-mol-0.9.70-r1 64
-MD5 9985a76cc5bd83c88a22a0356452c1b8 files/mol-0.9.71_pre1-big-filesystem.patch 289
+MD5 37a24cbf6bb78c4d9bd4c79b18aab9d6 files/mol-0.9.71_pre1-big-filesystem.patch 6554
MD5 2f8f758938db9b3cb5a13c0b33d989e3 files/mol-module-fix.patch 327
MD5 453e05b555f037270dd6da665e100aa8 files/digest-mol-0.9.71_pre1 69
MD5 0ea7bd65a5ff4666665a71fb9652aae8 files/mol-0.9.70-makefile-fix.patch 924
diff --git a/app-emulation/mol/files/mol-0.9.71_pre1-big-filesystem.patch b/app-emulation/mol/files/mol-0.9.71_pre1-big-filesystem.patch
index 5be5b4fdc2c2..4539a1a72c61 100644
--- a/app-emulation/mol/files/mol-0.9.71_pre1-big-filesystem.patch
+++ b/app-emulation/mol/files/mol-0.9.71_pre1-big-filesystem.patch
@@ -1,11 +1,292 @@
---- src/lib/llseek.c.old 2005-02-19 20:12:10.897625032 +1100
-+++ src/lib/llseek.c 2005-02-19 20:12:41.027044664 +1100
-@@ -23,6 +23,8 @@
- #endif
- #ifdef __linux__
- #define BLKGETSIZE _IO(0x12,96) /* from <linux/fs.h> */
+--- src/drivers/oldworld/scsi_main.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/oldworld/scsi_main.c 2004-12-13 19:14:53.286913872 +0100
+@@ -14,6 +14,10 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
+ #include "mol_config.h"
+
+ #include "booter.h"
+--- src/drivers/oldworld/include/scsi_main.h-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/oldworld/include/scsi_main.h 2004-12-13 19:14:59.434979224 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #ifndef _H_SCSI_MAIN
+ #define _H_SCSI_MAIN
+
+--- src/drivers/oldworld/scsi-unit.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/oldworld/scsi-unit.c 2004-12-13 19:15:05.629037584 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+
+ /* #define VERBOSE */
+--- src/drivers/oldworld/swim3.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/oldworld/swim3.c 2004-12-13 19:15:15.750498888 +0100
+@@ -20,6 +20,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <pthread.h>
+
+--- src/drivers/nvram.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/nvram.c 2004-12-13 19:15:22.200518336 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+
+ #include <sys/param.h>
+--- src/drivers/include/swim_hw.h-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/include/swim_hw.h 2004-12-13 19:15:27.816664552 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #ifndef _H_SWIM_HW
+ #define _H_SWIM_HW
+
+--- src/drivers/osi_driver.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/osi_driver.c 2004-12-13 19:15:32.895892392 +0100
+@@ -15,6 +15,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include "promif.h"
+ #include "booter.h"
+--- src/drivers/disk/ablk.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/disk/ablk.c 2004-12-13 19:15:39.655864720 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <sys/uio.h>
+ #include <sys/resource.h>
+--- src/drivers/disk/disk_open.c-orig 2004-12-13 19:09:16.799067000 +0100
++++ src/drivers/disk/disk_open.c 2004-12-13 19:15:45.009050912 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+
+ #include <sys/ioctl.h>
+--- src/drivers/disk/blkdev.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/disk/blkdev.c 2004-12-13 19:15:57.653128720 +0100
+@@ -15,6 +15,11 @@
+ *
+ */
+
++#ifdef __linux__
+#define _FILE_OFFSET_BITS 64
+#define _LARGE_FILES
- #endif
++#endif
++
+ #include "mol_config.h"
- ulong
+ #include <sys/time.h>
+--- src/drivers/disk/ablk-cd.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/disk/ablk-cd.c 2004-12-13 19:16:04.395103784 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <sys/uio.h>
+ #include <sys/ioctl.h>
+--- src/drivers/disk/pseudofs.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/drivers/disk/pseudofs.c 2004-12-13 19:16:09.277361568 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <sys/stat.h>
+ #include "pseudofs.h"
+--- src/cpu/mpc107/init.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/cpu/mpc107/init.c 2004-12-13 19:16:14.513565544 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <sys/mman.h>
+ #include <sys/file.h>
+--- src/booter/elf.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/booter/elf.c 2004-12-13 19:16:18.943892032 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <sys/param.h>
+ #include "booter.h"
+--- src/main/promif.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/main/promif.c 2004-12-13 19:16:23.810152248 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <sys/param.h>
+ #include <stdarg.h>
+--- src/main/memory.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/main/memory.c 2004-12-13 19:16:29.296318224 +0100
+@@ -13,6 +13,11 @@
+ * as published by the Free Software Foundation
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <sys/mman.h>
+ #include "debugger.h"
+--- src/main/session.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/main/session.c 2004-12-13 19:16:34.306556552 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include "session.h"
+ #include "verbose.h"
+--- src/include/llseek.h-orig 2004-03-21 23:20:39.000000000 +0100
++++ src/include/llseek.h 2004-12-13 19:16:42.670285072 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #ifndef _H_LONG_LSEEK
+ #define _H_LONG_LSEEK
+
+--- src/lib/llseek.c-orig 2004-12-13 19:09:16.798067000 +0100
++++ src/lib/llseek.c 2004-12-13 19:16:52.386807936 +0100
+@@ -14,6 +14,11 @@
+ *
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <sys/ioctl.h>
+ #include <sys/file.h>
+--- src/lib/elfload.c-orig 2004-03-21 23:20:40.000000000 +0100
++++ src/lib/elfload.c 2004-12-13 19:17:08.754319696 +0100
+@@ -29,6 +29,11 @@
+ (at your option) any later version.
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include "elfload.h"
+ #include "byteorder.h"
+--- util/nvs/nvs.c-orig 2004-03-21 23:20:39.000000000 +0100
++++ util/nvs/nvs.c 2004-12-13 19:17:18.003913544 +0100
+@@ -1,5 +1,10 @@
+ /* Modified version of nvsetenv */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ #include "mol_config.h"
+ #include <stdio.h>
+ #include <fcntl.h>