summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2004-08-16 01:41:02 +0000
committerIan Leitch <port001@gentoo.org>2004-08-16 01:41:02 +0000
commit8c2031e69272de99fc9733a5ce2b99c8ac25d03d (patch)
treef23c03c78ed377d7e45fa52e7a25ac817cb360f3 /app-emulation
parentUpdating patchsets for all versions, see bug #57081 for more (diff)
downloadhistorical-8c2031e69272de99fc9733a5ce2b99c8ac25d03d.tar.gz
historical-8c2031e69272de99fc9733a5ce2b99c8ac25d03d.tar.bz2
historical-8c2031e69272de99fc9733a5ce2b99c8ac25d03d.zip
Version bump. No gtk or qt support at the moment, neither work
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/pearpc/ChangeLog7
-rw-r--r--app-emulation/pearpc/Manifest14
-rw-r--r--app-emulation/pearpc/files/digest-pearpc-0.3.01
-rw-r--r--app-emulation/pearpc/pearpc-0.3.0.ebuild92
4 files changed, 112 insertions, 2 deletions
diff --git a/app-emulation/pearpc/ChangeLog b/app-emulation/pearpc/ChangeLog
index e7662e19545b..aab4a9d972ed 100644
--- a/app-emulation/pearpc/ChangeLog
+++ b/app-emulation/pearpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/pearpc
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/ChangeLog,v 1.3 2004/06/24 22:33:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/ChangeLog,v 1.4 2004/08/16 01:41:02 port001 Exp $
+
+*pearpc-0.3.0 (16 Aug 2004)
+
+ 16 Aug 2004; Ian Leitch <port001@gentoo.org> +pearpc-0.3.0.ebuild:
+ Version bump. No gtk or qt support at the moment, neither work
19 Jun 2004; David Holm <dholm@gentoo.org> pearpc-0.2.0.ebuild:
Added to ~ppc.
diff --git a/app-emulation/pearpc/Manifest b/app-emulation/pearpc/Manifest
index 2b97546b5827..6c07a346f5f3 100644
--- a/app-emulation/pearpc/Manifest
+++ b/app-emulation/pearpc/Manifest
@@ -1,4 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 21b7635ca96435ee8152450d037d39be pearpc-0.2.0.ebuild 1375
-MD5 1fdf7c0b67e1f2c7a0d0a82e77f6a570 ChangeLog 471
+MD5 7025fbe898974b19bb542268f1d395a2 pearpc-0.3.0.ebuild 2157
+MD5 fb3c39d23e965458ba7f23cf4385a882 ChangeLog 634
MD5 85f77517fd1072e8fa38899d6386bcb7 metadata.xml 238
MD5 0da949433d98e78b13793dcb92d1b8d7 files/digest-pearpc-0.2.0 65
+MD5 0f8c3e5dea2396ed22adc8931b8370d1 files/digest-pearpc-0.3.0 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFBIBDCefZ4eWAXRGIRAvmcAKCY5YFIzPQroIvgcWOrGa6WiltaEACgn/er
+HwLa5M44FwP0YzvDLp6l2Bs=
+=N95U
+-----END PGP SIGNATURE-----
diff --git a/app-emulation/pearpc/files/digest-pearpc-0.3.0 b/app-emulation/pearpc/files/digest-pearpc-0.3.0
new file mode 100644
index 000000000000..c9ac63c607e7
--- /dev/null
+++ b/app-emulation/pearpc/files/digest-pearpc-0.3.0
@@ -0,0 +1 @@
+MD5 f14f5a6dd42a7e5e715f59965f1c25a2 pearpc-0.3.0.tar.bz2 629123
diff --git a/app-emulation/pearpc/pearpc-0.3.0.ebuild b/app-emulation/pearpc/pearpc-0.3.0.ebuild
new file mode 100644
index 000000000000..a9b28839f66f
--- /dev/null
+++ b/app-emulation/pearpc/pearpc-0.3.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/pearpc-0.3.0.ebuild,v 1.1 2004/08/16 01:41:02 port001 Exp $
+
+IUSE="debug jit sdl"
+#IUSE="debug qt gtk jit sdl"
+
+DESCRIPTION="PowerPC Architecture Emulator"
+HOMEPAGE="http://pearpc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pearpc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="x86? ( dev-lang/nasm )"
+
+RDEPEND="virtual/x11
+ media-libs/libmng
+ media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/freetype
+ sdl? ( media-libs/libsdl )"
+# gtk? ( >=x11-libs/gtk-2.0 )
+# qt? ( >=x11-libs/qt-3.1.1 )"
+
+DEFAULT_TO_X11=0
+
+#pkg_setup() {
+# if (use qt && use sdl) || (use qt && use gtk) || (use gtk && sdl) || (use gtk && use qt && use sdl); then
+# ewarn
+# ewarn "More than one frontend USE flags enabled, defaulting to X11 support."
+# ewarn
+# DEFAULT_TO_X11=1
+# fi
+#}
+
+src_compile() {
+ local myconf
+ myconf="--enable-release"
+
+ use jit && myconf="${myconf} --enable-cpu=jitc_x86"
+
+ if use debug; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+
+ if [ $DEFAULT_TO_X11 = 1 ]; then
+ myconf="${myconf} --enable-ui=x11"
+ else
+ if use sdl; then
+ myconf="${myconf} --enable-ui=sdl"
+# elif use qt; then
+# myconf="${myconf} --enable-ui=qt"
+# elif use gtk; then
+# myconf="${myconf} --enable-ui=gtk"
+ else
+ myconf="${myconf} --enable-ui=x11"
+ fi
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin src/ppc
+ dodoc ChangeLog AUTHORS COPYING README TODO
+
+ dodir /usr/share/${P}
+ insinto /usr/share/${P}
+ doins scripts/ifppc_down scripts/ifppc_up
+ doins video.x
+
+ insinto /usr/share/doc/${P}
+ sed -i -e "s:video.x:/usr/share/${P}/video.x:g" ppccfg.example
+ doins ppccfg.example
+}
+
+pkg_postinst() {
+ echo
+ einfo "You will need to update your configuration files to point"
+ einfo "to the new location of video.x, which is now"
+ einfo "/usr/share/${P}/video.x"
+ echo
+ einfo "Also, be sure to check /usr/share/doc/${P}/ppccfg.example"
+ einfo "for new configuration options."
+ echo
+}