summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-03-24 12:56:26 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2012-03-24 12:56:26 +0000
commit6df8b9c5faf75ce65f8c826729ff6d85fa9574be (patch)
tree0b71923b0c6023b6803fd8a7f768410125533886 /app-emulation
parentAdd Prefix keywords, bug #403413 (diff)
downloadhistorical-6df8b9c5faf75ce65f8c826729ff6d85fa9574be.tar.gz
historical-6df8b9c5faf75ce65f8c826729ff6d85fa9574be.tar.bz2
historical-6df8b9c5faf75ce65f8c826729ff6d85fa9574be.zip
version bump
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools-kmod/ChangeLog11
-rw-r--r--app-emulation/open-vm-tools-kmod/files/moduleparam.patch12
-rw-r--r--app-emulation/open-vm-tools-kmod/files/setnlink.patch45
-rw-r--r--app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2012.03.13.651368.ebuild76
-rw-r--r--app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-8.8.2.590212.ebuild (renamed from app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-8.8.1.528969.ebuild)4
-rw-r--r--app-emulation/open-vm-tools/ChangeLog10
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild114
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-8.8.2.590212.ebuild (renamed from app-emulation/open-vm-tools/open-vm-tools-8.8.1.528969.ebuild)4
8 files changed, 212 insertions, 64 deletions
diff --git a/app-emulation/open-vm-tools-kmod/ChangeLog b/app-emulation/open-vm-tools-kmod/ChangeLog
index 7a241ef51f07..e5d7ad14b8a6 100644
--- a/app-emulation/open-vm-tools-kmod/ChangeLog
+++ b/app-emulation/open-vm-tools-kmod/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/open-vm-tools-kmod
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/ChangeLog,v 1.23 2012/03/17 17:23:45 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/ChangeLog,v 1.24 2012/03/24 12:55:45 vadimk Exp $
+
+*open-vm-tools-kmod-8.8.2.590212 (24 Mar 2012)
+*open-vm-tools-kmod-2012.03.13.651368 (24 Mar 2012)
+
+ 24 Mar 2012; Vadim Kuznetsov <vadimk@gentoo.org>
+ +open-vm-tools-kmod-2012.03.13.651368.ebuild,
+ +open-vm-tools-kmod-8.8.2.590212.ebuild, -files/moduleparam.patch,
+ -files/setnlink.patch, -open-vm-tools-kmod-8.8.1.528969.ebuild:
+ version bump
17 Mar 2012; Vadim Kuznetsov <vadimk@gentoo.org>
-open-vm-tools-kmod-0.0.20111026.514583.ebuild:
diff --git a/app-emulation/open-vm-tools-kmod/files/moduleparam.patch b/app-emulation/open-vm-tools-kmod/files/moduleparam.patch
deleted file mode 100644
index 6589705a3a1c..000000000000
--- a/app-emulation/open-vm-tools-kmod/files/moduleparam.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/modules/linux/vmhgfs/tcp.c b/modules/linux/vmhgfs/tcp.c
-index c7070a6..31a40df 100644
---- a/modules/linux/vmhgfs/tcp.c
-+++ b/modules/linux/vmhgfs/tcp.c
-@@ -32,6 +32,7 @@
- #include <linux/in.h>
- #include <linux/net.h>
- #include <linux/inet.h>
-+#include <linux/moduleparam.h>
- #include <linux/errno.h>
- #include <linux/kthread.h>
-
diff --git a/app-emulation/open-vm-tools-kmod/files/setnlink.patch b/app-emulation/open-vm-tools-kmod/files/setnlink.patch
deleted file mode 100644
index 9ae4fe7a4fef..000000000000
--- a/app-emulation/open-vm-tools-kmod/files/setnlink.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/modules/linux/vmhgfs/fsutil.c b/modules/linux/vmhgfs/fsutil.c
-index 0c5102b..a978005 100644
---- a/modules/linux/vmhgfs/fsutil.c
-+++ b/modules/linux/vmhgfs/fsutil.c
-@@ -62,6 +62,31 @@ static int HgfsPackGetattrRequest(HgfsReq *req,
- * Private function implementations.
- */
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
-+/*
-+ *----------------------------------------------------------------------------
-+ *
-+ * set_nlink --
-+ *
-+ * Set an inode's link count.
-+ *
-+ * Results:
-+ * None
-+ *
-+ * Side effects:
-+ * None
-+ *
-+ *----------------------------------------------------------------------------
-+ */
-+
-+static inline void
-+set_nlink(struct inode *inode, unsigned int nlink)
-+{
-+ inode->i_nlink = nlink;
-+}
-+#endif
-+
-+
- /*
- *----------------------------------------------------------------------
- *
-@@ -607,7 +632,7 @@ HgfsChangeFileAttributes(struct inode *inode, // IN/OUT: Inode
- * account for '.' and ".."), and find printed a hard link error. So until
- * we have getattr support for nlink, everyone gets 1.
- */
-- inode->i_nlink = 1;
-+ set_nlink(inode, 1);
-
- /*
- * Use the stored uid and gid if we were given them at mount-time, or if
diff --git a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2012.03.13.651368.ebuild b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2012.03.13.651368.ebuild
new file mode 100644
index 000000000000..41eb59a34a40
--- /dev/null
+++ b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2012.03.13.651368.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2012.03.13.651368.ebuild,v 1.1 2012/03/24 12:55:45 vadimk Exp $
+
+EAPI="4"
+
+inherit linux-mod versionator
+
+MY_PN="${PN/-kmod}"
+MY_PV="$(replace_version_separator 3 '-')"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ VMWARE_MOD_DIR="modules/linux"
+ VMWARE_MODULE_LIST="vmblock vmci vmhgfs vmsync vmxnet vsock"
+
+ MODULE_NAMES=""
+ BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR} OVT_SOURCE_DIR=${S}"
+
+ for mod in ${VMWARE_MODULE_LIST};
+ do
+ if [ "${mod}" == "vmxnet" ];
+ then
+ MODTARGET="net"
+ else
+ MODTARGET="openvmtools"
+ fi
+ MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
+ done
+}
+
+src_prepare() {
+ sed -i.bak -e '/\smake\s/s/make/$(MAKE)/g' modules/linux/{vmblock,vmci,vmhgfs,vmsync,vmxnet,vsock}/Makefile\
+ || die "Sed failed."
+}
+
+src_configure() {
+ : # do nothing at all
+}
+
+src_install() {
+ linux-mod_src_install
+
+ local udevrules="${T}/60-vmware.rules"
+ cat > "${udevrules}" <<-EOF
+ KERNEL=="vsock", GROUP="vmware", MODE=660
+ EOF
+ insinto /etc/udev/rules.d/
+ doins "${udevrules}"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog "vmxnet3 for Linux is now upstream (as of Linux 2.6.32)"
+ elog "pvscsi for Linux is now upstream (vmw_pvscsi) (as of Linux 2.6.33)"
+ elog "vmmemctl for Linux is now upstream (vmw_balloon) (as of Linux 2.6.34)"
+}
diff --git a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-8.8.1.528969.ebuild b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-8.8.2.590212.ebuild
index 1d0def00d634..82f874e6d682 100644
--- a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-8.8.1.528969.ebuild
+++ b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-8.8.2.590212.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-8.8.1.528969.ebuild,v 1.2 2012/02/04 16:34:59 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-8.8.2.590212.ebuild,v 1.1 2012/03/24 12:55:45 vadimk Exp $
EAPI="4"
@@ -51,8 +51,6 @@ pkg_setup() {
src_prepare() {
sed -i.bak -e '/\smake\s/s/make/$(MAKE)/g' modules/linux/{vmblock,vmci,vmhgfs,vmsync,vmxnet,vsock}/Makefile\
|| die "Sed failed."
- kernel_is ge 3 2 0 && epatch "${FILESDIR}/moduleparam.patch"
- kernel_is ge 3 2 0 && epatch "${FILESDIR}/setnlink.patch"
kernel_is ge 3 2 0 && epatch "${FILESDIR}/fragsize.patch"
}
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 5553f78a30f7..bb4198b1a8f2 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.60 2012/03/17 17:23:10 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.61 2012/03/24 12:56:26 vadimk Exp $
+
+*open-vm-tools-2012.03.13.651368 (24 Mar 2012)
+*open-vm-tools-8.8.2.590212 (24 Mar 2012)
+
+ 24 Mar 2012; Vadim Kuznetsov <vadimk@gentoo.org>
+ +open-vm-tools-2012.03.13.651368.ebuild, +open-vm-tools-8.8.2.590212.ebuild,
+ -open-vm-tools-8.8.1.528969.ebuild:
+ version bump
17 Mar 2012; Vadim Kuznetsov <vadimk@gentoo.org>
-open-vm-tools-0.0.20111026.514583.ebuild:
diff --git a/app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild b/app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild
new file mode 100644
index 000000000000..abef36af7e71
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild,v 1.1 2012/03/24 12:56:26 vadimk Exp $
+
+EAPI="4"
+
+inherit eutils pam versionator flag-o-matic toolchain-funcs
+
+MY_PV="$(replace_version_separator 3 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc fuse icu +pic xinerama"
+
+RDEPEND="app-emulation/open-vm-tools-kmod
+ dev-libs/glib:2
+ dev-libs/libdnet
+ sys-apps/ethtool
+ sys-process/procps
+ virtual/pam
+ X? (
+ dev-cpp/gtkmm:2.4
+ x11-base/xorg-server
+ x11-drivers/xf86-input-vmmouse
+ x11-drivers/xf86-video-vmware
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ fuse? ( sys-fs/fuse )
+ icu? ( dev-libs/icu )
+ xinerama? ( x11-libs/libXinerama )
+ "
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig
+ virtual/linux-sources
+ sys-apps/findutils
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup vmware
+}
+
+src_prepare() {
+ # Do not filter out Werror
+ # Upstream Bug http://sourceforge.net/tracker/?func=detail&aid=2959749&group_id=204462&atid=989708
+ # sed -i -e 's/CFLAGS=.*Werror/#&/g' configure || die "sed comment out Werror failed"
+ sed -i -e 's:\(TEST_PLUGIN_INSTALLDIR=\).*:\1\$libdir/open-vm-tools/plugins/tests:g' configure || die "sed test_plugin_installdir failed"
+}
+
+src_configure() {
+ # http://bugs.gentoo.org/402279
+ if has_version '>=sys-process/procps-3.3.2'; then
+ export CUSTOM_PROCPS_NAME=procps
+ export CUSTOM_PROCPS_LIBS="$($(tc-getPKG_CONFIG) --libs libprocps)"
+ fi
+
+ econf \
+ --with-procps \
+ --with-dnet \
+ --without-kernel-modules \
+ $(use_enable doc docs) \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with X x) \
+ $(use_with X gtk2) \
+ $(use_with X gtkmm) \
+ $(use_with icu) \
+ $(use_with pic) \
+ $(use_enable xinerama multimon)
+
+ # Bugs 260878, 326761
+ find ./ -name Makefile | xargs sed -i -e 's/-Werror//g' || die "sed out Werror failed"
+}
+
+src_install() {
+ default
+
+ rm "${D}"/etc/pam.d/vmtoolsd
+ pamd_mimic_system vmtoolsd auth account
+
+ rm "${D}"/usr/$(get_libdir)/*.la
+ rm "${D}"/usr/$(get_libdir)/open-vm-tools/plugins/common/*.la
+
+ newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
+ newconfd "${FILESDIR}/open-vm-tools.confd" vmware-tools
+
+ exeinto /etc/vmware-tools/scripts/vmware/
+ doexe "${FILESDIR}"/network
+
+ if use X;
+ then
+ fperms 4755 "/usr/bin/vmware-user-suid-wrapper"
+
+ dobin "${S}"/scripts/common/vmware-xdg-detect-de
+
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, please add the users to the 'vmware' group."
+ fi
+ elog "Add 'vmware-tools' service to the default runlevel."
+}
diff --git a/app-emulation/open-vm-tools/open-vm-tools-8.8.1.528969.ebuild b/app-emulation/open-vm-tools/open-vm-tools-8.8.2.590212.ebuild
index b152bf9be400..455ab9a9f3e0 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-8.8.1.528969.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-8.8.2.590212.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-8.8.1.528969.ebuild,v 1.1 2011/12/03 18:34:42 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-8.8.2.590212.ebuild,v 1.1 2012/03/24 12:56:26 vadimk Exp $
EAPI="4"