summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-02 11:55:53 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-02 11:55:53 +0000
commit19ea960a17b0723d658426d694744eacf3ca428b (patch)
tree660f98fa0abb3a482ed2f9e645ef540cecda05f0 /app-emulation/uae/uae-0.8.29-r2.ebuild
parentDowngrade 4.2_p46-r1 to EAPI 4 per Poly-C's request, as this is an essential ... (diff)
downloadhistorical-19ea960a17b0723d658426d694744eacf3ca428b.tar.gz
historical-19ea960a17b0723d658426d694744eacf3ca428b.tar.bz2
historical-19ea960a17b0723d658426d694744eacf3ca428b.zip
[QA] Revision bump to 0.8.29-r2. EAPI 5.
Package-Manager: portage-HEAD/cvs/Linux x86_64 Manifest-Sign-Key: 0x6D34E57D
Diffstat (limited to 'app-emulation/uae/uae-0.8.29-r2.ebuild')
-rw-r--r--app-emulation/uae/uae-0.8.29-r2.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-emulation/uae/uae-0.8.29-r2.ebuild b/app-emulation/uae/uae-0.8.29-r2.ebuild
new file mode 100644
index 000000000000..8f0c3b0c758c
--- /dev/null
+++ b/app-emulation/uae/uae-0.8.29-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.29-r2.ebuild,v 1.1 2014/04/02 11:55:44 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="The Umiquious Amiga Emulator"
+HOMEPAGE="http://www.amigaemulator.org/"
+SRC_URI="ftp://ftp.amigaemulator.org/pub/uae/sources/develop/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="sdl alsa scsi"
+
+DEPEND="sdl? ( media-libs/libsdl
+ media-libs/sdl-gfx
+ x11-libs/gtk+:2
+ alsa? ( media-libs/alsa-lib )
+ )
+ !sdl? ( x11-libs/libXext
+ x11-libs/gtk+:2
+ )
+ alsa? ( media-libs/alsa-lib )
+ scsi? ( app-cdr/cdrtools )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.25-allow_spaces_in_zip_filenames.diff
+ epatch "${FILESDIR}"/${PN}-0.8.25-struct_uae_wrong_fields_name.diff
+ epatch "${FILESDIR}"/${PN}-0.8.26-uae_reset_args.diff
+
+ cp "${FILESDIR}"/sdlgfx.h "${S}"/src || die
+}
+
+src_configure() {
+ # disabling lots of options, cause many code-paths are broken, these should compile,
+ # if you want/need other options, please test if they work with other combinations
+ # before opening a bug
+ econf --enable-ui --with-x --without-svgalib \
+ --without-asciiart --without-sdl-sound --enable-threads \
+ $(use_with sdl) $(use_with sdl sdl-gfx) \
+ $(use_with alsa) \
+ $(use_enable scsi scsi-device)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dobin uae readdisk
+ cp docs/unix/README docs/README.unix || die
+ rm -r docs/{AmigaOS,BeOS,pOS,translated,unix} || die
+ dodoc docs/*
+
+ insinto /usr/share/uae/amiga-tools
+ doins amiga/{*hack,trans*,uae*}
+}
+
+pkg_postinst() {
+ elog
+ elog "Upstream recomends using SDL graphics (with an environment variable)"
+ elog "SDL_VIDEO_X11_XRANDR=1 for fullscreen support."
+ echo
+}