summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-03 06:43:38 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-03 06:43:38 +0000
commit47f690378b2990860858006bbd5275c5842375d6 (patch)
treefe550a45c4657dd2365941ddcd90db6cf8b7eb44 /app-emacs
parentUnmasking alsa packages: switched to using ~arch instead. (diff)
downloadhistorical-47f690378b2990860858006bbd5275c5842375d6.tar.gz
historical-47f690378b2990860858006bbd5275c5842375d6.tar.bz2
historical-47f690378b2990860858006bbd5275c5842375d6.zip
initial
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/h4x0r/ChangeLog11
-rw-r--r--app-emacs/h4x0r/files/50h4x0r-gentoo.el6
-rw-r--r--app-emacs/h4x0r/files/digest-h4x0r-0.111
-rw-r--r--app-emacs/h4x0r/h4x0r-0.11.ebuild38
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/h4x0r/ChangeLog b/app-emacs/h4x0r/ChangeLog
new file mode 100644
index 000000000000..df7bedb825e2
--- /dev/null
+++ b/app-emacs/h4x0r/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/h4x0r
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/h4x0r/ChangeLog,v 1.1 2002/11/03 06:43:38 mkennedy Exp $
+
+*h4x0r-0.11 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ h4x0r-0.11.ebuild, files/50h4x0r-gentoo.el,
+ files/digest-h4x0r-0.11 :
+
+ Initial import.
diff --git a/app-emacs/h4x0r/files/50h4x0r-gentoo.el b/app-emacs/h4x0r/files/50h4x0r-gentoo.el
new file mode 100644
index 000000000000..b6cffe8f52b5
--- /dev/null
+++ b/app-emacs/h4x0r/files/50h4x0r-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; h4x0r site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'h4x0r)
+
diff --git a/app-emacs/h4x0r/files/digest-h4x0r-0.11 b/app-emacs/h4x0r/files/digest-h4x0r-0.11
new file mode 100644
index 000000000000..b34e773875ec
--- /dev/null
+++ b/app-emacs/h4x0r/files/digest-h4x0r-0.11
@@ -0,0 +1 @@
+MD5 ff65a6bba69a148fc3b8c3b16748285f h4x0r-0.11.tar.bz2 1755
diff --git a/app-emacs/h4x0r/h4x0r-0.11.ebuild b/app-emacs/h4x0r/h4x0r-0.11.ebuild
new file mode 100644
index 000000000000..0ff8c19684c3
--- /dev/null
+++ b/app-emacs/h4x0r/h4x0r-0.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/h4x0r/h4x0r-0.11.ebuild,v 1.1 2002/11/03 06:43:38 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Aid in writing like a script kiddie does"
+HOMEPAGE="http://www.livingtorah.org/~csebold/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50h4x0r-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/h4x0r.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}