summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-05-26 15:24:48 +0000
committerMamoru Komachi <usata@gentoo.org>2004-05-26 15:24:48 +0000
commit977148531518a530225d2b234b42a9028e03be9a (patch)
treef3912c9e5e002c998d5858bf198449106f3c959f /app-emacs/howm/howm-1.1.2.1-r1.ebuild
parentchange defaults from xfree to xorg (diff)
downloadhistorical-977148531518a530225d2b234b42a9028e03be9a.tar.gz
historical-977148531518a530225d2b234b42a9028e03be9a.tar.bz2
historical-977148531518a530225d2b234b42a9028e03be9a.zip
Fixed site file installation
Diffstat (limited to 'app-emacs/howm/howm-1.1.2.1-r1.ebuild')
-rw-r--r--app-emacs/howm/howm-1.1.2.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/howm/howm-1.1.2.1-r1.ebuild b/app-emacs/howm/howm-1.1.2.1-r1.ebuild
new file mode 100644
index 000000000000..560dc7c464f4
--- /dev/null
+++ b/app-emacs/howm/howm-1.1.2.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Howm is a note-taking tool on Emacs"
+SRC_URI="http://howm.sourceforge.jp/a/${P}.tar.gz"
+HOMEPAGE="http://howm.sourceforge.jp/"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND="virtual/emacs"
+
+SITEFILE="50howm-gentoo.el"
+
+src_compile() {
+
+ econf --with-docdir=/usr/share/doc/${P} || die
+ emake < /dev/null || die
+}
+
+src_install () {
+
+ emake < /dev/null \
+ DESTDIR=${D} PREFIX=/usr LISPDIR=${SITELISP}/${PN} install || die
+ elisp-site-file-install ${FILESDIR}/${SITEFILE} || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you prefer Japanese menu, add the following line to your ~/.emacs"
+ einfo
+ einfo "(setq howm-menu-lang 'ja) ; Japanese interface"
+ einfo
+
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}