summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-04-08 16:21:00 +0000
committerUlrich Müller <ulm@gentoo.org>2009-04-08 16:21:00 +0000
commit7fd219f9af4d49bf81cff84dbace441677ba9dcc (patch)
tree4c23b076dff8a85d49e7d47983fb985c550cfb22 /app-emacs/company-mode
parentNew package, dependency of sci-biology/bioperl (diff)
downloadhistorical-7fd219f9af4d49bf81cff84dbace441677ba9dcc.tar.gz
historical-7fd219f9af4d49bf81cff84dbace441677ba9dcc.tar.bz2
historical-7fd219f9af4d49bf81cff84dbace441677ba9dcc.zip
Initial import, from Emacs overlay, bug 226031.
Package-Manager: portage-2.2_rc28/cvs/Linux i686
Diffstat (limited to 'app-emacs/company-mode')
-rw-r--r--app-emacs/company-mode/ChangeLog11
-rw-r--r--app-emacs/company-mode/Manifest15
-rw-r--r--app-emacs/company-mode/company-mode-0.2.1.ebuild36
-rw-r--r--app-emacs/company-mode/files/50company-mode-gentoo.el2
-rw-r--r--app-emacs/company-mode/metadata.xml9
5 files changed, 73 insertions, 0 deletions
diff --git a/app-emacs/company-mode/ChangeLog b/app-emacs/company-mode/ChangeLog
new file mode 100644
index 000000000000..4ad670aef768
--- /dev/null
+++ b/app-emacs/company-mode/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/company-mode
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/ChangeLog,v 1.1 2009/04/08 16:20:59 ulm Exp $
+
+*company-mode-0.2.1 (08 Apr 2009)
+
+ 08 Apr 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/50company-mode-gentoo.el, +metadata.xml,
+ +company-mode-0.2.1.ebuild:
+ Initial import, from Emacs overlay, bug 226031. Ebuild contributed by me.
+
diff --git a/app-emacs/company-mode/Manifest b/app-emacs/company-mode/Manifest
new file mode 100644
index 000000000000..2ae049e84d4a
--- /dev/null
+++ b/app-emacs/company-mode/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 50company-mode-gentoo.el 79 RMD160 ccb20f0d54ed7cfbe9f26b2819fcb3419b8e13ba SHA1 56354ef1d7f03d4eeb59f11e5455ccf15af2b1df SHA256 9e50754cd23e5babffb29c4c93b4df8c34680fb714f6fc36a73d5c739cc4c3b0
+DIST company-0.2.1.tar.bz2 18158 RMD160 cc90cf29716c9074c9573f7fd1f78f05094f2c9a SHA1 610b6a7285a74220bfa46fa1f160e6840e46d7a6 SHA256 96c15f7a2be9d1dabbf286ab7f5f6ff8c228b1a3371d96ad36ccad1a0b00adc9
+EBUILD company-mode-0.2.1.ebuild 1010 RMD160 33bf5646a4f764eb437057811f8a830db9e372eb SHA1 bc8bf08dd60d85338083e82323836daf439485b0 SHA256 71ccaf7340ba987bf31a7f57ba4b665725f9dcb3b95e1a810d444f67989091fb
+MISC ChangeLog 453 RMD160 5da4ab8f05842c42d63a5db8bd8af4ed1b34f31b SHA1 27aaabe3e824d91872c5adc629808ae49cb81b66 SHA256 456a6f457c8e94d11f2fce07554ea01016cb3f27bdf3b7e660635e5991f3731b
+MISC metadata.xml 264 RMD160 fee47893caceaee540a298ea5be98c1ccc30c4bb SHA1 c22d054bd4537d56ae81dd7bcd5d91da0541d5c7 SHA256 d87731d73adb0aeb01ff8ec113f72121cfae828470693060904ca8d3fa26ee9a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.9 (GNU/Linux)
+
+iEUEARECAAYFAkncz0QACgkQOeoy/oIi7uy4gACWM1b9TC9pu/d0unaHP3vcsq+i
+nACgpJMYsmkGkn6ABLiA+u+G7D4rFuU=
+=RrAn
+-----END PGP SIGNATURE-----
diff --git a/app-emacs/company-mode/company-mode-0.2.1.ebuild b/app-emacs/company-mode/company-mode-0.2.1.ebuild
new file mode 100644
index 000000000000..9c9527a4da9c
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/company-mode/company-mode-0.2.1.ebuild,v 1.1 2009/04/08 16:20:59 ulm Exp $
+
+EAPI=2
+NEED_EMACS=22
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="http://nschum.de/src/emacs/company-mode/"
+SRC_URI="http://nschum.de/src/emacs/${PN}/company-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic"
+
+DEPEND="semantic? ( app-emacs/cedet )"
+ #oddmuse? ( app-emacs/oddmuse )
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ # Disable backends that require extra dependencies, unless they are
+ # selected by the respective USE flag
+ local backend
+ for backend in oddmuse semantic; do
+ [ "${backend}" = semantic ] && use "${backend}" && continue
+ elog "Disabling ${backend} backend"
+ rm "company-${backend}.el" || die
+ sed -i -e "s/company-${backend} *//" company.el || die
+ done
+}
diff --git a/app-emacs/company-mode/files/50company-mode-gentoo.el b/app-emacs/company-mode/files/50company-mode-gentoo.el
new file mode 100644
index 000000000000..cd85457fe91e
--- /dev/null
+++ b/app-emacs/company-mode/files/50company-mode-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'company-mode "company" nil t)
diff --git a/app-emacs/company-mode/metadata.xml b/app-emacs/company-mode/metadata.xml
new file mode 100644
index 000000000000..94a72c765714
--- /dev/null
+++ b/app-emacs/company-mode/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<use>
+ <flag name='semantic'>Install backend for semantic
+ (<pkg>app-emacs/cedet</pkg>)</flag>
+</use>
+</pkgmetadata>