summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2007-07-04 22:42:11 +0000
committerChristian Faulhammer <fauli@gentoo.org>2007-07-04 22:42:11 +0000
commit3ee43362383aa9aa83691b276059c06db5fce7f5 (patch)
tree6f671c030714d9e403326721a61a412a7254c476 /app-emacs/calc/calc-2.02f.ebuild
parentUse JAVA_PKG_IUSE and delete bundled classes in src_unpack. (diff)
downloadhistorical-3ee43362383aa9aa83691b276059c06db5fce7f5.tar.gz
historical-3ee43362383aa9aa83691b276059c06db5fce7f5.tar.bz2
historical-3ee43362383aa9aa83691b276059c06db5fce7f5.zip
added some quotes; added die comment
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'app-emacs/calc/calc-2.02f.ebuild')
-rw-r--r--app-emacs/calc/calc-2.02f.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-emacs/calc/calc-2.02f.ebuild b/app-emacs/calc/calc-2.02f.ebuild
index a84dfead8c26..d52cef0a6609 100644
--- a/app-emacs/calc/calc-2.02f.ebuild
+++ b/app-emacs/calc/calc-2.02f.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/calc/calc-2.02f.ebuild,v 1.2 2006/12/10 17:43:51 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/calc/calc-2.02f.ebuild,v 1.3 2007/07/04 22:42:11 opfer Exp $
inherit elisp eutils
@@ -17,18 +17,18 @@ SITEFILE="50calc-gentoo.el"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-emacs-21.patch
- epatch ${FILESDIR}/${P}-info-dir.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-emacs-21.patch"
+ epatch "${FILESDIR}/${P}-info-dir.patch"
}
src_compile() {
- emake compile info || die
+ emake compile info || die "emake failed"
}
src_install() {
elisp-install ${PN} calc*.el calc*.elc
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
doinfo calc.info*
dodoc README README.prev
}