summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-01-21 19:41:06 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-01-21 19:41:06 +0000
commitab6b72672a54b0774b01a0cde1d1b3a6f902c10a (patch)
tree6eab3616b1ff0fc02139838b09c67e88ee4c4358 /app-editors/wily
parentFixed DEPEND for modular X. (diff)
downloadhistorical-ab6b72672a54b0774b01a0cde1d1b3a6f902c10a.tar.gz
historical-ab6b72672a54b0774b01a0cde1d1b3a6f902c10a.tar.bz2
historical-ab6b72672a54b0774b01a0cde1d1b3a6f902c10a.zip
Make modular X friendly.
Package-Manager: portage-2.0.54
Diffstat (limited to 'app-editors/wily')
-rw-r--r--app-editors/wily/ChangeLog9
-rw-r--r--app-editors/wily/Manifest16
-rw-r--r--app-editors/wily/files/digest-wily-1.0-r11
-rw-r--r--app-editors/wily/wily-1.0-r1.ebuild41
4 files changed, 53 insertions, 14 deletions
diff --git a/app-editors/wily/ChangeLog b/app-editors/wily/ChangeLog
index 7545d17da68d..851a4413a07f 100644
--- a/app-editors/wily/ChangeLog
+++ b/app-editors/wily/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/wily
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/wily/ChangeLog,v 1.9 2005/09/25 12:33:45 tove Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wily/ChangeLog,v 1.10 2006/01/21 19:41:06 vanquirius Exp $
+
+*wily-1.0-r1 (21 Jan 2006)
+
+ 21 Jan 2006; Marcelo Goes <vanquirius@gentoo.org> +wily-1.0-r1.ebuild:
+ Make modular X friendly.
25 Sep 2005; Torsten Veller <tove@gentoo.org> wily-1.0.ebuild:
Adapts changes in dev-libs/9libs.
diff --git a/app-editors/wily/Manifest b/app-editors/wily/Manifest
index 5ca213c0cc76..c2f3af705c95 100644
--- a/app-editors/wily/Manifest
+++ b/app-editors/wily/Manifest
@@ -1,13 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 ea3ce3a8aea241b4e11c8e19cd44452b ChangeLog 1054
-MD5 d5c65ec4f3cd4fb9d26b2b875ff7efb0 wily-1.0.ebuild 877
+MD5 71ab31314dd304ff65c63a1e793f6cac ChangeLog 1190
MD5 ac1d989779c3d7f524fb5470d2b48e1b files/digest-wily-1.0 62
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDNplAV3J2n04EauwRAtneAJ9TmSABcelGnruzhMCtjMIwHL4c+wCfZBP5
-PD+YBhkpZ62cEpe+X852EmE=
-=icgU
------END PGP SIGNATURE-----
+MD5 ac1d989779c3d7f524fb5470d2b48e1b files/digest-wily-1.0-r1 62
+MD5 2ff013956d452f5d08e9375669edd788 wily-1.0-r1.ebuild 1003
+MD5 d5c65ec4f3cd4fb9d26b2b875ff7efb0 wily-1.0.ebuild 877
diff --git a/app-editors/wily/files/digest-wily-1.0-r1 b/app-editors/wily/files/digest-wily-1.0-r1
new file mode 100644
index 000000000000..2579452decb1
--- /dev/null
+++ b/app-editors/wily/files/digest-wily-1.0-r1
@@ -0,0 +1 @@
+MD5 453f6473bf2603bf5b3c9cfe0be7a394 wily-9libs.tar.gz 125247
diff --git a/app-editors/wily/wily-1.0-r1.ebuild b/app-editors/wily/wily-1.0-r1.ebuild
new file mode 100644
index 000000000000..babcdc5a4f49
--- /dev/null
+++ b/app-editors/wily/wily-1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wily/wily-1.0-r1.ebuild,v 1.1 2006/01/21 19:41:06 vanquirius Exp $
+
+inherit toolchain-funcs
+
+MY_P="${P/1.0/9libs}"
+
+DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor for programmers."
+HOMEPAGE="http://www.netlib.org/research/9libs/"
+SRC_URI="ftp://www.netlib.org/research/9libs/${MY_P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/9libs
+ ( || (
+ ( >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0 )
+ virtual/x11 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf --includedir="/usr/include/9libs" || die "configure failed."
+ emake || die "make failed."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+ dodoc README
+ insinto /usr/share/${PN}
+ doins "${S}"/misc/*
+}
+