summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-06 15:43:04 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-06 15:43:04 +0000
commit4b5c9e04bc989332198e91bf9d0ad27cd1c93148 (patch)
tree98301bcb5f3e40fe3c2107a3ecba43dacedee70b /app-editors/ted/ted-2.11.ebuild
parentRemoved RDEPEND="${DEPEND}" (diff)
downloadhistorical-4b5c9e04bc989332198e91bf9d0ad27cd1c93148.tar.gz
historical-4b5c9e04bc989332198e91bf9d0ad27cd1c93148.tar.bz2
historical-4b5c9e04bc989332198e91bf9d0ad27cd1c93148.zip
Removed RDEPEND=${DEPEND}
Diffstat (limited to 'app-editors/ted/ted-2.11.ebuild')
-rw-r--r--app-editors/ted/ted-2.11.ebuild45
1 files changed, 17 insertions, 28 deletions
diff --git a/app-editors/ted/ted-2.11.ebuild b/app-editors/ted/ted-2.11.ebuild
index 686feb31f757..f2821bf96272 100644
--- a/app-editors/ted/ted-2.11.ebuild
+++ b/app-editors/ted/ted-2.11.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.11.ebuild,v 1.4 2002/10/17 13:17:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.11.ebuild,v 1.5 2002/11/06 15:43:04 vapier Exp $
DESCRIPTION="ted is an X-based rich text editor."
HOMEPAGE="http://www.nllgg.nl/Ted"
SRC_URI="ftp://ftp.nluug.nl/pub/editors/ted/${P}.src.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc sparc64"
@@ -14,14 +15,10 @@ DEPEND=">=x11-libs/openmotif-2.1.30
>=media-libs/jpeg-6b
>=media-libs/libpng-1.2.3
>=media-libs/xpm-3.4k"
-RDEPEND=${DEPEND}
-
-
S="${WORKDIR}/Ted-2.11"
-
src_unpack() {
- tar --use=gzip -xvf /usr/portage/distfiles/${A}
+ unpack ${A}
cd ${S}/Ted
mv makefile.in makefile.in.orig
sed 's@^CFLAGS=@CFLAGS= -DDOCUMENT_DIR=\\"/usr/share/doc/${PF}/Ted/\\"@' makefile.in.orig > makefile.in
@@ -31,42 +28,34 @@ src_compile() {
cd ${S} || die "where are we?" $(pwd)
for dir in Ted tedPackage appFrame appUtil ind bitmap libreg; do
- (
- cd ${dir};
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --cache-file=../config.cache \
- --mandir=/usr/share/man || die "./configure failed"
- )
+ cd ${dir}
+ econf --cache-file=../config.cache
done
- #
+
# The makefile doesn't really allow parallel make, but it does
# no harm either.
- #
emake DEF_AFMDIR=-DAFMDIR=\\\"/usr/share/Ted/afm\\\" \
DEF_INDDIR=-DINDDIR=\\\"/usr/share/Ted/ind\\\" \
- package.shared || die
+ package.shared || die "couldnt emake"
}
-src_install () {
+src_install() {
cd ${WORKDIR}
cd ..
- (
- mkdir temp/pkg;
- cd temp/pkg || die "Couldn't cd to package"
- tar --use=gzip -xvf ../../work/Ted-2.11/tedPackage/Ted*.tar.gz || die;
- ) || die
+
+ mkdir temp/pkg
+ cd temp/pkg || die "Couldn't cd to package"
+ tar --use=gzip -xvf ../../work/Ted-2.11/tedPackage/Ted*.tar.gz || die "couldnt unpack tedPackage/Ted*.tar.gz"
+
mkdir -p ${D}/usr/share/Ted || die "mkdir Ted failed"
- cp -R temp/pkg/afm ${D}/usr/share/Ted/afm || die
- cp -R temp/pkg/ind ${D}/usr/share/Ted/ind || die
+ cp -R temp/pkg/afm ${D}/usr/share/Ted/afm || die "couldnt cp temp/pkg/afm"
+ cp -R temp/pkg/ind ${D}/usr/share/Ted/ind || die "couldnt cp temp/pkg/ind"
exeinto /usr/bin
- doexe temp/pkg/bin/* || die
+ doexe temp/pkg/bin/* || die "couldnt doexe temp/pkg/bin/*"
mkdir -p ${D}/usr/share/doc/${P}
- cp -R temp/pkg/Ted ${D}/usr/share/doc/${P} || die
+ cp -R temp/pkg/Ted ${D}/usr/share/doc/${P} || die "couldnt cp temp/pkg/Ted"
rm -rf temp
}