summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-02-19 12:20:02 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-02-19 12:20:02 +0000
commit13706c7715e2906289d7a73d602a80f5aa06a76c (patch)
tree2f96a6c896ceddfc3d10de1ea4906fb75f9bbf24 /app-editors/nedit
parentQuoted NTOP_OPTS in /etc/conf.d/ntop to fix bug #80663 (diff)
downloadhistorical-13706c7715e2906289d7a73d602a80f5aa06a76c.tar.gz
historical-13706c7715e2906289d7a73d602a80f5aa06a76c.tar.bz2
historical-13706c7715e2906289d7a73d602a80f5aa06a76c.zip
fix to compile with all motif versions, mark stable
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-editors/nedit')
-rw-r--r--app-editors/nedit/ChangeLog5
-rw-r--r--app-editors/nedit/Manifest8
-rw-r--r--app-editors/nedit/nedit-5.5.ebuild9
3 files changed, 14 insertions, 8 deletions
diff --git a/app-editors/nedit/ChangeLog b/app-editors/nedit/ChangeLog
index 70ad85305175..5da499f03a8f 100644
--- a/app-editors/nedit/ChangeLog
+++ b/app-editors/nedit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/nedit
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.34 2005/01/01 13:32:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/ChangeLog,v 1.35 2005/02/19 12:20:02 lanius Exp $
+
+ 19 Feb 2005; Heinrich Wendel <lanius@gentoo.org> nedit-5.5.ebuild:
+ fix to compile with all motif versions, mark stable
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/app-editors/nedit/Manifest b/app-editors/nedit/Manifest
index bac54afe281f..7c866332dbaa 100644
--- a/app-editors/nedit/Manifest
+++ b/app-editors/nedit/Manifest
@@ -1,6 +1,6 @@
-MD5 30ebc3f4e476d3f3b5b3d3db2c3981fc ChangeLog 4877
+MD5 679d92bbb53d49d0f7a7c83c1f972c3f nedit-5.5.ebuild 1148
MD5 026faccb64c0f42b40e90e261249f6f1 nedit-5.4.ebuild 913
-MD5 b8921a913f203b8c04b1d57fc61cbad0 nedit-5.5.ebuild 973
-MD5 6cf9b886dea4a5ed42e0a83603218a9d files/digest-nedit-5.5 67
-MD5 4223c3125634eaecc7bd7556581cc29b files/digest-nedit-5.4 69
+MD5 b7e28bcc44d9cf5c0bfaefa692a17c64 ChangeLog 4997
MD5 f1de401822d203ac95aa0366234fb63a files/nedit-5.3-gentoo.diff 2629
+MD5 4223c3125634eaecc7bd7556581cc29b files/digest-nedit-5.4 69
+MD5 6cf9b886dea4a5ed42e0a83603218a9d files/digest-nedit-5.5 67
diff --git a/app-editors/nedit/nedit-5.5.ebuild b/app-editors/nedit/nedit-5.5.ebuild
index fa56912fecf2..c64f0eceb3b2 100644
--- a/app-editors/nedit/nedit-5.5.ebuild
+++ b/app-editors/nedit/nedit-5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5.ebuild,v 1.2 2005/01/01 13:32:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5.ebuild,v 1.3 2005/02/19 12:20:02 lanius Exp $
inherit gcc
@@ -10,16 +10,19 @@ SRC_URI="mirror://sourceforge/nedit/${P}-src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~amd64 ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~mips amd64 ~alpha"
IUSE="spell"
RDEPEND="spell? ( virtual/aspell-dict )
- virtual/x11"
+ x11-libs/openmotif"
DEPEND="${RDEPEND}
dev-util/yacc
x11-libs/openmotif"
src_compile() {
+ sed -i -e "s:-Wl,-Bstatic::" makefiles/Makefile.linux
+ sed -i -e "s:0.93.0:0.94.0:" util/check_lin_tif.c
+ sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" makefiles/Makefile.linux
sed -i -e 's:"/bin/csh":"/bin/sh":' source/preferences.c
make CC=$(gcc-getCC) linux || die
}