summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-07 02:02:32 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-07 02:02:32 +0000
commit962b2f3ad8532b7615def88fa20c4eb8e074cb9c (patch)
treed180fcfcf8a85f20427f0e0291321c2627319ba2 /app-editors/nano
parentFixups for vim7 (diff)
downloadhistorical-962b2f3ad8532b7615def88fa20c4eb8e074cb9c.tar.gz
historical-962b2f3ad8532b7615def88fa20c4eb8e074cb9c.tar.bz2
historical-962b2f3ad8532b7615def88fa20c4eb8e074cb9c.zip
some initial support for live cvs
Package-Manager: portage-2.0.53
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/Manifest12
-rw-r--r--app-editors/nano/nano-1.3.9.ebuild10
2 files changed, 20 insertions, 2 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 8e1fbf84a008..ed14c118f56d 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 5db4f611865d986b37a2d95404054e72 ChangeLog 8917
MD5 c3684059e73752ce1f114e768ecbaa2b files/1.3.4-nanobrack.patch 557
MD5 4cf6c77ed7c28d94c8de44d8318176c3 files/1.3.4-nomac.patch 511
@@ -19,4 +22,11 @@ MD5 27bac9f5ff88d92d3386c6854eb29ae4 nano-1.3.4.ebuild 1587
MD5 6f760844d541acb2dd4c92e22edc5759 nano-1.3.6.ebuild 1755
MD5 042d14bbc6965489bd62af12f5943519 nano-1.3.7.ebuild 1742
MD5 45fcb350931e56594b7bfcc19838f5c9 nano-1.3.8.ebuild 1880
-MD5 8fadf591c63d478f0c7ee4c58735c766 nano-1.3.9.ebuild 1635
+MD5 90ec8a0f8e7045596eaeace7ab5b7f6b nano-1.3.9.ebuild 1811
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDlkNzgIKl8Uu19MoRAlHIAJ4oQY5mL3kamyjqlgLjNKu1oJaYLQCdHLtY
+JCBE0rpeiVdBIWATd6RrEN0=
+=6nny
+-----END PGP SIGNATURE-----
diff --git a/app-editors/nano/nano-1.3.9.ebuild b/app-editors/nano/nano-1.3.9.ebuild
index abb0a8c24ab1..51cc4e103303 100644
--- a/app-editors/nano/nano-1.3.9.ebuild
+++ b/app-editors/nano/nano-1.3.9.ebuild
@@ -1,7 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.9.ebuild,v 1.1 2005/10/26 00:11:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.9.ebuild,v 1.2 2005/12/07 02:02:32 vapier Exp $
+#ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+#ECVS_USER="anoncvs"
+#ECVS_MODULE="nano"
+#inherit cvs
inherit eutils
MY_P=${PN}-${PV/_}
@@ -20,6 +24,10 @@ DEPEND=">=sys-libs/ncurses-5.2
PROVIDE="virtual/editor"
src_compile() {
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+
local myconf=""
use ncurses \
&& myconf="--without-slang" \