summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-03-02 00:11:15 +0000
committerBen de Groot <yngwin@gentoo.org>2010-03-02 00:11:15 +0000
commit99c1529a2271b81ee07f54a1dc2913d03965a7ce (patch)
tree5f20a266ece9b9b098e297801adf54821f1b530d /app-editors/juffed/juffed-0.8.ebuild
parentInitial import. (diff)
downloadhistorical-99c1529a2271b81ee07f54a1dc2913d03965a7ce.tar.gz
historical-99c1529a2271b81ee07f54a1dc2913d03965a7ce.tar.bz2
historical-99c1529a2271b81ee07f54a1dc2913d03965a7ce.zip
Version bump
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64
Diffstat (limited to 'app-editors/juffed/juffed-0.8.ebuild')
-rw-r--r--app-editors/juffed/juffed-0.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/juffed/juffed-0.8.ebuild b/app-editors/juffed/juffed-0.8.ebuild
new file mode 100644
index 000000000000..f80a88f3dbbd
--- /dev/null
+++ b/app-editors/juffed/juffed-0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/juffed-0.8.ebuild,v 1.1 2010/03/02 00:11:15 yngwin Exp $
+
+EAPI=2
+inherit multilib cmake-utils
+
+DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/JuffEd?content=59940"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/qscintilla
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${P/_/-}
+
+src_prepare() {
+ sed -i -e \
+ "s:\${CMAKE_INSTALL_PREFIX}/lib:\${CMAKE_INSTALL_PREFIX}/$(get_libdir):" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog README
+}