summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-11 12:09:28 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-11 12:09:28 +0000
commit54ce667bedf1c0ebe71c8db64b0a1f17c48715b1 (patch)
treee1da616a084844ad9a065468268747e9858f8653 /app-editors/jext
parentstable on amd64 wrt bug 96767 (diff)
downloadhistorical-54ce667bedf1c0ebe71c8db64b0a1f17c48715b1.tar.gz
historical-54ce667bedf1c0ebe71c8db64b0a1f17c48715b1.tar.bz2
historical-54ce667bedf1c0ebe71c8db64b0a1f17c48715b1.zip
cleanup
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-editors/jext')
-rw-r--r--app-editors/jext/Manifest14
-rw-r--r--app-editors/jext/files/jext-gentoo.sh4
-rw-r--r--app-editors/jext/jext-3.2_pre3.ebuild15
3 files changed, 21 insertions, 12 deletions
diff --git a/app-editors/jext/Manifest b/app-editors/jext/Manifest
index 399f3eac69c6..2b73c725b00a 100644
--- a/app-editors/jext/Manifest
+++ b/app-editors/jext/Manifest
@@ -1,5 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 d72b418bc32dc472d391cb598c5f6136 jext-3.2_pre3.ebuild 972
MD5 e72f711d9d2eaeb28dab6955cd6333e3 ChangeLog 1183
-MD5 9110bcae4cc4cd82d0613a86e9ace2e2 jext-3.2_pre3.ebuild 1069
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 fca68db8123a833b2fd6d85e60d9c39d files/jext-gentoo.sh 1309
MD5 88b56bf3784153591e9487638ded6dfe files/digest-jext-3.2_pre3 73
-MD5 ba19c214a7e8f8ccb21f74bc3b3b1626 files/jext-gentoo.sh 1351
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC0mGT/rLF9B432nYRAu5nAJ9EmOUD/sMrkd3/8/ZfZZ2lz9MtgACgg2WY
+nNCXs8HVWApN+yO38tvD2u4=
+=6onY
+-----END PGP SIGNATURE-----
diff --git a/app-editors/jext/files/jext-gentoo.sh b/app-editors/jext/files/jext-gentoo.sh
index bac53dfb37a4..ea5681724daf 100644
--- a/app-editors/jext/files/jext-gentoo.sh
+++ b/app-editors/jext/files/jext-gentoo.sh
@@ -36,7 +36,7 @@ fi
if ! [ -f ~/.jext/variables ]
then
echo "JEXT_HOME="/usr/share/jext/lib > ~/.jext/variables
- echo "JAVA_CMD="`java-config --java` >>~/.jext/variables
+ echo "JAVA_CMD=java" >>~/.jext/variables
fi
@@ -47,4 +47,4 @@ JAVA_OPT=`grep JAVA_OPT ~/.jext/variables | cut -f2 -d=`
# Launch JEXT
-exec "$JAVA_CMD" $JAVA_OPTS -Dpython=`java-config --classpath=jython` -classpath "`java-config --classpath=jython`:`java-config --classpath=jext`" org.jext.Jext "$@"
+exec "$JAVA_CMD" $JAVA_OPTS -Dpython=`java-config --classpath=jython` -classpath "`java-config --classpath=jython,jext`" org.jext.Jext "$@"
diff --git a/app-editors/jext/jext-3.2_pre3.ebuild b/app-editors/jext/jext-3.2_pre3.ebuild
index 0c10b1723a8c..3c0d12754b87 100644
--- a/app-editors/jext/jext-3.2_pre3.ebuild
+++ b/app-editors/jext/jext-3.2_pre3.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-3.2_pre3.ebuild,v 1.17 2005/01/01 13:28:43 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jext/jext-3.2_pre3.ebuild,v 1.18 2005/07/11 12:09:28 axxo Exp $
inherit java-pkg
-IUSE="doc"
-
DESCRIPTION="A cool and fully featured editor in Java"
HOMEPAGE="http://www.jext.org/"
MY_PV="${PV/_}"
@@ -13,18 +11,19 @@ SRC_URI="mirror://sourceforge/jext/${PN}-sources-${MY_PV}.tar.gz"
LICENSE="|| ( GPL-2 JPython )"
SLOT="0"
KEYWORDS="x86 ppc sparc"
+IUSE="doc"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4.1
+RDEPEND=">=virtual/jre-1.3
+ ${RDEPEND}
>=dev-java/jython-2.1-r5"
-RDEPEND=">=virtual/jre-1.3"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant-core"
S=${WORKDIR}/${PN}-sources-${MY_PV}
src_compile() {
cd ${S}/src
- sed -e s:'<property name="classpath" value="" />':"<property name='classpath' value='`java-config --classpath=jython`' />": -i build.xml
- local antflags="jar"
+ local antflags="jar -Dclasspath=$(java-pkg_getjars jython)"
use doc && antflags="${antflags} javadocs"
ant ${antflags} || die "compile failed"
}