summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2002-04-28 08:22:08 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2002-04-28 08:22:08 +0000
commite63768d8c7fd3f3179e122a62ec32ec509184245 (patch)
tree89fd10c15ff2e8c245a160b6e045e99eee77980a /app-editors/emacs
parent(all-arch) GPL flash plugin (diff)
downloadhistorical-e63768d8c7fd3f3179e122a62ec32ec509184245.tar.gz
historical-e63768d8c7fd3f3179e122a62ec32ec509184245.tar.bz2
historical-e63768d8c7fd3f3179e122a62ec32ec509184245.zip
PPC fix (bug 2104), new emacs version
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog10
-rw-r--r--app-editors/emacs/emacs-21.1-r4.ebuild35
-rw-r--r--app-editors/emacs/emacs-21.2.ebuild80
-rw-r--r--app-editors/emacs/files/digest-emacs-21.21
-rw-r--r--app-editors/emacs/files/emacs-21.1-gentoo.diff13
5 files changed, 136 insertions, 3 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index a2c12e6d47c7..6bbf4b797b41 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,12 +1,20 @@
# ChangeLog for app-editors/emacs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.2 2002/04/12 21:05:14 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.3 2002/04/28 08:22:08 pvdabeel Exp $
+*emacs-21.2 (28 Apr 2002)
+
+ 28 Apr 2002; pvdabeel <pvdabeel@gentoo.org>
+ Version bump
*emacs-21.1-r4 (11 Apr 2002)
+
11 Apr 2002; Spider <spider@gentoo.org>
Update libpng dependency
+ 28 Apr 2002; pvdabeel <pvdabeel@gentoo.org>
+ PPC fix (nocombreloc - fixes bug # 2104)
+
*emacs-21.1-r3 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/app-editors/emacs/emacs-21.1-r4.ebuild b/app-editors/emacs/emacs-21.1-r4.ebuild
index dbe09a34df9a..a6feeef0ff98 100644
--- a/app-editors/emacs/emacs-21.1-r4.ebuild
+++ b/app-editors/emacs/emacs-21.1-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Mikael Hallendal <micke@hallendal.net>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.1-r4.ebuild,v 1.2 2002/04/12 22:39:21 seemant Exp $
+# /space/gentoo/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.1-r4.ebuild,v 1.2 2002/04/12 22:39:21 seemant Exp
S=${WORKDIR}/${P}
@@ -26,9 +26,40 @@ DEPEND=">=sys-libs/ncurses-5.2
PROVIDE="virtual/emacs"
+src_unpack() {
+
+ # Resolves bug 2104 # ppc fix
+
+ SYSTEM_ARCH=`echo $ARCH |\
+ sed -e s/[i]*.86/i386/ -e s/sun4u/sparc64/ -e s/arm.*/arm/ -e s/sa110/arm/`
+ if [ -z "$SYSTEM_ARCH" ]
+ then
+ SYSTEM_ARCH=`uname -m |\
+ sed -e s/[i]*.86/i386/ -e s/sun4u/sparc64/ -e s/arm.*/arm/ -e s/sa110/arm/`
+ fi
+
+ cd ${WORKDIR}
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ case $SYSTEM_ARCH in
+ ppc)
+ cat ${FILESDIR}/emacs-21.1-gentoo.diff | patch -p1 || die
+ ;;
+ i386)
+ ;;
+ sparc64)
+ ;;
+ arm)
+ ;;
+ esac
+}
+
+
src_compile() {
local myconf
-
+
+
use nls \
|| myconf="${myconf} --disable-nls"
diff --git a/app-editors/emacs/emacs-21.2.ebuild b/app-editors/emacs/emacs-21.2.ebuild
new file mode 100644
index 000000000000..002af04c4f06
--- /dev/null
+++ b/app-editors/emacs/emacs-21.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Mikael Hallendal <micke@hallendal.net>
+# Modified by: Mark Yeun <mark@cs.columbia.edu>
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An incredibly powerful, extensible text editor"
+SRC_URI="ftp://ftp.codefactory.se/pub/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+
+# Never use the sandbox, it causes Emacs to segfault on startup
+SANDBOX_DISABLED="1"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ sys-libs/gdbm
+ X? ( virtual/x11
+ >=media-libs/libungif-4.1.0
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/tiff-3.5.5-r3
+ >=media-libs/libpng-1.2.1 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+
+PROVIDE="virtual/emacs"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ || myconf="${myconf} --disable-nls"
+
+ use X \
+ && myconf="${myconf} \
+ --with-x \
+ --with-xpm \
+ --with-jpeg \
+ --with-tiff \
+ --with-gif \
+ --with-png" \
+ || myconf="${myconf} --without-x"
+
+ use motif \
+ && myconf="${myconf} --with-x-toolkit=motif"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ cd ${D}/usr/share/info
+ rm dir
+
+ for i in *
+ do
+ mv ${i%.info} $i.info
+ done
+
+ dodoc BUGS ChangeLog README
+
+ # Gives a warning if it doesn't exist
+ dodir /usr/share/emacs/21.2/leim
+ touch ${D}/usr/share/emacs/21.2/leim/.keep
+}
diff --git a/app-editors/emacs/files/digest-emacs-21.2 b/app-editors/emacs/files/digest-emacs-21.2
new file mode 100644
index 000000000000..9ec99656013d
--- /dev/null
+++ b/app-editors/emacs/files/digest-emacs-21.2
@@ -0,0 +1 @@
+MD5 f4b58e5c2d923fc92495e0c2f167c5db emacs-21.2.tar.gz 20288222
diff --git a/app-editors/emacs/files/emacs-21.1-gentoo.diff b/app-editors/emacs/files/emacs-21.1-gentoo.diff
new file mode 100644
index 000000000000..319a96607c17
--- /dev/null
+++ b/app-editors/emacs/files/emacs-21.1-gentoo.diff
@@ -0,0 +1,13 @@
+--- emacs-21.1/src/m/macppc.h.~1.6.~ Mon Oct 1 10:57:25 2001
++++ emacs-21.1/src/m/macppc.h Mon Oct 22 21:02:28 2001
+@@ -96,6 +96,10 @@
+ #ifdef LINUX
+ #define LINKER $(CC) -nostdlib
+ #define LD_SWITCH_MACHINE -Xlinker -m -Xlinker elf32ppc
++/* s/gnu-linux.h defines this to `-z nocombreloc' which does not work here
++ because prefix-args is not used. */
++#undef LD_SWITCH_SYSTEM_TEMACS
++#define LD_SWITCH_MACHINE_TEMACS -Xlinker -znocombreloc
+ #endif
+
+ #if 0 /* This breaks things on PPC GNU/Linux ecept for Yellowdog,