summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-12 13:39:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-12 13:39:26 +0000
commitb25d93d7c04acd8f6f2e1e6fdd2ffc5d11c53257 (patch)
tree407369c1ce5c53d77411901104ba3b2fe18071e9 /app-editors/bluefish
parentAdded USE dependent nls compilation (diff)
downloadhistorical-b25d93d7c04acd8f6f2e1e6fdd2ffc5d11c53257.tar.gz
historical-b25d93d7c04acd8f6f2e1e6fdd2ffc5d11c53257.tar.bz2
historical-b25d93d7c04acd8f6f2e1e6fdd2ffc5d11c53257.zip
Added USE dependent nls compilation
Diffstat (limited to 'app-editors/bluefish')
-rw-r--r--app-editors/bluefish/ChangeLog8
-rw-r--r--app-editors/bluefish/bluefish-0.7-r1.ebuild45
-rw-r--r--app-editors/bluefish/files/digest-bluefish-0.7-r11
3 files changed, 53 insertions, 1 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index 942da270c818..b435d38f4bab 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/bluefish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.1 2002/02/01 21:53:00 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.2 2002/03/12 13:39:26 seemant Exp $
+
+*bluefish-0.7-r1 (12 Mar 2002)
+
+ 12 Mar 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog :
+
+ Updated the copyright info, and added USE dependent nls compilation.
*bluefish-0.7 (1 Feb 2002)
diff --git a/app-editors/bluefish/bluefish-0.7-r1.ebuild b/app-editors/bluefish/bluefish-0.7-r1.ebuild
new file mode 100644
index 000000000000..d9929b179978
--- /dev/null
+++ b/app-editors/bluefish/bluefish-0.7-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.7-r1.ebuild,v 1.1 2002/03/12 13:39:26 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use perl && myconf="${myconf} --with-perl"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --with-autocomplet \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ makefiles=`find . -name Makefile`
+ for f in $makefiles; do
+ mv $f $f.orig
+ sed -e 's#$(prefix)#$(DESTDIR)$(prefix)#' \
+ -e 's#${prefix}#$(DESTDIR)${prefix}#' \
+ -e 's#/usr/share/pixmaps#$(DESTDIR)$(prefix)/share/pixmaps#' \
+ $f.orig > $f
+ done
+
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING INSTALL NEWS README TODO
+ mv manual ${D}usr/share/doc/${PF}
+}
diff --git a/app-editors/bluefish/files/digest-bluefish-0.7-r1 b/app-editors/bluefish/files/digest-bluefish-0.7-r1
new file mode 100644
index 000000000000..2f86ca5aa08d
--- /dev/null
+++ b/app-editors/bluefish/files/digest-bluefish-0.7-r1
@@ -0,0 +1 @@
+MD5 f3085245839edb278b77f6c3619ed396 bluefish-0.7.tar.bz2 1686219