summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-11-10 12:34:17 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-11-10 12:34:17 +0000
commit18ade31d64770b5b97ac866ea58735c78134d04c (patch)
tree3901b8c6a0d0e3dc1936da3fefe16117518fd8c6 /app-crypt/mcrypt/mcrypt-2.6.7.ebuild
parentStable on ppc wrt bug 198013 (diff)
downloadhistorical-18ade31d64770b5b97ac866ea58735c78134d04c.tar.gz
historical-18ade31d64770b5b97ac866ea58735c78134d04c.tar.bz2
historical-18ade31d64770b5b97ac866ea58735c78134d04c.zip
Version bump
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'app-crypt/mcrypt/mcrypt-2.6.7.ebuild')
-rw-r--r--app-crypt/mcrypt/mcrypt-2.6.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/mcrypt/mcrypt-2.6.7.ebuild b/app-crypt/mcrypt/mcrypt-2.6.7.ebuild
new file mode 100644
index 000000000000..a8a2bad50cbe
--- /dev/null
+++ b/app-crypt/mcrypt/mcrypt-2.6.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/mcrypt-2.6.7.ebuild,v 1.1 2007/11/10 12:34:16 alonbl Exp $
+
+inherit eutils
+
+DESCRIPTION="replacement of the old unix crypt(1)"
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=dev-libs/libmcrypt-2.5.8
+ >=app-crypt/mhash-0.9.9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-qa.patch"
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "configure error"
+ emake || die "make error"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install error"
+ dodoc README NEWS AUTHORS THANKS TODO
+}